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Gimp Open source image-editing
software you can get your teeth into

Gimp: Leopard

A Leopard-based desktop starts with professionally styled icons. This month
Michael J Hammel shows how Gimp makes icon design a breeze.

Evolution

) Here’s what we’re aiming for: a series of icons created
in Gimp, displayed on my desktop in SimDock.

than the JPEGs your digital camera typically produces. Being
able to work with RAW, then, means a better end product.

At the other end of the image spectrum are desktop
graphics — specifically icons. An icon is a small image used to
represent a program, file, device or data accessible by a user.
Icons can clutter the desktop, but utilities such as the Avant
Window Navigator and SimDock enable you to organise your
0 ver the past year of tutorials we've worked on rather program icons in a Mac-like dock. These docks are like KDE

large-scale projects (by large | mean in the sense of or Gnome panels but with a 3D appearance. SimDock, in

canvas size). If you've been following along, you'll particular, is designed to look just like the dock in Mac OS X.
have learned how to create a universe, destroy a city and Docks are essentially icon managers that handle resizing
Our create your own iPod advert. Each of these projects was automatically. SimDock, for example, initially displays icons
expert suited to small prints, with processes that could easily scale scaled to a very small size and then zooms them to a larger
Michael J up. By this time, it should be clear that Gimp is an excellent size as you mouse over them. Users can specify the zoom
Hammel graphic design tool for print projects. amount in the settings, and by using a large zoom factor,
is a contributor to But print projects are only a small sample of what Gimp larger icons can be used.
;T]edfg:g&fé?c;f can do. This multipurpose toolbox is suited to many design Which is where Gimp comes in. The use of large icons
three books on the projects — working with digital photographs, for example. I've makes it much easier to create the images they're based on,
;?sbljaetcetétmg'll}::mg not touched often on photography simply because I'm not because the Gimp project can work with a larger canvas. It's
Artist's Guide to much of a photographer — | don't even own a digital camera—  very different to, and easier than, working with Gnome panel
Gimp Effects. but despite my shortcomings, Gimp is heavily used in image launchers, for example, where all displayed icons are the
processing fields and supports multiple RAW file formats same size and usually no larger than about 32 pixels wide by
(through the ufraw plugin). This is useful to photographers 32 pixels tall. SimDock enables the icon to be created at a
because RAW image files are of a significantly better quality much larger size, and will handle scaling automatically.

This month we'll visit the icon world as | walk you through

e the design of icons suitable for use with SimDock and other
PI'O] eCt resources desktop docks. The tutorial is intended for use with Gimp 2.6

and can be performed even by beginner users of Gimp — onl
This tutorial is based on Richard Carpenter’s excellent ‘Carbon Style Icon’ tutorial . P y . g . G p_ y
. basic knowledge of the software is required, such as using
for Photoshop from HV-Designs.

» http://hv-designs.co.uk/2009/02/10/carbon-style-icon. layers and understanding the default layout of the toolbox. No
» SimDock: http:/ /simdock.sourceforge.net. outside stock images are required. Advanced users can
» Avant Window Navigator: https://launchpad.net/awn. complete this tutorial in less than an hour, but beginners will

take a little longer.

Last month \We helped you create your own Frank Miller-inspired designs.
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style icons

Create an icon

Gimp Tutorial

Set the colours

Open a new, 640x480 image window (File >
ew). Reset the Foreground and Background
colours by typing D in the image window. Click
on the Background Colour Swatch in the
Toolbox to open the Change Background
Colour dialog. Next, set the R, G and B values
10121, 121, and 121 respectively. Close the
colour dialog. The black and grey colours will
then be used as the background gradient for
the finished icon.

I Create check pattern

Open a new image window scaled to 16x16
pixels. In the window that opens, hit the + key
10 times to zoom in. Add vertical guides (Image
> Guides > New Guide) at 4, 8 and 12 pixels and
horizontal guides at 4, 8 and 12 pixels. This
divides the window into 12 blocks. Set the
Foreground colour R, G, Bto 103,103, and 103
respectively. Use the Rectangle selection tool
to outline blocks, and then fill alternating blocks
with the foreground colour.

B Rectangular selection

Add a transparent layer (Layer > New) and
name it ‘lcon Background'. Choose the
Rectangle selection tool from the Toolbox. In
the Tool Options dialog, click on the Rounded
Rectangle and set its Radius to 25. Draw an
initial selection in the image window. In the Tool
Options dialog set the Size to 274x240 and the
Position to 183x120. This is the size of the icon,
plus some transparent padding.

Gradient fill

Drag a guide from the left to the middle of the
image. Choose the Blend Fill tool and set the
Mode to Normal, Opacity to 100%, Gradient to
‘FG to BG' with Reverse checked, and the
Shape to Linear. Drag from the top of the
selection to the bottom, along the guide. Now
clear the selection (Select > None) and add a
Drop Shadow (Filters > Light and Shadow >
Drop Shadow) offset by 3 pixels and blurred by
5 pixels.

Change the Foreground RGB to 67, 67, and 67
respectively, then select and fill blocks 1/2,1/4,
2/3,3/2,3/4,and 4/1. Change the Foreground
RGB to 141, 141, and 141 respectively and fill in
blocks 2/1and 4/3. Save this file as Docklcon.
pat in your $SHOME/.gimp-2.6/patterns
directory, then open the Patterns dialog
(Windows > Dockable Dialogs > Patterns) and
then click on the Refresh button to add the new
pattern to the list of patterns. When you've
finished, close the Docklcon.pat window.

B Add the pattern

Add a transparent layer to the icon image
window and name it Pattern. Click on the Icon
Background layer in the Layers dialog and
create a selection of the icon (Layer >
Transparency > Alpha to Selection). Click on
the Pattern layer to make it active. In the
Patterns dialog (Windows > Dockable Dialogs
> Patterns), drag the ‘Dock Icon BG' pattern
into the image window to fill the selection with
the new pattern. Your icon should now have a
checkered background. »

If you missed last issue Call 08/0 837 4/73 or +44 1858 438795.
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Tutorial Gimp

*Dockicon.xcf-3.0 (RGB, 4 layers) 640x480 - GIMP

Mask the pattern

Add a White Layer Mask to the Pattern layer. Type D in the image
window, choose the Blend tool, then set the Opacity to 75% and the
Shape to Radial. Drag from the top of the icon to the middle. Switch the
Shape to Linear and the Mode to Multiply, then drag from the middle of
the icon to the bottom and again from the top to the middle of the icon.
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B Front shelf

Add a transparent layer at the top of the Layer stack called Front Shelf.
Add vertical guides at 173, 183, 458 and 468, and horizontal guides at
290, 300 and 340, then draw a rectangular selection from the guides
intersecting at 173/300 to the intersection of 468/340. Set the
Foreground colour to a medium grey.

@ Right shelf

Slide the image window to the right to view the right edge of the front
shelf. Use the Paths tool and click on the guides intersecting at
458/290, 468/300 and 458/300. Click on the Selection from Path
button in the Tool Options dialog. Set the foreground colour to a dark
grey, drag the colour into the selection, then clear the selection.

[pe & ][50 ]| pattemmask o we)

B Another mask

Apply the layer mask, clear the selection, then add another White
Layer Mask to the Pattern layer. Use the Paths tool from the Toolbox
and place anchors to make a rectangle around the upper half of the
icon, then move the anchor handles to create a wave effect along the
bottom edge of the path. Now invert the selection and fill it with black.

[= *Docklcon.xcf-3.0 (RGB, 5 layers) 640x480 - GIMP
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Left shelf

Zoom in to the left of the shelf. Choose the Paths tool and set Edit
mode to Design. Select the guides at 173/300, 183/290 and 183/300
and click Selection From Path in Tool Options. Set the foreground
colour to a lighter grey, with R, G and B values of 203. Drag the
foreground colour into the selection.
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B Application colours

Reset the foreground and background colours, then click on the
foreground colour swatch and set the RGB values to 74, 164, and 75
respectively. Now change the background colour to RGB values of 28,
130 and 29 respectively. Close the colour dialog. The green shades will
be used as the gradient for the application icon.

Never miss another issue Subscribe to the #1 source for Linux on pl02.
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Ellipse Select

*Dockicon.xcf-1.0 (RGB, 6 layers) 640x480 - GIMP
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Application sphere

Add atransparent layer at the top of the layer stack and name it Sphere.

Choose the Ellipse selection tool and create a circular selectionin the
image window, centered on the icon and above the shelf. Choose the

Blend tool and set a Radial shape and an FG to BG gradient in the Tool
Options. Drag from the centre to the edge of the selection.

0 *Docklc

icf-1.0 (RGB, 7 layers) 640x430 - GIMP
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71 Adaptive supersampling

Lower highlight mask

Add a White Layer Mask to the Lower Highlight layer. Reset the
Foreground and Background. Choose the Blend tool and set a Linear
shape and FG to Transparent gradient. Drag in the image window from
the top of the icon to the bottom. Add a transparent layer at the top of
the layer stack and name it Upper Highlight.

Highlight mask (11.3 ME)

Application ID

Choose the Text tool. Select a Font and set the Font size to 160 and the
colour to White. Type an upper-case G (for Gimp) and centre it over the
sphere with the Move tool. Change the Lower Highlight layer's mode to
Overlay. In a smaller font and in white, type the word “Gimp” and
position it over the shelf, then add a drop shadow.

Gimp Tutorial

(SE16J

0 (RGB, 7 layers) 630x480 - GIMP.

Shrink selection by
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Shrink from image border
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2 Lower highlight

Add a transparent layer at the top of the Layer stack and name it Lower
Highlight. Shrink the selection by 2 pixels, then reset and invert the
foreground and background colours. Use the Blend tool with a Radial
shape and FG to Transparent gradient with Reverse button set and
drag from the centre to the edge of the selection.

0 *Dockicon.xcf-1.0 (RGB, B layers) 640x480 - GIMP
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Upper highlight

Choose the Scale tool and set the Transform to Selection. Drag in the
image window to scale the selection to 1/2 its size and about 3/5 the
width. Reset and invert the swatches in the Toolbox, then use the Blend
tool with a Linear shape and FG to Transparent gradient and drag from
the top of the selection to the middle.

xcf-1.0 (RGB, 11 layers) 640x480 - GIMP
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B GIMP.

Application name

Save this image as your source file for other icons. To save the icon
itself, delete the white background layer and use the Crop tool to crop
the image leaving just a small amount of transparent space around the
icon. Save the image as Gimplcon.png. Use this file as the icon file
when adding a Launcher to the SimDock.

Next month In a fest of retro-futurism we're blending cubism with pixellation.

www.tuxradar.com
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