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Introduction

men creative juggernaut Adobe announced that it had acquired
Macromedia in 2006, long-time Macromedia users wondered what it
would mean for their preferred suite of Web development tools, Studio.
Would Photoshop’s superior power and depth spell the end of Fireworks,
despite the fact that Fireworks has more user-friendly image-optimizing

and -exporting capabilities? Would FreeHand survive? Would ColdFusion get
lost in the shuffle? For those of us who always used Photoshop and Acrobat as
well as the applications in the Studio suite, the question was, How long do we
have to wait for better integration of Adobe’s software with Dreamweaver,
Flash, and Fireworks? With Adobe Creative Suite 3 Web Premium, we have
our answers, and the future looks bright for Web developers!

About This Book

Adobe Creative Suite 3 Web Premium All-in-One Desk Reference For Dummies
(we know, it’s a mouthful) is designed to be a hands-on, easy-to-understand
guide to the main features in all the CS3 Web development products. The no-
nonsense approach will help you begin to build Web sites by covering the
basics in a clear and concise fashion. The way we see it, you've got things to
do, and reading a book, even a clever one, takes up valuable time. The faster
we can help you do something or answer a question, the better.

How to Use This Book

You can use this book in a few different ways:

4+ As areference: If you already have a Web site and use Creative Suite 3,
this book can be a handy refresher for that thing you couldn’t quite
remember how to do. Whether it’s finding out how to export graphics to
Flash from Illustrator, or how to add a behavior to a button graphic in
Fireworks, you can use this book to fill in those gaps that we all have.. ..
especially as we get older.

4+ To guide you through building a Web site: Several authors contributed
to the creation of this book. All of us have a wealth of experience in the
process of building Web sites. In this book, we’ve tried to impart as
much of our collective knowledge about the processes and pitfalls of
building Web sites using these tools as we can.
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Three Presumptuous Assumptions

4+ To find out more about the tools: In this All-in-One Desk Reference, each
minibook has a limited number of pages to cover a product or topic,
which means that we get right to the point and make the topics covered
easy to understand. We believe that this approach makes figuring out
these products easier.

Three Presumptuous Assumptions

Before you dive into the book, we thought we should give you some advance
warning of our expectations. We know, you’re the audience, so we shouldn’t
assume anything! But, just so you know where we’re coming from, here are
our three basic assumptions about you, the reader:

4+ You're in a hurry. Frankly, if you wanted a more in-depth book, you'd
have picked up a regular For Dummies book on one or all of these prod-
ucts. Hence the no-nonsense, get-it-done, and keep-on-moving approach
that you find inside this book.

4+ You know something about Web development. This isn’t a book in which
we spend a lot of time talking about HTML and how it works. So you
won't find a chapter anywhere in this book titled, “What the Internet Is
and How It Works.”

4+ You’'ll experiment on your own. The approach here is to give you quick,
useful examples of how things work across all these products. In some
cases, the examples can be fairly sophisticated. In most cases, though,
the book presents the basics. Our hope is that you'll take those basic
examples and build your own, more complex ones on top of that,
according to the complexity of your site.

Macintosh versus Windows

Adobe Creative Suite 3 is both a Windows and a Macintosh product. In this
book, you see us use the Windows commands, and most of the figures show
Windows XP.

In general, you can convert between Windows (PC) and Macintosh key com-
mands by using the following equivalencies:

4+ The Ctrl key on a PC is equivalent to the Command (88) key on a Mac.

4+ The Alt key on a PC is equivalent to the Option key on a Mac.

4+ The Enter key on a PC is equivalent to the Return key on a Mac.

When the Mac key command equivalents don’t follow the rules just
described, we note the exceptions where they occur throughout the text.
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The Mac operating system uses several of the F keys to operate various
elements such as hiding windows, opening the Dock, closing or opening
windows and applications, and so on. To override the Mac OS defaults and
enable an application’s default key commands, open System Preferences

(in the Dock) and then open Keyboard & Mouse. Select Keyboard Shortcuts
from the three menu choices and scroll through the various shortcuts. If you
wish to change F12 from opening or closing the Dashboard, for example,
select it and click the plus sign button at the bottom of the window. Doing so
brings up a new window headed by an Application menu. Select the applica-
tion in which you wish to use F12, give it a name in the Menu Title box, and
click the F12 in the Keyboard Shortcut window. Then, pressing F12 will do
whatever the selected application wants to do instead of opening the
Dashboard. Other applications will continue to use F12 as defaulted by the
operating system, but you can change them just as easily.

How This Book Is Organized

As with all the All-in-One Desk References For Dummies, this book’s chapters
are organized into minibooks. Most of the minibooks revolve around prod-
ucts, but one is geared toward the Web development process. The following
sections describe each minibook in more detail.

Book 1: Dreamweaver CS3

Dreamweaver CS3 is the crux of any Web development effort with Creative
Suite 3, so naturally, this is a good place to start. In this minibook, you get a
hands-on look at how you can use Dreamweaver to create and manage your
Web sites.

Book 11: Photoshop CS3

Long the premier software for 2-D bitmap image creation and manipulation,
Photoshop is the gold standard of Web design tools. This minibook aims to
help you achieve good imagery, starting with basics that even advanced
users may have missed along the way. We show you how to color correct
images like a pro and use tools to keep images at the right resolution and
size, no matter whether the image is intended for print or for the Web.

Book 11I: Fireworks CS3

Thanks to Photoshop’s inclusion in CS3, Fireworks can concentrate on what
it does best: act as a conduit between Photoshop/Illustrator in the design
phase and Flash/Dreamweaver in the implementation phase of Web develop-
ment. This minibook shows you how to work with bitmap and vector images,
and how to optimize and export those images for the Web.
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Conventions Used in This Book

Book 1U: llustrator CS3

Book IV starts with the fundamentals of Adobe Illustrator CS3 to put you on
your way to creating useful and interesting illustrations. Check out this mini-
book to discover how to take advantage of features that have been around
for many versions of Illustrator, such as the Pen tool, as well as new and
exciting advances, such as the Live Trace feature. See how to take advantage
of the Appearance palette and save time by creating graphics styles, tem-
plates, and symbols. Pick up hard-to-find keyboard shortcuts that can help
reduce the time spent mousing around for menu items and tools.

Book U: Flash CS3

Adobe Flash CS3 delivers animation, sound, video, and interactivity to the
Web as no other product ever has. If you've ever wanted to find out how
to use this tool to add some new zip to your Web site, this is the minibook
for you!

Book Ul: Contribute CS3

Designed as a collaborative tool that turns your hard development work into
an easy interface for nontechies to update and publish content to the Web,
Contribute puts the power of maintaining Web sites in the hands of the
people you work with. In this minibook, you find everything you need to
know to get you and your collaborators up and running with Contribute in
no time flat.

Book VII: Acrobat CS3

Adobe Acrobat CS3 is a powerful viewing and editing application that allows
you to share documents with colleagues, clients, and production personnel
such as printers and Web page designers. Book VII shows you how you can
save time and money previously spent on couriers and overnight shipping
by taking advantage of annotation capabilities. Discover features that even
advanced users may have missed along the way, and see how you can feel
comfortable about using PDF as a file format of choice.

Conventions Used in This Book

We use some conventions throughout this book that merit a little explana-
tion. When you see a phrase such as “choose Filec>Save,” it means to click
through the sequence of menu commands. In this example, those commands
are File followed by Save.
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Whenever we tell you to click something (most likely it’s a button or an icon),
you use the left mouse button and click just once. On those rare occasions
when clicking twice is required to get the job done, we tell you to double-
click, or, if you need to use the right mouse button, we tell you to right-click.

To select an item, you either highlight it or click in a check box or radio
button, depending on the item. Text that we tell you to enter (that is, type)
into the program, such as in a text box, appears in boldface type. Web site
addresses and on-screen messages show up in monofont type. And finally,
to avoid confusion, we use title-style capitalization for option names and
links, even when the program doesn’t.

Icons Used in This Book
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Along the way, when there’s something of interest to point out, we toss in
one of the icons you see in the left margin. When you see one, slow down for
a moment to check it out to see what’s up!

If there’s a way to make something easier, or a more commonly accepted
way of doing something, we tell you about it. This is the icon to look for!

When we really want to reinforce something, we throw in a Remember icon.

Pitfall ahead! That’s what this icon is all about. If something could cause
trouble, we let you know.

Because we love technology, you have to forgive us for geeking out every
now and then. When we do, though, we let you know with this icon.

This icon highlights new features in the products that make up the Adobe
Creative Suite 3 Web Premium package.

You can use the Adobe Creative Suite 3 programs together in many different
and helpful ways to make your workflow more efficient. In the Photoshop,
lllustrator, and Acrobat minibooks, we use this icon when we explain how you
can implement integration wherever it’s pertinent to the discussion at hand.
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Where to Go from Here

If you've read this far, then you may actually be a candidate for reading this
book from cover to cover! From here, we suggest you dive right in to whatever
section you’re most interested in. Remember, all these minibooks are self-
contained and don’t require you to read the others. So have at it. It’s buffet
time, and your plate needs fillin’ up!
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Chapter 1: Introduction
to Dreamweaver CS3

In This Chapter

+ Exploring the Dreamweaver CS3 interface

v Choosing between Design view and Code view

1 Choosing among Standard, Expanded Table, and Layout modes
v+~ Examining your site with the Files panel

+ Exploring toolbar buttons

v+~ Using panels and inspectors

1 Getting help

If you're looking for a Web design tool that’s both easy enough for beginners
and sophisticated enough for Web design gurus, you’'ve come to the right
place. Dreamweaver CS3 from Adobe is a powerful program that enables you
to create almost any type of Web page. This chapter covers the Dreamweaver
basics and introduces you to some of the program’s essential tools.

Dreamweaver is the industry standard for Web site design and production.
Whether you're interested in creating a site for fun, such as an online photo
album or a site devoted to one of your hobbies, or for business, such as an
online store, Dreamweaver’s flexible interface provides simultaneous graphi-
cal and HTML editing. In other words, using Dreamweaver, you can not only
lay out pages like an artist but also fine-tune the associated code as a pro-
grammer would. Additionally, Dreamweaver’s built-in FTP features enable
you to upload your site to the Web in a snap so that you can share your
masterpieces with the world.

Activating Dreamweaver CS3

When you launch Dreamweaver for the first time, the Adobe Dreamweaver
CS3 Grace Period window appears. Product activation is required, but if
you'’re in a hurry to get to work on your site right away, you can select the
Activate Later option and click the Next button. You have a 30-day grace
period during which you can continue to select the Activate Later option
every time you launch Dreamweaver. When the 30 days are up, though, you
won’t be able to use the application until you activate it.
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Exploring the Dreamweaver CS3 Interface

Exploring the Dreamweaver CS3 Interface
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With Dreamweaver CS3, Adobe continues the tradition of allowing you to
choose from two versions of the Dreamweaver workspace — Designer style
and Coder style — that debuted with Dreamweaver MX 2004. This selection
allows you, the developer, to work in an environment that is best suited to
your personal development taste: one geared toward WYSIWYG (What You
See Is What You Get) development and one that is more code oriented.

Selecting a workspace

Dreamweaver offers two workspace options:

4+ Designer: The WYSIWYG (What You See Is What You Get) interface,
which shows the page you are working on much like it would be in a
Web browser. This style is more appropriate for Web design novices
working on basic HTML pages.

4 Coder: The style that shows the page you are working on as an editable
text document, which is appropriate for experienced coders and for
pages on which you’re editing CSS (Cascading Style Sheets), XML, or
dynamic code such as CFML (ColdFusion Markup Language) or ASP
(Active Server Pages).

You can switch between the two styles, or even combine them, at the click of
a button. See the “Introducing the Document Window” section, later in this
chapter, for details. You might even consider switching back and forth
between modes as you're learning HTML because doing so is a good way to
see the underlying HTML as it’s being generated.

Introducing the Start page

After you've selected a workspace, when you launch Dreamweaver by
double-clicking its icon on the desktop or by selecting it from the Windows
Start menu, you'll see a Start page, as shown in Figure 1-1. The Start page
allows you to perform the following tasks with a single click of your mouse:

4+ Open pages you've recently edited: Simply click the filename of the
page you want to open.

4+ Create a new page in one of eight formats: Simply click the type of
page you want to create, from basic HTML to ColdFusion (CFML) to CSS
(Cascading Style Sheets). You can also click More to view additional
formats.



A\

Figure 1-1:
The Start
page gives
you one-
click access
to a variety
of options.

Exploring the Dreamweaver CS3 Interface 11

4+ Create a new Dreamweaver Site: Click the Dreamweaver Site icon (in
the Create New column) to open the Site Definition Wizard, which guides
you through the process of setting up the directory location, FTP infor-
mation, server technology (if applicable), and more for your Web site. A
“site” in Dreamweaver is a collection of Web pages, images, and tools
that allow you to more easily manage your Web sites. See Book I,
Chapter 3 for more in-depth details on Dreamweaver Sites.

4 Create a new page based on Dreamweaver’s built-in samples: Click an
option in the Create from Samples column to open the New Document
dialog box and choose from the preset formatting options for that type
of page.

The Start page also gives you fast access to a quick tour and set of tutorials
for Dreamweaver, and to Adobe’s Dreamweaver Exchange page, where you
can find lots of nifty objects that extend Dreamweaver’s capabilities.

If you find the Start page incompatible with your working methods, you can
prevent it from appearing in the future by selecting the Don’t Show Again
check box at the lower-left corner of the page.
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Introducing the Document Window

Figure 1-2:
Design view
approximates
what your
page looks
like in a Web
browser.

Your primary workspace in Dreamweaver is the Document window, which
appears automatically when you open a page in Dreamweaver. In the
Document window, you construct your individual Web pages using panels
and dialog boxes to format your work. The three primary views in
Dreamweaver are as follows:

4+ Design view: The graphical view of your document, as shown in
Figure 1-2. You can select this view by choosing View=>Design or simply
clicking the Design button near the top left of the Document window.

4+ Code view: This view shows the underlying code of your document.
You can select this view by choosing View=>Code or clicking the Code
button.

4+ Split view: As you may expect, this is a split-screen view that includes
both the Code and Design windows. You can select this view by choos-
ing View=>Code and Design or clicking the Split button.
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Choosing among Standard, Expanded Table, and Layout Modes '3

You can toggle between these views easily at any time by clicking their cor- Book |
responding buttons at the top left of the Document window. Chapter 1

When you have several documents open in a site, you can select which doc-
ument you want to work on by clicking the document’s name at the top of
the Dreamweaver Document window. You can also click the Site tab in the
Files panel to work on an entire site.
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The Insert bar sits directly underneath Dreamweaver’s main menu. It gives
you quick access to seven tabs you can use to insert everything from tables
to Flash movies to form elements in your page. To select one of the seven
categories, click the Insert bar’s name (Common, Layout, and so on) and
choose a new category from the drop-down list.

£S9 JaAeamuweai(

Choosing among Standard, Expanded
Table, and Layout Modes

When viewing your document in either Split or Design view, you can view
content using the Standard mode, the Expanded Table mode, or the Layout
mode. The Standard mode is the default. (Figure 1-2, in the previous section,
shows a page in Standard mode in the Design view, with the Insert bar set to
Common.) The Expanded Table mode makes it easier for you to select tables
and cells (though if you want to resize the table or row or column, you need
to do so in Standard mode). The Expanded Table mode is most useful for
editing existing tables. The Layout mode provides a simpler interface for
drawing and editing tables and table cells.

Two special tools are available only when working in Layout mode: the Draw
Layout Cell button and the Draw Layout Table button. A table created with
the Draw Layout Table tool is shown in Figure 1-3. Both of these tools can
help you generate tables or table cells quickly and easily in Dreamweaver,
and are described in more detail in Book I, Chapter 2.

To change to the Layout mode, select the Layout Insert bar at the top left of
the Document window and click the Layout Mode button, or choose Viewr>
Table Moder>Layout Mode, or press Alt+F6. When you’re in Layout mode,
press Alt+F6 (Opt+F6 on a Mac) to return to Standard mode.

To change to Expanded Table mode, select the Layout Insert bar at the top
left of the Document window and click the Expanded Table Mode button at
the top of the Document window, or choose Viewr>Table Moder>Expanded
Table Mode, or press F6. When you’re in Expanded Table mode, press F6 or
click the Expanded Table Mode button to return to Standard mode. Note:
None of the table modes is available in Code view.



14

=T Adoba Dreamweaver CS3 [Untiad 1 (RITHLY] B
File Edit View Insert Modify Text Commands Site Window Help
winsert  Common Layout  Forss | Data | Sery | Text | Favorites 5 [l ress
Sarnderd | Exparnded fH|es @8 m EO-aE e
b Taxg Trespnctor
Unided-1= - @x | ks =
o] ok | <] op | [ Dstign | Tl Unitied Dt i @ | & B B | o 5 heckroge '_"" i . =
Lavouk mode [eutt] B3 By Bowlateria re | [Locl view ||
. B m e, e e e s R m ARG r08D
E Local tiles size[i~
Ey e Faels Bowdabesi. . F
® B3 mayes F
# B3 Liwery F
# B3 meda F
© D sprysssats I
= B3 Temclates [
T mdievedPa.,  IHBL
== about-narls him HKBH
= aconsscebes.chm IKE 8
B bowder ol BB S
= bowingbsbdm 1B A
B il B S
= dothing.cfm A
B costyles.css aue
S dwbest hem A
&4 [T - P home.suf B
= hatspot hemd B H
= rdex.dm IBA
. = ek KEH
Flglll'e 1-3: = e 318 )
i = prodtemgFwbem 11K |
Atable w; . & |&Q () 1K { 1 500 = products.cm e Al
. v Praperties [ = products him KB F
drawn in = . = —— - = 2 podetwhm
D Lovouttable | wth Efeed (44 | et 2w Celesd |0 B Gl v] 2 - Pt e
Layout (Chdwkrtreteh w ] Cebsonce 0 =| S sorywidgetD0Lbl KB F
= skarsml KB HM™
mode. < >
o W 1 ical Rems selectend Lotalion 1 [Log. .|

Examining Your Web Site with the Files Panel

Examining Your Web Site with the Files Panel

Dreamweaver offers Web developers the opportunity to work on individual
files that make up a Web site, as well as to manage their entire Web site, all
through the Dreamweaver interface. This concept is called, not surprisingly,
a Site; to avoid confusion, we call them Dreamweaver Sites. Dreamweaver
Sites can include the following elements:

4+ HTML, CFM, ASP, and other files that make up the code of the site

4+ Graphics, such as GIF and JPEG files

4 Documents, such as PDF and DOC files

4+ Directories (folders that might contain any of the above)
Dreamweaver Sites are initially viewable within the Files panel (which is open
by default; if the Files panel is not open, you can open it by pressing F8).
To expand the Files panel so that it fills your screen, or to collapse the panel

back to panel size, click the Expand/Collapse button (the icon of the two-
row, two-column box with an arrow in the middle, at the right of the panel).
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The Web site management tools for Dreamweaver Sites are designed to give Book |
you total control over the way in which your Web site is built and main- Chapter 1
tained from your local computer. The key features of the Dreamweaver Site

tools include o _
g2
4+ Asset management tools that help you manage all the files that make up g =4
your site. For example, these tools keep track of all your files and the & E
links between files. Anytime you move a file, the tools will change the g<g =)
related links in other files. 28

w

4+ Basic source control to ensure that files don’t get overwritten. These tools
lock files so that when you're working on a particular file, others on your
team can’t edit that same file.

4+ Publishing tools that allow you to use FTP to upload the content from
your site locally to the remote server where the site is housed.

4 Utilities that create site maps, check links, check the HTML code, and
run reports on who’s been working on what.

Dreamweaver Sites are covered in more detail in Book I, Chapter 3.

Exploring Toolbar Buttons

Dreamweaver provides you with a number of useful view buttons (shown in
Figure 1-4 and Figure 1-5) that you can use to see different views of your site
or to perform various functions. You can easily switch among views to exam-
ine your site in different ways. Each Dreamweaver view offers specialized
menus and tools to help you perform your work in that view. Certain views
are available for an individual document or page, whereas other views are
available for the entire site. At any time while you work, you can choose to
preview your site in target Web browsers, which enables you to see your site
from the user’s perspective.

Figure 1-4 shows the following Site-related buttons from the Files panel:

4+ Connect to Remote Host button: Connects your local computer and your
Web host, allowing you to transfer files between the two computers.

4+ Refresh button: Refreshes the panel’s view of files in the Site if you've
made a change to filenames or file structures outside of Dreamweaver
while the program was open.

4 Get File(s) button: Downloads (retrieves) documents and files from
the host.
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4 Put File(s) button: Uploads (sends) documents and files to the host.
4 Check Out File(s) button: Locks files for editing by a single individual.

4+ Check In button: Replaces files on the server and makes them available
for editing by unlocking them.

4+ Synchronize button: Upload or download files to synch the assets on
your local site with those on your remote site.

4+ Expand/Collapse button: Enlarges the Site tab to full screen, with remote
and local files side by side (or, conversely, collapses the full-screen view).

Refresh Check In
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Put File(s) Collapse
i
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o 4 4 V4@ F
1
ldl.dl Files | Size[1
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72 imdges =
H A -5 Libfary F
Flgur_91 4 3 E mefia F
The Files tab 5 E Seassets F
1 - templates F
Of the FI|ES T | #ni-tevd Pa.. IpKET
panel T Ahqu-raris.Hm 1IER +
H T acgessories.cfm LKE A
includes B topiront ln o
useful 2 bofinabalskfm ko A
buttons. Sl w. 2
§ | Inral ibeeps siprted tofaling 1 Tog...
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to Remote
Host Get File(s) Synchronize

Figure 1-5 shows the following document-related buttons from the top of the
Document window:
4 Code: Enables you to view the HTML page code full-screen.

4+ Split: Allows you to view the HTML page code and the graphical view of
your document at the same time.

4+ Design: Enables you to view the WYSIWIG graphical representation of
your page full-screen.
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4+ File Management button: Click and then select Get to retrieve files
from the Web site host, or select Put to send files to the host.

4+ Preview/Debug in Browser button: Click and select to preview or
debug in your browser(s).

4+ Refresh button: Reloads your page so that changes to the code are
reflected in the Design view.

4+ View Options button: Click to select options (such as Word Wrap
in Code view and the Ruler in Design view) to assist you in viewing
your page.

4+ Visual Aids: Hides and shows the various visual cues available to you in
the Split and Design views.

4+ Validate Markup: Allows you to run a check on your code to see
whether the HTML code is well formed.

4 Check Browser Compatibility button: Allows you to run a check on
your code for browser compatibility.

File Management Visual Aids

Figure 1-5:

The buttons Refr|eshJ Check| Page

atthe tOp Conin | S gl | 3] Pvesign || Thin: | UntRied Document [ o B G, | g 5 ChediPage

of the | 1] | i v.T. =l B, | B e

a?:;?;nt Preview/Debug Validate

' in Browser Markup
View
Options

&Q,N\BER
< Some of these items may be unavailable, depending on what view you're in

and what you have selected in a document or panel.

Using Panels and Inspectors

You can use Dreamweaver panels and inspectors to enter details about all
aspects of your Web site. These interfaces offer areas where you can add
and format page features, set up navigation and behaviors, and manage the
workflow of building your site.

Book |
Chapter 1
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Figure 1-6:
The Tag
Inspector
panel with
general
page
properties
displayed.

Understanding the role of panels

A panel typically provides information about all instances of a particular fea-
ture on a page. For example, the Layers panel lists information about all the
layers on the current page.

The Tag Inspector panel gives you easy access to various properties and
behaviors specific to a selected object. The Tag Inspector panel updates
continually, depending on what you have selected on your page. (If you have
nothing selected on the page, the panel displays properties and behaviors of
the whole page itself, as shown in Figure 1-6.) Note that the Tag Inspector
panel’s name reflects the HTML or CFML tag being inspected.
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To switch among tabs in a panel, just click the tab names.

Working with the Properties panel

The Properties panel changes, as does the Tag Inspector panel, based on the
individual document object you have selected on your page, and it contains
details on attributes of the object. For example, selecting text on a page
opens the Text Property inspector in the Properties panel, where you can
format the size, font, color, link, and other attributes of the text. (Figure 1-3
shows the Properties panel with a Layout Table selected.) To make certain
that the Properties panel is shown below the Document window, choose
Windowr=>Properties or press Shift+F3.

The Properties panel has a small down arrow in the lower-right corner,
called an Expander button. Click the button to enlarge the Properties panel
to view additional formatting options. In an expanded Properties panel, click
the small up arrow in the lower-right corner to collapse the panel.
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Getting Help

‘v‘“ T0

Dreamweaver offers a variety of tools to help you find the answer to virtually
any question you have about the program. The Help tools provide basic
information for beginners, as well as advanced references detailing HTML
and JavaScript code.

You can get help by clicking the Help button — the small question mark —
in the top-right corner of some panels. Similarly, you can open the Options
menu in the top-right corner of any panel and select Help from the list.

You can also access help by using the Help menu located on the main menu.
Just choose Help and then you can select from a host of options. Some of the
more popular ones include

4+ Dreamweaver Help: Provides definitions and itemized steps in perform-
ing routine Dreamweaver tasks. It contains Help Contents, Index, and
Search categories.

4+ Spry Framework Help: Launches a Web browser and loads a page from
the Adobe Web site, where you can find information about the Spry
framework. See Book I, Chapter 7 for step-by-step instructions on using
Dreamweaver to place smart Spry widgets on a page.

4+ Using ColdFusion: Provides information about coding dynamic sites
using ColdFusion technology.

4+ Reference: Opens the Reference tab of the Results panel, offering a
dictionary-style reference on CSS, HTML, Accessibility requirements,
Sitespring tags, and JavaScript. You can also access the Reference tab
of the Results panel by clicking the Reference button in the Document
window.

4+ Extensions: Provides assistance in performing more advanced
Dreamweaver tasks, especially tasks involving the integration of adjunct
programs, such as Adobe Flash, with Dreamweaver. This help option
contains nitty-gritty information about application programming inter-
faces (APIs) — specific software interfaces that allow you to integrate
Dreamweaver with databases, the C and Java programming languages,
and much more.

4+ Dreamweaver Support Center: Connects you to the Web, where you
can find constantly updated information on working with Dreamweaver,
answers to frequently asked questions, and program extensions. You can
also join a developer’s forum, where you can chat with other Dreamweaver
users to get (and give) help.

Book |
Chapter 1
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Chapter 2: Creating
Basic Web Pages

In This Chapter

v Setting ruler and grid options in the Document window
v~ Creating and opening pages

v~ Establishing page properties

+* Working with text

1+ Working with images

v+~ Adding links

v Working with tables

v+ Previewing your work

v Checking browser compatibility

Fe most significant (and, fortunately, the easiest) process in building a
Web site is creating the individual pages that convey the site’s content.
Even if you plan on creating an ultrahip site chock full of animation and
interactive forms, you spend the vast majority of your site-building effort
constructing basic Web pages comprised of words and images. This chapter
shows you how to set up, add color to, and name individual Web pages. You
also discover how to add basic elements such as text, graphics, and tables,
to your pages.

Setting Ruler and Grid Options
in the Document Window

Dreamweaver offers you complete control over how you work in the Document
window by providing two guide tools — rulers and a grid — to help you lay
out your work accurately. You can customize a variety of guide tool attributes,
such as ruler increments and grid snapping, to suit your personal prefer-
ences and speed Web page development.
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Here’s a brief look at all your options with rulers and grids:

4 Turning rulers on and off: Using rulers — both horizontal and vertical —
in the Document window can help you measure and position page
elements. Toggle the rulers on and off by choosing Viewr>Rulersw>
Show or by pressing Ctrl+Alt+R (38+Opt+R on a Mac).

4+ Moving and resetting the origin: By default, the origin, or (0,0) coordinate,
of a Dreamweaver ruler is set to the upper-left corner of the Document
window. You can reposition it to any coordinate in the Document window
by clicking the origin cross hairs and dragging them to new coordinates,
which can be useful if you want to use the rulers to position elements
of a table whose upper-left corner doesn’t sit at (0,0) in the Document
window. Reset the origin to its default position by choosing View=>
Rulers>Reset Origin.

4+ Changing ruler measurement units: You can change the ruler’s measur-
ing increment by choosing View=>Rulers and then choosing Pixels,
Inches, or Centimeters.

4+ Viewing the grid: Dreamweaver provides a Document window grid that
can assist you in visually positioning and aligning page elements. You can
toggle the grid on and off by choosing Viewr>Gride>Show Grid or press-
ing Ctrl+Alt+G (88+Opt+G on a Mac). The grid is shown in Figure 2-1.
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4 Activating and deactivating grid snapping: The Document window grid Book I
offers a snapping feature that causes a div or Layout table or cell to Chapter 2
automatically align precisely with the snap-to points you define, which
can be useful when you draw, resize, or move a div (see Book I, Chapter 5

for the skinny on divs). You can toggle grid snapping on and off by s S
choosing Viewt>Grid=Snap to Grid. o2
-
T
[
® You can adjust how the grid appears in the Document window in the Grid a 9
Settings dialog box. To do so, open the Grid Settings dialog box by choosing e 2

View=Grid=>Grid Settings and change any (or all) of the attributes that
appear. When you finish, click the Apply button to view the effect of your
changes. Click OK to accept the changes and close the dialog box.

Creating and Opening Pages

You have several ways to create a new page in Dreamweaver:

4 On the Start page, scan through the Create New column and click the
type of page you want to create from scratch.

4+ On the Start page, click one of the options in the Create from Samples
column to open the New Document dialog box and make a new page
with many common settings precoded.

4+ Choose File> New or use the keyboard shortcut Ctrl+N to open the New
Document dialog box, from which you can create pages from scratch or
from templates.

To open an existing page, do any of the following:

4+ On the Start page, click the name of the page in the Open Recent column.
4+ Double-click the page’s filename in the Files tab of the Files panel.

4+ Choose File=>Open or press Ctrl+O to summon the Open dialog box,
which you can use to browse to the page you want to open.

Establishing Page Properties

The Page Properties dialog box provides you with control over how several
key page properties appear, including the title of the page, page background
color, link colors, and page margins. Selections apply only to the current
page, not to the entire site. Open a Page Properties dialog box similar to the
one shown in Figure 2-2 by choosing Modify~>Page Properties or pressing
Ctrl+J. Then make changes to any of the following in each of the five cate-
gories (Appearance, Links, Headings, Title/Encoding, and Tracing Image):
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Figure 2-2:
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4+ Page Font, Size, Text Color, Background Color, Background Image:

Choose a font or set of fonts from the Page Font drop-down list; add a
style (bold or italic) if desired. Click the Color box next to each property
and pick a color from the Web-safe color palette that appears, or enter a
hexadecimal color code directly in any Color Code text field. You can also
customize your own colors by selecting the color wheel and entering
either RGB values or Hue, Saturation, and Luminosity values. For more
information about using colors for the Web, see Book IIl, Chapter 2.
Book IIl, Chapter 3 includes information on how to use the color picker
to select colors in both Dreamweaver and Fireworks. For Background
Image, click the Browse button to locate the image file that you want to
appear as the Document window background. If the image is smaller
than the available background area, the image is tiled (repeated in a
checkerboard fashion, like floor tiles) to fill the background.

Even if you choose to use a background image, select a complementary
background color; the color shows while the background image is
downloading.

Left Margin, Right Margin, Top Margin, and Bottom Margin: Enter
numbers (in pixels) in these text fields to set up margins that affect how
your page appears in modern browsers. Enter a whole number for the
number of pixels of buffer space you want between the left, right, top,
and bottom edges of your document and the content of the document.

Link Font and Size, Color for Links, Rollover Links, Visited Links, and
Active Links: Choose a font or set of fonts from the drop-down list; add
a style (bold or italic) if desired. Click the Color box next to each property
and pick a color from the Web-safe color palette that appears, or enter a
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hexadecimal color code directly in any Color Code text field. You can
also customize your own colors (see the first bullet on Text Color).

4+ Underline Style: Select an option from the drop-down list.

4+ Heading Font, Sizes, and Colors: Choose a font or set of fonts from the
drop-down list; add a style (bold or italic) if desired. For as many of the
six standard HTML heading levels as necessary, select a font size. If you
choose a numeric value, the unit-of-measurement drop-down list to the
right becomes active so that you can select an option. Click the Color
box next to each heading and pick a color from the Web-safe color
palette that appears, or enter a hexadecimal color code directly in any
Color Code text field. You can also customize your own colors (see the
first bullet point on Text Color).

4+ Title/Encoding: Enter a page title in the text field. This title appears in
the title bar area of the window both during construction in Dreamweaver
and when the page is viewed in a Web browser. Select an Encoding format
if your site requires the use of non-Western fonts (Japanese or Cyrillic,
for example). If your site is in English, you can leave the setting at the
default, Western European.

4+ Tracing Image: Click the Browse button to locate the image file you
want to use as a guide for laying out your Web page in the Document
window. This feature is handy for developers who prefer to mock up a
portion of their Web page design in a graphics program and then re-create
that design in their Web pages. Tracing images appear in Dreamweaver
only as a pattern to help guide you in creating an actual Web page; the
tracing image never appears on the finished Web page.

4+ Image Transparency: Drag the slider to adjust the visibility level of the
tracing image. At 0 percent, the tracing image is invisible; at 100 percent,
the image is completely opaque.

Click the Apply button to view the effect of any property you change. Click
OK to accept your changes and close the Page Properties dialog box.

Working with Text

As we mention in Book I, Chapter 1, Dreamweaver has three different design
views: Design, Code, and Split (Code and Design). The following sections apply
when you’re working in Design view or Split view of Dreamweaver. In these
views, you can enter and manipulate text on a Web page in Dreamweaver by
using similar procedures to those you use when working with a word pro-
cessing document.

Book |
Chapter 2
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Figure 2-3:
The
Properties
panel with
the Text
Property
inspector
loaded.

MBER
é“'
&

Adding, editing, and deleting text

To enter text on a page, click in the Document window and begin typing.
Your mouse pointer appears as a blinking cursor that moves along with the
text you enter. When you reach the end of a line, the text automatically
wraps to the next line. Dreamweaver automatically adds the associated code
for your new text in the HTML for the page.

To delete text from a page, in the Document window, select the chunk that
you want to delete and press Backspace or Del on your keyboard.

You can also modify how text appears on a page by editing its font, size, color,
alignment, and other attributes. To modify text in the Document window,
click and drag to select the text you want to modify. The Properties panel
loads the Text Property inspector, as shown in Figure 2-3 (the Tag Inspector
panel also reflects the selection). If the Text Property inspector is not open,
choose Window>Properties or press Ctrl+F3 to open it. In the Text Property
inspector, modify any of the following properties:
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4+ Format: From the Format drop-down list, select a default text style.
Heading 1 is the largest style and Heading 6 is the smallest, but none of
the headings correlates with a specific pixel size unless you set it to do so.
Select Paragraph for the basic body text of your pages. Select Preformatted
if you want spaces, tabs, and new lines in a paragraph to show up in a
browser. (Ordinarily, when you add multiple spaces in a row or tabs to
your HTML — this is particularly obvious in the Dreamweaver docu-
ment’s Code view — they appear as single spaces in a browser.)

4+ Font: Select a font face from the Font drop-down list. Browsers show
your text formatted as the first font in your selection that resides on the
user’s computer. Choosing Edit Font List allows you to add more fonts that
you may have installed on your computer to the Font drop-down list.

Most computers will have standard fonts such as Arial and Helvetica
and won’t have less common fonts such as, say, Univers or Futura. If you
use a nonstandard font and it’s not on the user’s machine, the layout
could look very different from what you planned.
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Style: Dreamweaver has been updated to work better with CSS styles.
Styles defined within the document or in a linked stylesheet will be avail-
able from the Style drop-down list. You can also use the drop-down list
to attach a stylesheet and create and edit styles.

Size: Select a font size from the Size drop-down list. The options include
None (choosing this option displays text in the default size), specific
numbers, generic sizes XX-small to XX-large, and relative sizes Smaller
and Larger. If you select a number, the unit-of-measurement drop-down
list becomes available so that you can specify what the font size number
refers to (pixels, ems, and so on).

Color: Click the color box and select a text color from the Web-safe color
palette that appears. Alternatively, you may enter a hexadecimal color
code directly in any color code text field. (To set the default text color
for a page, check out the “Establishing Page Properties” section, earlier
in this chapter.)

Bold or Italic: Click the Bold button to make your selected text appear
in bold. Click the Italic button to italicize your selected text. You can
click either button, or both.

Alignment: Click an alignment button to align your text. Choices are Letft,
Center, Right, and Justify.

Link: Type a URL in this field to transform selected text into a hypertext
link. You can also use the Point to File tool to link to a file. To link to a
file using this tool, just follow these steps:

1. Open the Files panel by choosing Window=>Files or by pressing F8.

2. Open Explorer to the folder location that includes the file you
want to link to by selecting the collapsing menu squares.

Alternatively, skip to Step 3 and hover your cursor over the folder
that contains the file; the folder will expand so that you can select
the file within.

3. Click and hold the Point to File button in the Text Property inspec-
tor and drag the pointer to the file you want to link to. Release the
mouse button when the pointer is over the file.

The Point to File button looks like a compass without the needle or a
clock face without hands or numbers. It’s located to the right of the
Links field.

When you’re dragging the button, a line appears from the origin
point to your cursor, as shown in Figure 2-4.

After you let go of the mouse button, the link to the file appears in
the Link text field. If you select the Link drop-down list, it shows you
your recent links as well.

Book |
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Figure 2-4:
The line
helps you
see which
file you're
linking to.
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4+ Target: If you are linking the selected text, you can specify how the
linked page will open when the user clicks the link; you do so by select-
ing one of the following options from the drop-down list:

e _blank: Opens the link in a new window.

e _parent: Opens the link in the parent of the window that is cur-
rently open. If the window with the link in it is not in a frame, the
linked page opens in the same window as the link. If the link is in a
frame, the linked window will open in the parent frame or in the
parent window of the frame with the link. See Book I, Chapter 4 for

more information about frames.

e _self: Opens the link in the currently opened window; this is the

default target.

e _top: Opens the link in the top-level window, replacing any existing

frames.

4+ List: Click the Unordered List button next to the Target field to transform
text into an unordered (bulleted) list; click the Ordered List button to

transform text into an ordered (numbered) list.
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4+ Placement: Click the Text Outdent button, which you find next to the
Ordered List button, to outdent (decrease the indent) the selected text;
click the Text Indent button to indent the selected text. If you outdent an
item in a bulleted or numbered list, the item will no longer be a list item.

Inserting a line break

When you want to start a new line in a word-processing program, you
press the Enter key. If you press Enter in Dreamweaver, you create a para-
graph break, which starts a new paragraph and creates a blank space
between paragraphs. If you want to start a new line directly under another
line of text and without the big space between lines, you need to insert

a line break. In Dreamweaver, you create a line break by choosing
Insert->HTML=>Special Characters=Line Break or by pressing Shift+Enter.
Alternatively, you may click the Insert Line Break button from the HTML
category of the Insert bar. Dreamweaver places the cursor at the start

of the next line and inserts the line-break HTML code.

Working with Images

A\

Aside from entering text, manipulating images on a Web page is probably
the most common Dreamweaver function you perform. You can add or
delete an image and modify its properties to create an aesthetically
pleasing layout that effectively conveys the information you want to deliver
to the user.

To see how to place an image on the background of your page, check out the
“Establishing Page Properties” section, earlier in this chapter.

Inserting an image

To insert an image on a page, follow these steps:

1. Choose Insert->Image.

Alternatively, you can click the Insert Image button in the Common cate-
gory of the Insert bar.

2. In the Select Image Source dialog box that appears (shown in Figure 2-5),
click the image you want to insert.

If the image is outside the folder that holds your HTML document, use
the Look In drop-down list to browse to the file you want. The Image Tag
Accessibility Attributes window appears.
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3. If desired, enter Alternate text in the Alternate Text field of the Image
Tag Accessibility Attributes window.
Specifying alternate text ensures that when viewers’ browsers don’t —
or can’t — display the image, some meaningful text appears instead; it
also serves as an alternative for sight-impaired visitors to your page.
Alternate text should be limited to a few words. You can also add more
details about the image in the Long description field.
4. Click OK to insert the image.
Note: Every image you want to include on a Web page should reside
within the root folder of the current site. (Typically, you should have
your HTML files in the site root folder — the master folder that holds
everything on your site — and all your images in an images folder that’s
also in the site’s root folder.) If you attempt to insert an image from
another location, Dreamweaver asks whether you want to copy the
image to the current site root folder. Click Yes. In the Copy File As dialog
box, you can enter a new name for the image in the File Name text field,
or you can accept the current name and click the Save button.
® Always be sure that you have saved your HTML file at least once before you

insert an image into it. If your file isn’t saved, Dreamweaver won’t know
where to place the image in relation to the file. After you've saved the file in
a particular folder, the location is known and Dreamweaver can include the
correct relative location of the image.
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Select the Preview Images check box at the bottom of the Select Image
Source dialog box to view a thumbnail of the image before you select it for
insertion. The preview area also tells you the size of the image and the
expected download time.

Deleting or moving an image
To delete an image from a page, click the image in the Document window and
press the Delete key on your keyboard.

If you want to move the image from one place on the page to another, you
can click the image in the Document window, press Ctrl+X to cut the image,
click the spot on the page where you want to move the image, and press
Ctrl+V to paste the image. You can also move an image by clicking and drag-
ging it to a new location.

Modifying an image
You can modify how an image appears on a page by editing its size and align-
ment, adding a border, and changing other attributes.

To modify an image, click the image in the Document window to select it. If
the Image Property inspector does not appear, choose Window=>Properties
to open it.

To see all the options the Image Property inspector offers, click the down
arrow in the bottom-right corner of the Image Property inspector. (Clicking
the up arrow displays fewer options.)

You can do any of the following things to modify the way an image appears:

4+ Resize the image: Click and drag a sizing handle to change the dimen-
sions of the image. To resize the image maintaining the same propor-
tions, hold down the Shift key as you drag a sizing handle. You can also
resize the image by typing new pixel dimensions in the W and H text
fields in the Image Property inspector. Click the Resample button to con-
form the resized image to the new dimensions. (Otherwise, resizing in
Dreamweaver changes the dimensions in which the browser draws the
image but leaves the image file itself untouched — and image quality suf-
fers when the browser resizes the image.)

If you want the resized image to look its best, you may be better off
resizing the image in Fireworks, because Fireworks gives you more con-
trol over the resizing process. To edit the image in Fireworks, select the
image and click the Edit button (the pencil icon) in the Edit section of
the Properties panel.
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4+ Align the image: In the Image Property inspector, click an alignment

button to position the image on the page (or within a cell if the image is
located in a table cell). Alignment button choices are Left, Center, and
Right. To align an image with special word wrapping, select one of the
alignment options, which are detailed in Table 2-1, from the Align
drop-down list that appears when you position your image near a
bunch of text.

Add a border to the image: In the Image Property inspector, enter a
number in the Border text field to add a border of that thickness to the
image. Border thickness is measured in pixels.

Pad an image with spaces: In the Image Property inspector, enter a
number in pixels in the V Space (V for vertical) text field for the space
you want to appear between the top and bottom of the image and other
page elements; then, enter a number in pixels in the H Space (H for hori-
zontal) text field for the space you want to appear between the image
and page elements on either side of the image.

Make the image a link: In the Image Property inspector, enter a URL in
the Link text field.

Specify alternate text for the image: In the Image Property inspector,
enter alternative text in the Alt field. (Specifying alternate text ensures
that when viewers’ browsers don’t — or can’t — display the image,
some meaningful text appears instead, and also serves as an alternative
for sight-impaired visitors to your page.)

Name the image: In the Image Property inspector, enter a name in the
text field next to the thumbnail image. (Naming an image is important if
you want to refer to that image using a behavior or scripting language,
such as JavaScript, but is otherwise unnecessary.)

Edit the image: In the Image Property inspector, click the Edit button.

Dreamweaver allows you to optimize, crop, resample, adjust brightness
and contrast of, and sharpen an image by using the buttons in the Edit
section of the Image Property inspector. If you want the most control
over the process of editing the image, click the Edit button to open the
image in Fireworks or Photoshop. You’ll have the choice of working
directly with the image or opening the source file the image came from.
In most cases, you maintain the highest image quality by manipulating
the pre-optimized source version of the image and then exporting it as a
new GIF or JPEG.
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4+ Change the image file: In the Image Property inspector, enter a different
filename in the Src (source) text field (or click the File Folder button to
browse for image files).

4 Add an image map: In Dreamweaver, you can add multiple hyperlinked
hotspots to images to create an image map. In the bottom left of the
Image Property inspector, you see an arrow pointer and some image
tools (a rectangle, circle, and free-form hotspot creator). With these
tools, you can create hotspots on your images, and you can specify the
following for each hotspot:

¢ The link location for the hotspot

e The target window for the link

¢ The alternate text for the hotspot

Table 2-1 Aligning an Image in Relation to Text
Alignment Option Effect on Image and Text Wrapping

Default Same as Bottom alignment

Baseline Same as Bottom alignment

Top Aligns the image top with the highest other inline element
Middle Aligns the image middle with the text baseline

Bottom Aligns the image bottom with the text baseline

Text Top Aligns the image top with the text top

Absolute Middle Aligns the image middle with the text middle

Absolute Bottom Aligns the image bottom with the bottom of the text descenders
Left Aligns the image flush left

Right Aligns the image flush right

Working with Links

Linking your page to other Web pages enables you to direct visitors to
related content on the Web. To insert a link, you must specify an image or
some text to serve as the link; you must also specify the link location to
which you want to send your visitors. The link can go to a page within your
site or to a page elsewhere on the Web.
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Inserting a link

To insert a link on a page, follow these steps:

1. Select the text or image you want to make into a link.

Doing so opens the Property inspector for your text or image. If the
Property inspector does not appear, choose Window= Properties to
open it.

2. In the Link area of the Property inspector, enter the destination URL
of the link (text or image) that you created in Step 1.

The URL you specify can be any valid URL; for example, it can be a
Web page within your own site (somePage.html), a page on the Web
(http://www.someSite.com/somePage.html), or even an e-mail address
(mailto:somebody@somewhere.com).

Alternatively, you may click the File Folder button that you see in the
Property inspector to display the Select File dialog box. After you
browse your computer using the Select File dialog box and select a file,
click OK to make that file the target of a link.

To create an e-mail link quickly, click anywhere in your document and
choose Insert>Email Link. Specifying the same value for the Text and
E-mail fields that appear allows folks who haven’t configured their Web
browsers to handle e-mail automatically to see the e-mail address on the
page. Then, they can copy and paste the e-mail address information into
their e-mail program of choice.

Deleting a link

To delete a link from text or an image without deleting the text or image
itself, follow these steps:
1. Select the text or image you want to remove the link from.

The Property inspector for your text or image opens. If the Property
inspector doesn’t appear, choose Window=>Properties to open it.

2. In the Property inspector, delete the URL from the Link text field.

Note that if you delete a linked image or linked text from a page, the link gets
deleted along with the text or image.
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Using named anchors Book!
When you want to create a navigational link that connects users not only to aper
a page but also to a specific location on the page, you need to create a named

anchor. Named anchors are frequently used for jumping to exact positions Q
within a large block of text so that users don’t have to scroll through para- 5 1-3,
graph after paragraph to find the information they need. Named anchors are :é
especially useful when creating links from a directory or a table of contents % o
to the content it presents. » 2

Inserting a named anchor
Place an anchor anywhere on your Web page as follows:

1. In the Document window, click at the position you want to insert the
named anchor.

2. Click the Named Anchor button on the Common category of the Insert
bar or choose Insert>Named Anchor.

The Named Anchor dialog box appears, as shown in Figure 2-6. If the
Insert bar is set to a different category, click and hold the category name
and select Common from the drop-down list.

Figure 2.6: Hamed Anchor &
The Named | anchor rome: | [ ]
Anchor [ concel |
dialog box. tep |
3. Type a name in the Anchor Name text field.
4. Click OK.
<P It’s a good idea to insert the named anchor tag slightly above the actual posi-

tion where you want the link to target. Doing so gives your targeted content
a little padding on top. Otherwise, the top of your image or your first line of
text appears flush with the top of the browser window.
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Linking to a named anchor

To link to a named anchor, follow the procedure outlined in the “Inserting
a link” section, earlier in this chapter, with the following modifications:

4+ Linking to a named anchor on the current page: In the Link text
field of the Property inspector, type a pound sign (#) followed by the
anchor name.

4+ Linking to a named anchor on a different page: In the Link text field of
the Property inspector, type the page’s URL followed by a pound sign
NG and then the anchor name.
S
Be sure not to include any spaces in the names of anchors. These may not
be read by the various Web browsers.

Working with Tables

You can position objects (such as text blocks, images, or animations) rela-
tive to each other on a page in two basic ways:

4+ Using tables: A time-honored Web tradition for page layout, tables are
grids of cells defined by columns and rows. Cells can have set sizes and
alignments and may contain anything you can put on a Web page, includ-
ing other tables.

4+ Using divs: Divs can be positioned precisely, and in Dreamweaver, divs
are in some ways easier to use than tables. For instructions on how to
lay out your Web page with divs, see Book I, Chapter 5.

Adding a table to a Web page can help you lay out page elements more easily
in the Document window. Tables consist of as many holding areas, or cells,
as you want, and you can place virtually any Web element, such as text or an
image, into a cell. Cells are organized horizontally into rows and vertically
into columns. Dreamweaver provides you with complete control over the
size, position, color, and other attributes of your table. You can edit these
attributes at any time via the Table Property inspector.

Inserting a table

To insert a table into a Web page, just follow these steps:

1. Click within the document at the point where you want to place the
table.

2. Choose Insert>Table, press Ctrl+Alt+T (88+Opt+T on a Mac), or click
the Table button in the Common category of the Insert bar.
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The Insert Table dialog box appears, as shown in Figure 2-7. If the Insert
bar is set to a different category, click and hold the category name and
select Common from the drop-down list.

Insert Table %]

Table size -

Rower |3 Columne: | 3
Table width: AL pivels |
Border thackness: | poeels
Cell padding: | 0

Cell spading: | 2

-] T mm-
- -
- -
- =
Left Top Doth
Accessibility —
Caption:
Algn caption: | defaull.  w
SUMMary:
| ok ][ conce

3. Enter the number of rows and columns you want the table to have in
the corresponding Rows and Columns fields.

You can always add or remove rows or columns later.
4. Use the Table Width field to set a width for the table.

The width can be either a set number of pixels or a percentage of the
area that bounds the table (the page itself, or, if the table is nested in a
cell, that cell).

5. In the Border Thickness field, enter a number for how many pixels
thick you want the border of your table to be.

If you don’t want the table border to show (which you probably don’t
if you're using the table for page layout purposes), enter 0 (zero).

6. In the Cell Padding field, enter a whole number for the amount of
pixels you want between the border of the cell and the text or object
inside the cell.

The cell padding applies to the top, bottom, left, and right of the inside
of each and every cell.

7. In the Cell Spacing field, enter a number for the amount of pixels you
want between the cells.

The cell spacing applies to the whole table; you can’t have different cell
spacing for individual rows or columns.
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8. If your table has a header row or header column (or both), click the
button (None, Left, Top, or Both) that represents the header structure
of your table.

The text in a header row has special formatting that you can define in a
stylesheet. If you're creating a table for layout purposes, you won’t want
a header row or column, so make sure that None is selected.

9. In the Accessibility section of the Insert Table dialog box, enter a cap-
tion and summary for the table if you need to describe the table for a
sight-impaired audience.

If you're making the table for page layout purposes, leave these blank.
10. Click OK.

The Insert Table dialog box disappears and the empty table appears in
your document.

An empty table is shown in Figure 2-8. To enter data into the table, just click
an individual cell and enter the content you want in that cell. You can modify
any of the table’s attributes by selecting the table and changing the attrib-
utes in the Property inspector or the Tag Inspector panel.
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Deleting a table

To delete a table from a page, click the border of the table to select it and
then press the Backspace or Del key. Dreamweaver removes the table from
your page and deletes the associated code in the HTML for the page.
Naturally, everything that was in the table is also deleted from the page.

Using layout tables

The use of tables is central to the traditional way of building great Web
pages. (For information on laying out pages with divs, see Book I, Chapter 5.)
What happens, though, when you want to put an image right smack in the
middle of a page, or when you want to have one column of information along
the right side of the page and a square text block at the bottom of the page?
You can nest tables, which involves building new tables inside cells of other
tables, but creating nested tables is complicated, especially with complex

pages.

Thankfully, Dreamweaver offers an easy way to work with complex tables
called layout tables. With a layout table, you tell Dreamweaver where you
want to put something on the screen, and the program generates all the
required tablework to make it happen.

To create a layout table, just follow these steps:

1. Choose Viewr>Table Moder>Layout Mode or press Alt+F6.

If the Insert bar is set to a different category, click the Layout tab.
The first time you press Alt+F6 (Opt+F6 on a Mac), a Table Help dialog
box appears.

2. Click the Draw Layout Table button (just to the left of the Draw Layout
Cell button).

3. Click and drag the cross hair to create the layout table of your choice.

A light-green table appears, as shown in Figure 2-9, with the dimensions
you gave it.

4. To create individual cells within that table, click the Draw Layout Cell
button to the right of the Draw Layout Table button and draw a cell
anywhere within the table.

If you create a layout cell outside a layout table, Dreamweaver will
create both the cell and the table to support it. Note that you cannot
draw a new cell that overlaps an existing cell in the table.
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<P If you create a layout cell, you can immediately edit the cell you created.

However, if you create a layout table, you either have to switch back to
Standard view to edit the single cell of that table or create a layout cell
within the table before you can edit the table.

Storing information in table cells

After you insert a table into a page, you can add or delete elements such as
text and images in the table cells:

4+ Adding an image to a cell: To add an image to a table cell, click in a
table cell and choose Insert>Image or press Ctr+Alt+I (88+Opt+I on
a Mac). Browse and select an image you want to add to the cell and
then click OK. (For more information on inserting images, flip to the
“Inserting an image” section, earlier in this chapter.)

4+ Adding text to a cell: To add text to a table cell, click to position the
cursor in a table cell and type the text you want placed inside the cell.
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4 Deleting an image from a cell: To delete an image from a table cell, Book |
select the image and press Backspace or Del. Chapter 2

4+ Deleting text from a cell: To delete text from a table cell, select the text

and press Backspace or Del. < Q
4
Previewing Your Work ¥

Whether you're working in Code view or Design view, at some point you’ll
want to see the page as visitors to your site will see it: in a browser such as
Internet Explorer or Netscape Navigator. If you have two or more browsers
on your computer, you can preview your page in any of the browsers —
without leaving Dreamweaver — by using the Preview in Browser feature.

To preview your page in your primary browser, choose File>
Preview in Browserw>Browser Name, or press F12. The keyboard
shortcut for previewing in your secondary browser is Shift+F12.

Checking Browser Compatibility

One of the most frustrating things about creating Web sites is that the same
HTML and CSS code may display differently in different browsers. In fact, it’s
possible that one part of a page that displays in one browser won’t display
at all in another.

Dreamweaver can find problems in the code that may lead to display issues
in different browsers. To use the Browser Compatibility Check, just follow
these steps:

1. Choose Filec>Check Page->Browser Compatibility.

The Results panel appears at the bottom of the workspace, open to the
Browser Compatibility Check tab.

2. Click the green right-facing arrow at the top left of the panel and
choose Check Browser Compatibility from the menu that appears.

Dreamweaver searches your code for problems. Any issues it finds are
listed in the panel, ordered by the line in the code where each problem
appears.
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Chapter 3: Creating and Using
Dreamweaver Sites

In This Chapter

v Defining a Site in Dreamweaver CS3
+* Whipping up your first site

v+~ Establishing a remote connection

v+~ Using advanced site options

+ Publishing and maintaining your site

v+~ Using source control

ou can use Dreamweaver CS3 to create many different kinds of Web

pages. During the course of building a Web site, you’ll add pages,
graphics, links, and all sorts of related information at a single location to
be posted eventually to a Web server on the Internet. After your site is
complete, you'll probably want to make updates and fixes. Heck, you may
even be making more than one site at the same time!

To help facilitate management of your Web site (or sites), Dreamweaver
offers a suite of site management tools. These tools are collectively called a
Dreamweaver Site. This chapter explores how you can use these tools to
manage your Web site more easily.

Defining a Site in Dreamweaver CS3

Figure 3-1 shows a typical relationship between where you build your Web
site (on your desktop) and where the site actually lives on the Internet (on a
Web server). Dreamweaver Sites facilitate getting all the correct information
from your desktop to the Web server and generally make the Web page cre-
ation process easier. Specifically, a Dreamweaver Site enables you to do the
following:

4+ Move files seamlessly back and forth between your local machine and
your Web server.

4+ Keep all your Site files in a single location.
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Figure 3-1:
The desktop
in relation to
the Web
server.

+

Generate pages for your Site based on templates that you create.

4+ Run reports on the pages in your Site to check links, page load, and
other key functions.

4+ Use source- and version-control to manage who works on what files and
when they do it, which can prevent team members from accidentally
overwriting each other’s work when building or maintaining a Site
collaboratively.

Internet

Your Desktop Web Server

www
Copy

Creating Your First Site

If you're working with a set of files regularly in Dreamweaver, or if you're
managing several sites, you're likely to find using Dreamweaver Sites —
which are different from a traditional Web site — an efficient way of working.
You can create a Site in Dreamweaver manually or by using a wizard.

This section shows you how to create a Dreamweaver Site manually. The fol-
lowing steps walk you through inputting the minimum amount of information
that you need to enter to create your Site. However, you can choose from a
number of other options, and they are covered in the “Using Advanced Site
Options” section, later in this chapter.

To create a basic site manually, follow these steps:

1. Choose Site>New Site.

The Site Definition dialog box appears, opened to the Advanced tab
by default. The Local Info options, shown in Figure 3-2, appear by
default.
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2. Set the options for your site by filling out each of the following pieces
of information:

¢ Site Name: Choose a name that you can remember easily and that
applies to the function of the Site.

¢ Local Root Folder: This is the location on your hard drive where you
want to store the files that make up your site. Again, you should title
the folder something intuitive and easy to remember. If you want to
browse for a folder, just click the folder icon to the right of the text

field.

¢ Default Images Folder: This is the standard directory for images
used on your site. Dreamweaver adds images here when you copy
image files into your Site. A good practice is to name this folder
images (if your site will be hosted on a UNIX-based server, you need
to be consistent about using upper- and lowercase letters in file-
names and links to those files from your site). If you want to browse
for the directory, just click the folder icon next to the text field.

¢ Links Relative To: Select Document if you want links to include a path
from the current document to the linked item (for example, ../../
images/spacer.gif for alink to an image in [site root]/images/
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from an HTML page in [site root]/aboutus/). Select Site Root if
you want all links relative only to the site’s main directory (for exam-
ple, a link to an image would be /images/spacer.gif, no matter
where the current document resides; the initial slash represents
[site root]).

e HTTP Address: This is the URL of your Web site. Dreamweaver uses
this to verify that links in your site are working properly.

¢ Case-sensitive Links: Select this check box if you want Dreamweaver
to distinguish between uppercase and lowercase letters in links.

¢ Enable Cache: Selecting this check box speeds up Dreamweaver’s site
management tools and is required for the Assets panel to work. See
your documentation for information about using the Assets panel.

3. Click OK to create the site.

Dreamweaver creates a folder for your Site if it doesn’t exist on your hard
drive, but it doesn’t create the images directory within that folder. Thus, it’s
always a good idea to create your folders on the hard drive first and then
create your Site.

Setting Up a Remote Connection

After you create your Site, it’s a good idea to get connected to the place
where the remote version of your Site (the one users will access via the
World Wide Web) will live. Dreamweaver can connect to a remote server in a
variety of ways. The route you choose depends largely on how you plan to
build and maintain your Site. You have essentially three different scenarios:

4+ Creating and testing your Site solely on your own computer: For exam-

ple, this may be the case if you're building your Site for someone
else — say, a client. Here the remote server is your computer — not
all that remote!

Creating your Site on your computer, but testing it somewhere else:
This is the most common situation. Dreamweaver has three different
delivery options for this scenario: FTP, Remote Development Services
(RDS), and local network connection.

Creating and testing your Site on a remote machine: In this case, the
options are the same as in the previous bullet. The only difference is that
when you're editing, you're editing files directly on the remote location,
leaving nothing on your local machine.



Figure 3-3:
The
Manage
Sites
dialog box.

Setting Up a Remote Connection 4 /

In most cases, your remote location is at an externally hosted Internet serv-
ice provider (ISP). If you have an account set up with an ISP, make sure to get
the following information, which is required for Dreamweaver to set up a
connection to your remote Web server:

4 An IP address or a URL to be used when posting your files (FTP host)

4+ A folder on the remote server where you are supposed to keep your site
files (host directory)

4 A username for your account

4+ A password for your account
To set up a remote connection, follow these steps:

1. Choose Siter>Manage Sites to bring up the Manage Sites dialog box,
shown in Figure 3-3.

Manage Sites Ed

changenotaacct

bermests

Earl's Bowdakeria —r—

lisa lef Edt...

mbr " =

werlealeria | Duplicate,..
Remave
Epart.
Import...

Done Help.

2. Select your site from the list on the left and then click the Edit button.
The Site Definition dialog box appears, opened to the Advanced tab.
3. From the Category list on the left, select Remote Info.

Along the right side of the dialog box, the Local Info options are replaced
with the Remote Info options. If you haven’t set up a connection previ-
ously, all you see is the Access drop-down list.

4. Select an option from the Access drop-down list.
You can choose from several Access options in this list, including
e FTP: The industry standard, file transfer protocol.

e Local/Network: A location on your local (meaning office, home
office, or your own computer) network.
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Figure 3-4:
Setting your
Firewall
preferences.

e WebDAV: Stands for Web-based Distributed Authoring and Versioning.
It’s a standard for version control and is used with Web servers such
as Apache Web Server and Microsoft IIS.

e RDS: ColdFusion’s Remote Development Services allows secure
remote access to files within a ColdFusion application server.

¢ Microsoft Visual SourceSafe Database: SourceSafe is Microsoft’s
version control application, which helps prevent the accidental over-
writing of files when you’re collaborating with others to build the
site. With Dreamweaver, you can integrate SourceSafe and use it for
your version control.

5. Fill out the appropriate information for the connection type you
selected.

Leave the source control settings (described in the “Using Source Control”
section, later in this chapter) alone for the moment. The following list
describes the information needed for each connection type:

e FTP: In addition to the four items we note at the beginning of this
section (FTP host, host directory, login (username), and password),
you also need to select the Passive FTP check box if you plan to use
Passive FTP (required for some servers). Select the Use IPv6 transfer
mode box if your remote server is enabled to use the latest version
of IP (Internet Protocol). If there’s a firewall you need to work through,
you can enter the Firewall host and port, as shown in Figure 3-4. Click
OK to save your Preferences and return to the Site Definition window.
Select the Use Secure FTP (SFTP) check box if you want to use
encrypted secure logins. After you've added the necessary settings,
you’re able to connect to your ISP.

Leave Maintain Synchronization Information selected to allow
Dreamweaver to track differences between the local and remote

Servers.

Prafarences ]
ategory re

[

o Hviys shows [localFies. (] onthe [fight o |
Code Colonng

Code Formst Dupandar: fles: (] Promot on gatjcheck out

CoawHLE 7] Proen n ! "

e Revwirting [ Pramet on putfched i

pcciio FTP convmection: (] Cesconnect after | 30 | Mnutes dde

5% styies

Fie Compars R

Fie Types | Frlters FlPlime oul: |60 | Seconds

Font:

Fehsing FTP rarer cptiorn: [Z] Select def sk action in dalogs after | 60 | seconds
Tirvidhe Elairerts :

Livouk Mode Firewal host: | 192.168.0.1300

Ny Document

Freview in Drosser Firesunl poet: | 31

She

Slalus Bar Putt pptiore: [] Sawe Fles hefone putting

Horve optiors: (] Prospl before moviegHles on server

[ Moo Stes...

f

e



Figure 3-5:
The
Configure
RDS Server
dialog box.
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If you select Automatically Upload Files to Server on Save,
Dreamweaver will automatically make a connection to the remote
server and upload your file each time you save it.

Select the Enable File Check In and Check Out option if you're work-
ing in a collaborative environment and you want to ensure that other
team members can’t work on a file at the same time that you're work-
ing on it. If you select this option, you need to add information that
will identify you to your collaborators.

Local/Network: Here you only need to specify the location of the
remote folder on the network or a local drive, which you can enter
manually or by clicking the folder icon to browse the network for the
folder location. See the bottom three items in the preceding FTP
bullet for information on other Local/Network settings.

e RDS: If you select RDS from the drop-down list, you need to click

the Settings button next to the list to configure the RDS connection,
as shown in Figure 3-5. To configure RDS, you need a host name

(IP address or URL), port number (the default is 80), the directory of
the site on the host, a username, and a password. If you don’t want
the password saved, then deselect the Save check box.

RDS Server %]

Host name: | Test Site

Pt | BU

Full Hust Divectony, | #6hinstpubmiwrooth

Usomame: | 3covatt

Passwnid | sessssss [¥] Save

Lok [ Cencd

¢ Microsoft Visual SourceSafe: As with RDS, with SourceSafe you have

to click the Settings button next to the drop-down list. Then you
specify the location of the SourceSafe Database Path (a path to an
.ini file, usually on a network volume), the name of the project, a
username, and a password. If you don’t want the password saved,
deselect the Save check box.

e WebDAV: You need the URL of the connection, a username, a pass-

word, and a checkout name and e-mail address. If you don’t want the
password saved, deselect the Save check box. You also have three
options, one of which is selected by default. See your documentation
for details.

6. Click OK to put the changes into effect.
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Figure 3-6:
Choosing a
testing
server.

You can configure a number of advanced settings with Dreamweaver.
You’re not likely to need most of them, but just in case, we describe them in
the following sections. You can access all these options by selecting the
name of the item in the Category list of the Site Definition dialog box (refer
to Figure 3-2).

Testing your server

Select Testing Server from the Category list on the Advanced tab of the Site
Definition dialog box to access the options for setting up your testing server.
If you're building a dynamic site, you need to have a Web server running that
can process the pages and render them as HTML. To specify a Web serving
technology, do the following:

1. Select a Web server from the Server Model drop-down list, as shown
in Figure 3-6.

You have several options here; if you’re working within the old
Macromedia model, your selection is probably going to be ColdFusion.
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2. Select an Access type.

You can choose FTP or Local/Network. If you chose RDS on the Remote
Info screen, you see an RDS option here as well. Choosing any of them
provides additional fields for you to fill out, as specified for each Access
type in the “Setting Up a Remote Connection” section, earlier in this
chapter. Choose None if you don’t want to use a testing server.

3. Click OK to save your settings.

Cloaking

Cloaking is a handy and appropriately named feature in Dreamweaver Sites.
When enabled, cloaking allows you to hide different file types or folders from
Dreamweaver’s site tools. This feature can be especially helpful if you keep your
raw asset files (your source Fireworks PNGs, Flash FLAs, and so on) in the same
directory as the site itself, but you don’t want the files uploaded or downloaded,
included in reports, or otherwise touched by various Dreamweaver operations.
To engage this feature, click the Advanced tab of the Site Definition dialog box
and select Cloaking from the Category list on the left. Then select the Enable
Cloaking and Cloak Files Ending With check boxes and add the file extensions
for the file types you want to mask. See the online Help files for more details.

Using Design Notes

Design Notes aren’t really necessary unless you're collaborating on a site
with other people. In that case, Design Notes can be especially helpful. For
example, you can use Design Notes to let others know the status of a given
file. To engage Design Notes, click the Advanced tab of the Site Definition
dialog box, select Design Notes from the Category list on the left, and then
simply select the Maintain Design Notes check box. If you want to move the
notes to the server when the site is published so that other team members
can access them, select the Upload Design Notes for Sharing check box.

Setting up a site map

If you select Site Map Layout in the Category list in the Site Definition dialog
box, you can set up the specifics of how you’d like your site’s site map to
look. You can specify the following:

4 The home page for the site map, which can be different from the home
page (index.htm) of the site

4 The number and width of the columns of the map

4 The labels for the site map icons

4+ Whether to display items marked hidden

4+ Whether to display dependent files
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Figure 3-7:
The File
view.

Selecting columns for File view

For the File view, shown in Figure 3-7, you have six built-in columns to
choose from: Name, Notes, Size, Type, Modified, and Checked Out By.

However, you can also add and remove your own columns by clicking the (+)
and (-) buttons, respectively. For a column you create, you can also specify

the following:

4 The column name

4+ The column’s Design Note association, if its contents relate to a specific

Design Note

<+

The text alignment for the column

4 The option to show or not show the column in the File view
(NVote: The Name column cannot be hidden or moved.)

4 Whether to share the column so that other workers on the site can see it
(Note: You must have Maintain Design Notes selected to share a column.)
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Enabling Contribute compatibility

To enable compatibility with Contribute, click the Advanced tab of the Site
Definition dialog box and select Contribute from the Category list on the left.
Select the Enable Contribute Compatibility check box if you plan to have
people maintain your site using Contribute. Selecting this option allows you
to perform many administrative functions related to Contribute (for exam-
ple, you can send Connection Keys based on your Dreamweaver Site setups).

Updating templates

When you create a document-relative link in a template file, the link is rela-
tive to the template. By default, when you create a page from the template,
Dreamweaver automatically adjusts the link to have the correct pathname
relative to the created page. To disable that feature, click the Advanced tab
of the Site Definition box and select Templates from the Category list on the
left. Select the Template Updating check box to remove the check.

Storing Spry Assets

The Spry framework, which incorporates JavaScript, CSS, and XML, allows
nonprogrammers to put fancy navigation and animation on Web sites with a
minimum of fuss. Book I, Chapter 7 offers instructions for using Spry to create
aricher user experience on your Web site. When you insert the first Spry
component in your site, Dreamweaver automatically creates a SpryAssets
folder in your root directory, where it places the JavaScript and CSS files.

To use a custom location for Spry Assets, click the Advanced tab of the Site
Definition box and select Spry from the Category list on the left. Enter the
location of your Spry Assets folder by typing or pasting it, or better yet, click
the folder icon at the right to browse to the folder.

Publishing Your Site

After you’ve set up a remote site in a Dreamweaver Site, publishing your Site
is a snap. To publish your Site to a remote server, just follow these steps:

1. If the Files panel isn’t already open, open it by choosing Window=>
Files or by pressing F8.

2. On the File tab, click the Expand/Collapse button (the button on the
far right of the toolbar) to switch to File view.

This brings up the File view shown previously in Figure 3-7.
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Figure 3-8:
Remote and
local sites.

.3

Publishing Your Site

If you haven’t connected to the remote server since you launched
Dreamweaver most recently, click the Connection button at the left
of the Files panel toolbar to establish a connection with the remote
server.

When you’re connected, you see the File view shown in Figure 3-8.

. Select a file and click the Put button on the toolbar (an upward point-

ing blue arrow) to copy a file from the local server to the remote
server, or click the Get button (a downward pointing green arrow) to
copy a file from the remote server to the local server.

If you're copying files for the first time, simply select the Site’s root
folder and click the Put button. To copy files from the Local to Remote
servers, or vice versa, you can also simply click and drag the elements
from local to remote, or vice versa. If you use this method, be careful to
place files in the correct folders.

If you ever want to see what’s going on behind the scenes when you’re copy-

ing

those files, just click the FTP button in the toolbar in File view. The Results

panel appears or expands and shows you the remote connections being set
and all the commands for the files being sent (the File view collapses back to
the Files panel as well).

File
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Maintaining Your Site

Figure 3-9:
The Reports
dialog box,
with some
options
selected.

After your Site is built, you want to make sure that it continues running at
peak efficiency. To help in this effort, Dreamweaver offers some valuable
tools that can help you keep on top of the wide array of items that go into
keeping your Site running smoothly. We describe the two basic types of
tools, reports and link checkers, in detail in the following sections.

Running reports

Reports encapsulate information about various aspects of your Site at the
time the reports are run, giving you a snapshot of information such as which
files on your Site are currently being worked on by different team members,
whether all the images on a selected page have Alt tags, and more. To run a
report in Dreamweaver, just follow these steps:

1. Choose SiteoReports.

The Reports dialog box appears, as shown in Figure 3-9.
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2. Choose what you want to run the report against.

You can choose to run a report on the currently selected document, the
entire site, selected files in the site, or a folder within the site. Select one
of these options from the Report On drop-down list.

3. Select the reports you want to run by selecting the check boxes next
to their names.

You can run nine possible reports across two categories: Workflow and
HTML Reports. The nine reports are as follows:
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¢ Checked Out By: This report tells you what files in source control
are currently being used by different members of the team. If you
want the report to show only which files are currently checked out
by a particular team member, click the Report Settings button at the
bottom of the dialog box while the report is selected and add an indi-
vidual’s name to the text field in the Checked Out By dialog box that
pops up.

¢ Design Notes: This report prints all the Design Notes associated with
files on the site. To filter your results via the Design Notes dialog box,
click the Report Settings button while the Design Notes report is
selected.

¢ Recently Modified: This report shows which files have been modi-
fied within parameters you set by clicking the Report Settings button
and specifying the parameters in the Recently Modified dialog box
that pops up.

¢ Combinable Nested Font Tags: This report details locations in the
code where overlapping Font tags could be merged. For example, if
you change the size of a block of text, your code might contain some-
thing like this:
<FONT face="Arial"><FONT size="2">Some
text.</FONT></FONT>

When it could and should be
<FONT face="Arial" size="2">Some text.</FONT>

¢ Accessibility: If you run this report, the site files are scanned to find
places where the code is not ADA (Americans with Disabilities Act)
compliant. For more information about accessibility, browse to the
W3C Web Accessibility Initiative pages at www.w3 .org/WAT/
Resources/.

¢ Missing Alt Text: This report looks for images to make sure they
have Alt text, which is not only a best practice but also important for
accessibility. (See the section on modifying an image in Book I,
Chapter 2 for a little more information on Alt text.)

¢ Redundant Nested Tags: This report searches the code for locations
where extra tags can be eliminated.

¢ Removable Empty Tags: If you're working in Design mode and
moving many things around, sometimes the underlying code can be
left with lingering, empty tags. This tool finds those empty tags.

e Untitled Documents: This report searches for pages that may have a
filename but don’t have a title.



Figure 3-10:
A site report
inthe
Results
panel.
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4. Click Run to run the reports.

The results appear in the Site Reports tab of the Results panel, as shown
in Figure 3-10.
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Checking links

In addition to the reports that help clean up your code, Dreamweaver can
also check the links on your site. To run the Link Check report, choose
Siter>Check Links Sitewide or press Ctrl+F8. You see the results in the Link
Checker tab in the Results panel. The report shows broken links, external
links, and orphaned files.

Using Source Control

Source control allows team members to check out a document in your site,
thereby locking it and making it uneditable by others until the team member
who checked it out checks it back in again. This process is intended to
ensure that files don’t get overwritten accidentally and that data doesn’t

get lost during the development process.

In most large-scale software development projects, in which multitudes of
people work on a single code-base, source control is critical. If your site
requires that more than three people work on the same pages and code, you
should consider taking advantage of this feature in Dreamweaver.

To set up source control, do the following:

1. Choose Siter>Manage Sites, select your site, and then click the Edit
button to open the Site Definition dialog box.

2. Click the Advanced tab if it’s not already open and select Remote Info
from the Category list on the left.
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3. Set your source control options at the bottom of the screen.

NG/

4.

When you enable file check in and check out, the following options
become available:

¢ Check out files automatically when you open a document within
the site.

¢ Provide your name and e-mail address for site reporting and informa-
tional purposes.

You must have selected an Access option on the Remote Info screen
before you can get the file check in and check out options to show up at
the bottom of the page. See the “Setting Up a Remote Connection” section,
earlier in this chapter, for more information about Access options.

Click OK to save your settings.

To work with a file after you’ve enabled source control, right-click the file
from the Files panel and select one of the following options:

+
+

+

Get: Retrieves the most recent version of the file and copies it locally.

Check Out: Makes your local version the only editable version of a docu-
ment and ensures that others can’t open and save the file.

Put: Copies the local version of your file to the remote location.

Check In: Puts your local version of the file on the server and unlocks it
so that others can check it out and work on it, if necessary.



Chapter 4: Punching Up Your
Pages with Forms and Frames

In This Chapter

v+ Incorporating forms into your Web pages

v Structuring your pages with frames

' wo Web page features, forms and frames, are also two of the most
advanced features. You use them in your Web pages to serve the follow-
ing functions:

4+ Forms: Enable you to gather information and feedback from the users
who visit your Web pages. Forms can consist of text fields, buttons,
check boxes, radio buttons, and drop-down lists, all of which enable the
user to enter information or to choose among options you present.

4+ Frames: Enable you to construct sophisticated navigational schemes for
your Web site. Frames are actually separate Web pages that are parti-
tioned off so that two or more can be displayed in the same browser
window at the same time. For example, one frame may be a navigational
page consisting of a list of links to other pages; that frame remains in
place in its portion of the browser window even when the user clicks a
link to display a different Web page in the other frame.

In this chapter, you see how to work with these powerful features in
Dreamweaver CS3.

Incorporating Forms into Web Pages

Forms on the Web serve the same purpose as the paper-based forms you fill
out — they provide a structured format for gathering specific information.
The difference is that Web-based forms usually require less time for keyboard-
savvy users to fill out.

Dreamweaver offers you a number of handy tools for creating Web-based
forms that you can easily include on your Web pages. You can incorporate
everything from text fields to radio buttons, and create surveys, gather user
data, and conduct e-commerce.
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Figure 4-1:
The dashed
lines mean
that you've
created a
form!

Creating Web-based forms requires the following two steps:

1. Creating the form that users see and interact with, which we demon-
strate how to do using Dreamweaver in this chapter.

2. Creating the processing program that accepts and processes form input,
which is beyond the scope of this book.

Adding a form
Before you can insert specific form objects such as check boxes on your

Web page, you must first add a form to the page so that the appropriate
code is added to the HTML.

To add a form to a page, click in the Document window where you want to
add the form and choose Insert=>Form=>Form, or click the Form button from
the Forms category on the Insert bar. (If the Insert bar is set to a different
category, click and hold the category name and select Common from the
drop-down list.)

Dreamweaver adds the form to the page, as indicated by the red dashed
lines, and adds the associated form tag to your HTML page code, as shown
in Figure 4-1. You can now insert form objects inside the red dashed lines of
the form.
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If you attempt to add a form object without first adding a form, a dialog box
appears, asking whether you want to add a form tag. Click Yes to add both
the form tag and the object to your page.

Dreamweaver’s new Spry functionality includes form-specific widgets that
perform tasks such as text field validation. See Book I, Chapter 7 for more
details.

Specifying form properties

A form has six properties that you can set using the Form Property inspec-
tor: Form Name, Action, Method, Enctype, Target, and Class. Click the form
to open the Form Property inspector. (If the Property inspector does not
appear, open it by choosing Window=>Properties.) Then specify the follow-
ing properties:

4+ Form Name: Enter an alphanumeric name in the empty text field (the
name should start with a letter, but it can be made up of both letters and
numbers). The advantage of naming your form is that you can use the
name to reference the form in a scripting language that you use to
retrieve, store, and manipulate the form data.

4 Action: Enter the URL of the application document or file that processes
the form data. Alternatively, you can browse to the location by clicking
the folder and making a selection in the Select File dialog box.

You can select the following three common actions:

¢ Enter the URL of a ColdFusion page that evaluates the form after it
has been submitted.

e Enter the JavaScript program that runs after the user submits the
form. The action appears as follows:

javascript:function()
Here, function refers to the name of your form-handling function.

¢ Enter a mailto: address where the form data goes after the user
clicks the Submit button. A mailto: address appears similar to the
following:

mailto:worker@formhandling.com

4 Method: Select a method from the drop-down list for how the form data
passes to the processing entity that you specified in the Action field.
Choices are Default, GET, and POST. (Default and GET are the same.) GET
sends the form data by appending it to the URL that Action specifies.
POST sends the form data as a separate entity. GET limits the amount of
data that can pass along, but POST does not.
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In other words, if you were to choose GET, the URL sent to the
server might look something like http: //www.server.com/
coldfusionpage.cfm&bowlingballcolor=blue, with the form
data stuck onto the end. If you were to choose POST instead, the
URL would just look something like http: //www.server.com/
coldfusionpage.cfm.

Most of the time, whether you choose GET or POST doesn’t really make
a difference. However, there are times when you may want to choose
one over the other. For example, for security purposes, you may not
want information, such as a credit card number, ever being shown in a
browser’s history. And if the user might choose to bookmark the URL,
whether to have all the form data appear could affect your decision.

If the form data included secure user information (such as the credit
card example), then you probably wouldn’t want to have the form

data appear. However, if the form data includes search criteria, the
user might want to bookmark the URL complete with the search

parameters.
&_N\BEH Data received at the specified mailto: address is not formatted for easy
& reading: It appears as strings of code with the form data embedded

within it. This may depend on the encoding option, which we are about
to discuss.

4+ Enctype: This is an optional attribute. For enctype, your choices are
application/x-www-form-urlencoded and multipart/form-data.
The first one, application/x-www-form-urlencoded, replaces all
blank characters in the text with a plus sign (+), and it replaces other
nonprinting characters with symbols and numbers. These replacements
are often necessary for the server to interpret the information it is
receiving — for example, when you’ve used the GET method, the
browser would not be able to process a URL with blank spaces in it.
The multipart/form-data attribute does not do this conversion but
instead transfers the information as a compound MIME document. The
multipart/form-data attribute is the method that must be used if you
are using an <INPUT TYPE="file"> element in the form. Alternatively,
if the form action ismailto:, you can input text/plain, which will
send the data unencoded; however, this is not a W3C standard.

4+ Target: This is also an optional attribute. If you do not specify a target,
the server will assume that you want any information that is sent back
to the browser (the URL of the response page, for example) sent to the
same window or frame that your original form is in. If you wish the form
submission’s results to appear in a different frame or window, you must
specify the name of the target window in this attribute.

4+ Class: You can apply a CSS (Cascading Style Sheet) class to the form as a
whole and to some form elements in order to control how those form
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elements appear in a browser. For example, you can specify the color
of a text field by assigning it a style. This attribute is also optional.

For details on using CSS stylesheets, take a look at CSS Web Design For
Dummies, by Richard Mansfield (published by Wiley Publishing, Inc.).

Labeling form objects

Dreamweaver enables you to provide descriptors for form objects and provide
the user with directions about how to complete the information requested
for each option. To add descriptors to form objects, simply position your
cursor in the form and begin typing. Then insert the form object you want.

Using text fields

Text fields are blank text boxes that you can insert in your form to hold
alphanumeric information that the user types. You can set up a text field to
hold a single line of text, multiple lines of text, or a password, as follows:

4+ Single line: Provides space for the user to enter a single word or short
phrase of text.

4+ Multi-line: Provides space for the user to enter a longer string of text.
Appropriate for a comment box.

4+ Password: Provides space for the user to enter a password. An asterisk
or other placeholder appears in the text field for each character that the
user types to hide the password characters from anyone who might be
looking over the user’s shoulder.

To add a text field, follow these steps:

1. In the Document window, click where you want to add the text field
and choose Insert>Form=Text Field, or click the Insert Text Field
button on the Form category of the Insert bar.

If the Insert bar is set to a different category, click Form.

The Input Tag Accessibility Attributes window appears, unless you have
set your preferences otherwise.

2. Enter Accessibility information as desired and click OK.

This information is not required, but including it makes your form
easier to navigate for sight-impaired users. See your Dreamweaver
documentation for details.

Dreamweaver adds a text field to your form and a Text Field Property
inspector appears. If the Text Field Property inspector does not appear,
choose Window=>Properties to open the inspector.

Book |

[x)
-
[
=]
=3
@
=
-

sawel4 pue
swio4 yum sabed
inop dn Buiyoung



64 Incorporating Forms into Web Pages

3. Fill in the following fields of the Text Field Property inspector to
define the parameters of the text field:

TextField name: Enter a name in the empty field. The field is refer-
enced by this name in the HTML page code.

Char Width: Enter a whole number for the approximate visible
width of the field. (The width is approximate because text characters
in your form are displayed differently according to users’ browser
settings.)

Max Chars: (Applies to Single line and Password fields only) Enter a
whole number to indicate the maximum number of characters that
the user can enter in the field. Max Chars can be different from Char
Width.

Num Lines: (Applies to Multi-line fields only) This specifies the height,
in lines, of the form element, and may be affected by the setting for
Wrap.

Type: Select a radio button for Single line, Multi-line, or Password.
When you select Password, Dreamweaver includes code that makes
an asterisk appear for each character the user enters.

Init Val: (Optional) Enter an alphanumeric word or phrase that occu-
pies the text field when the user first encounters the field. Users can
enter their own information over the Init Val. If you leave this attrib-
ute blank, the user will see a standard empty text field.

Wrap: (Applies to Multi-line fields only) Select an option for text
wrapping from the drop-down list. Options consist of Default, Off,
Virtual, or Physical. Default and Off are the same and do not wrap
text until the user presses the Enter key. The Virtual option wraps
text on the user’s screen but not when the form is submitted. The
Physical option wraps text both on the user’s screen and when the
form is submitted.

Class: (Optional) You may assign a CSS class to a text field to affect
the appearance of the field or the text within it. For details on using
CSS style sheets, look up CSS Web Design For Dummies, by Richard
Mansfield (published by Wiley Publishing, Inc.).

Setting up buttons

After a user enters data into a form, the user must then perform some sort of
task to transmit the data from his or her computer to another computer that
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can process the information. Dreamweaver offers you three buttons you can
use to activate your form: Submit Form, Reset Form, and None:

4+ Submit Form: After the user clicks this button, the form data scoots off
to another computer based on the specified action. (You see how to set
the action of a form in the “Specifying form properties” section, earlier in
this chapter.)

4+ Reset Form: After the user clicks this button, it erases all data entered
into the form, resetting each form field to its initial value.

4+ None: After the user clicks this button, it executes the programming
function that the Web designer assigned to it (for example, performs a
mathematical calculation or sends the user to a different URL).

Follow these steps to insert a button into your form:

1. Click where you want to add the button in the Document window and
choose Insert>Form=>Button or click Insert Button on the Form cate-
gory of the Insert bar.

If the Insert bar is set to a different category, click Forms.

Dreamweaver adds a button to your form and the Button Property
inspector becomes visible. If the Button Property inspector does not
appear, choose Windowr>Properties to open the inspector.

2. Fill in the following fields of the Button Property inspector to define
the parameters of the button:

¢ Button Name: Enter a name in the empty text field. This name identi-
fies the button in the HTML code.

¢ Label: Enter the text that you want to appear on the button.

e Action: Select a radio button to indicate the function of the button.
Choices consist of Submit Form, Reset Form, and None.

¢ Class: (Optional) You can assign a CSS style to affect the button’s
appearance (color, width, and the like).

You can create a graphical Submit button — a button created from a small
image — by choosing Insert>Formr>Image Field or by clicking the Image
Field button in the Form category of the Insert bar. Then browse to the
image file in your site or type the path to and name of the image file directly
into the File Name field.
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Adding other form elements

In addition to the text fields and buttons, you can add a variety of form ele-
ments that help your users give you information. Figure 4-2 shows some

of the useful form elements you can add to your forms. To insert any of the
elements you see in Figure 4-2, follow these steps:

1. Position your cursor in the area of the Document window where you
want to add the element.

2. Click the appropriate button in the Form category of the Insert bar
(see Figure 4-2) or choose Insert~>Form Objects~>Desired Form Element.

Create Check Jump Spry Validation
Form Box Menu  Label TextField
Spry
Hidden | Radio File Validation
Field Group Field Checkbox
Figure 4-2: l 4_ L i
Insert | Common mes Dk Sory et | F fes =
Form W m .—IY 5} T & 'r' £ T i) 'T- awd )3 GR &4 [

== | &
elements. | | | | |

Text Radio Image Field Spry
Field Button Field Set | Validation
Select

Text Area  ListMenu Button  Spry Validation Textarea

If the Insert bar is set to a different category, click Forms.

3. If the Input Tag Accessibility Attributes window appears, enter
Accessibility information as desired and click OK.

This information is not required, but including it makes your form
easier to navigate for sight-impaired users. See your Dreamweaver
documentation for details.

Dreamweaver adds the element to your form and the appropriate
inspector appears. (If the appropriate inspector does not appear, open it
by choosing Windows=>Properties.) Note: You must save your document
before inserting a Spry widget.

4. Fill in the fields of the Property inspector.

If you're adding a radio button group, jump menu, or image, a dialog box
will pop up and ask you for additional information. Fill in your choices
for each of these.

5. Click OK to apply your selections and close the dialog box.
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Frames are divisions of a Web page that enable you to load information inde-
pendently into distinct regions of the browser window. Frames are useful if
you want to display certain information on-screen while changing other
information. You frequently see three-frame pages on the Web — the top
frame shows the site’s title graphic, the left frame shows the navigation bar,
and the large body frame changes to show the content that you select.

A special HTML page called a frameset defines the structure and formatting
of frames on your Web page. As you work with frames, be aware that you
must always save the frameset page to lay out the size, position, and borders
of your frames, along with the content that you want to display in each
frame. Keep in mind that different browsers may draw the frames slightly dif-
ferently, even if you specify exact pixel dimensions.

You can create a frameset two ways in Dreamweaver:

4 From scratch

4+ By adding a frame to an existing document

We detail each in the following sections.

Creating a frameset from scratch

When you create a frameset from scratch, you create the frameset and all
the frames it describes in one fell swoop. To create a frameset using one of
Dreamweaver’s built-in templates, just follow these steps:
1. Choose Filec>New, or use the keyboard shortcut Ctrl+N.
The New Document window appears.
2. Click Page from Sample on the left.
The Sample Folder, Sample Page, and preview panes are updated.
3. Click Frameset in the Sample Folder area.
The Sample Page pane and preview areas are updated.
4. Click a Sample page.

The preview area shows you what the frameset will look like, as shown
in Figure 4-3.

5. Click Create.

The New Document window closes and the Frame Tag Accessibility
Attributes window appears. The document window displays the new
frameset.
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Figure 4-3:
Creating a
frameset the
easy way.
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6. Select a frame from the Frame drop-down menu and type or paste a
name in the Title field. Repeat until you’ve entered titles for all your
frames and click OK.

This step is optional. Adding titles to your frames makes them easier to
navigate for sight-impaired users. Dreamweaver automatically gives the
frames generic titles. If you don’t want to enter custom titles, simply
click OK. The Frame Tag Accessibility Attributes window disappears
and your document window displays the frameset.

Adding frames

You can add a frame to a frameless Document window or to an existing
frame within the Document window. Adding a frame to an existing frame
divides that frame into two or more regions.

To add a frame, click the Document window or existing frame in the area
where you want to add the frame. Then click the Frames button in the Form
category of the Insert bar and choose from the list of options that pops up.
You can also get to an equivalent list (the same options, some with slightly
different names and no icons) by choosing Insert->HTML=>Frames>

Frame Option, where Frame Option is one of the choices detailed in Table 4-1.

Table 4-1 Options for Creating Frames

Frame Option What It Does

Left Creates a vertical frame down the left side
Right Creates a vertical frame down the right side

Top Creates a horizontal frame across the top
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Frame Option

What It Does

Bottom

Creates a horizontal frame across the bottom

Bottom and Nested Left

Splits the page in two — top and bottom — and creates a
left frame in the top frame

Bottom and Nested Right

Splits the page in two — top and bottom — and creates a
right frame in the top frame

Left and Nested Bottom

Splits the page in two — right and left — and creates a
bottom frame in the right frame

Right and Nested Bottom

Splits the page in two — right and left — and creates a
bottom frame in the left frame

Top and Bottom

Creates three frames

Left and Nested Top

Splits the page in two — right and left — and creates a top
frame in the right frame

Right and Nested Top

Splits the page in two — right and left — and creates a top
frame in the left frame

Top and Nested Left

Splits the page in two — top and bottom — and creates a
left frame in the bottom frame

Top and Nested Right

Splits the page in two — top and bottom — and creates a
right frame in the bottom frame

A third method of adding a frame is to drag the outer border of the current
frame or Alt+click (Opt+click on a Mac) in the inner border. You can then
follow the steps in the next section to modify this new frame.

Modifying frames

You use the Frame Property inspector to select the source page that appears
in a frame. You also use the Frame Property inspector to format the appear-
ance of an individual frame. To modify a frame, follow these steps:

1. If the Properties panel is not already open, open it by choosing
Window~>Properties or by using the keyboard shortcut Ctrl+F3.

2. In the Frames panel, Alt+click (Opt+click on a Mac) the frame whose
attributes you want to modify.

Note: You can’t simply click a frame to open its associated Frame Property
inspector. If you click a frame, you're actually clicking the source page
that resides in the frame — a process identical to clicking in the Document
window for that page. To select a specific frame, press the Alt key and click
in the frame. You see the Frame Property inspector for an individual frame
and the selected frame marked with a dashed line, as shown in Figure 4-4.

A Frame Property inspector appears for the selected frame. If the inspec-
tor doesn’t appear, open it by choosing Window=>Properties.
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3. In the Frame Property inspector or the Attributes tab of the Tag

Inspector panel, enter a name for your frame in the Frame Name
text field.

This name is the name by which the frame is referenced in the Frames
panel, target drop-down lists, and the HTML page code.

&,N\BER The frame name must start with a letter, and you should not use hyphens,
& spaces, or periods. You should also avoid using JavaScript-reserved
names, such as top. Although these words and symbols may be accepted,
if you are using any scripting (JavaScript, VBScript) to manipulate your
frames, the results may be inconsistent or wrong. It’s a good idea to get
into the habit of avoiding these words and characters. Word separation
can be indicated by capitalization, and underscore characters can also
be used.
4. In the Src text field, enter the name of the source page whose content
you intend to display in the frame.
Alternatively, you can click the Src folder and browse to select the
source page.
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5. Select a scrolling option for your selected frame from the Scroll drop-
down list. The options are as follows:

¢ Yes: Adds scrollbars to the frame, whether they’re needed or not.

e No: Doesn’t add scrollbars to the frame, even if a scrollbar is needed
to display the entire frame.

e Auto: Places one or more scrollbars in the frame if the frame con-
tents exceed the frame boundaries.

e Default: Places one or more scrollbars in the frame, depending on
the user’s browser settings.

6. Select the No Resize check box if you don’t want the user to be able to
resize the frame.

If you do want the user to be able to resize the frame, leave the check
box deselected.

7. Format the frame border appearance by selecting a choice from the
Borders drop-down list:

¢ Yes: Creates a three-dimensional look for the borders. (This doesn’t
work in all browsers.)

e No: Creates a single-color flat look for the borders, or, if No is
selected for each of the frames in a frameset, no border appears.

e Default: Enables the user’s browser to set how borders appear.

8. Select a border color for the frame by clicking the Border Color
swatch and selecting a color from the Color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Border
Color text field. This doesn’t work in all browsers and is optional. If your
frames don’t have borders, the border color will not apply.

9. Enter a number in pixels in the Margin Width and the Margin Height
text fields.

Margin Width specifies the horizontal standoff space between the frame
content and the frame border. Margin Height specifies the vertical standoff
space between the frame content and the frame border. This is in addition
to any values that the page called into the frame already has assigned.

Deleting frames

To delete a frame, select the frame border and drag it to the edge of the
parent frame or to the edge of the Document window — whichever is closer.
If you only have two frames on the page, this action will result in a frameset
with only one page in it.

Book |

[x)
-
[
=]
=3
@
=
-

sawel4 pue
swio4 yum sabed
inop dn Buiyoung



72

A\

Structuring Pages with Frames

Saving frames

Saving a frame means that you're saving the HTML page from which the
source content of the frame originates. To save a frame, follow these steps:
1. Select the frame by clicking in it.
2. Choose Filew>Save Frame.

3. The first time you save the frame, enter a name in the File Name text
field of the Save As dialog box that appears and then click the Save
button.

Future saves require that you complete only Steps 1 and 2.

Saving framesets

Saving a frameset means saving the layout of frame positions, frame names,
and border formatting on a page. Keep in mind that you must save individual
frames to save the content contained in those frames. To save a frameset,
follow these steps:

1. Select the frameset by clicking one of its borders.
2. Choose FileZ>Save Frameset.

Note: This will not work if the frameset is nested.

3. The first time you save the frameset, enter a name in the File Name
text field of the Save As dialog box that appears and then click Save.

Future saves require that you complete only Steps 1 and 2.

If you have made changes to individual frames — not just the frameset —
since your last save, Dreamweaver asks whether you want to save individual
frames. Make sure that you do so.

Setting no-frames content

Text-based browsers and many older browsers frequently don’t support
frames and can’t correctly display pages that you create by using frames.

To help ensure that the maximum number of users can view your page cor-
rectly, Dreamweaver offers you a method for building no-frames pages as
companions to your frame-enabled pages. To create a no-frames page for
your current frameset, follow these steps:

1. Choose Modify->Frameset->Edit NoFrames Content.

A blank, NoFrames Content page appears in the Document window and
replaces your frame-enabled page, as shown in Figure 4-5.
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2. On the NoFrames Content page, insert the content that you want to
appear in NoFrames browsers.

This content can include text, images, and other page elements.

3. Return to your frame-enabled page by choosing Modify->Frameset->
Edit NoFrames Content.

Targeting content

You can set up a two-frame frameset in which you use the left frame for navi-
gation and the main frame to display any link that the user clicks in the navi-
gation frame. Simply set up the link to target the main frame as the location
where you want the selected HTML page to open.

Set up a target by following these steps:

1. Select the text or image that you want to act as a link.

Doing so opens the associated Property inspector. If the inspector doesn’t
appear, open it by choosing Window=>Properties.

2. In the Link field, enter the name of the HTML source page that will
appear in the frame.

Alternatively, you can click the Link folder and browse to select the
source page.
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3. From the Target drop-down list, select the target frame where the link
is to appear.

All available targets are listed in the drop-down list, as shown in Figure 4-6.
These targets include the names of all frames that you set up and also
the following systemwide targets:

e _blank: Opens a new browser window and shows the link in that
window. The current window remains open.

e _parent: Opens the link in a window that replaces the frameset
containing the current page.

e _self:Opens the link in the current frame. The linked page replaces
the page in the current frame. If you want the link to open in the cur-
rent frame, you can select _self or leave the Target area in the
Property inspector empty.

e _top: Opens the link in a window that replaces the outermost frame-
set of the current page. (Same as _parent, unless you're using
nested framesets.)
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Targeting can work in more complicated framesets using the same basic
process. Whichever frame you target is the one that will update when the
user clicks a link targeting that frame.

Adding IFrames

An [Frame allows you to embed one HTML page in another HTML page with-
out having to create a frameset (the / in [Frame stands for inline). To insert
an [Frame into an HTML page, follow these simple steps:

1. Click in your document where you want the IFrame to go.

2. Click Layout in the Insert bar if Layout is not already selected.

3. Click the IFrame button.

The Document window shows that the IFrame has been inserted, as
shown in Figure 4-7.

Any content you enter inside the I[Frame tags functions as alternative
content for users whose browsers don’t support [Frames.
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4. Right-click inside the <iframe> tag and select Edit Tag from the menu

that appears.

The Tag Editor window appears, open to the General area.

. Enter a filename or click Browse to navigate to the Source file (the

HTML page or other content that will appear inside the IFrame).

The only required field is Source, because that field determines what
goes in the [Frame; the rest of the settings control how the I[Frame looks
and functions.

. Enter other settings as necessary and click OK.

The Tag Editor disappears, and the document window is updated. To see
your IFrame in action, choose Filew>Preview in Browser=Browser Name
or use the keyboard shortcut F12 (PC only).



Chapter 5: Laying Out Pages with
AP Divs and AP Elements

In This Chapter

v~ Distinguishing between divs and AP Divs

v+~ Using a tracing image

v~ Adding, selecting, and deleting an AP Element
v Placing objects in an AP Div

+ Changing AP Element properties

+ Nesting AP Divs

T) lay out the content of your Web page precisely, you can use tables (see
Book I, Chapter 2), or you can use the latest and greatest layout aid: AP
Divs. You can think of AP Divs in Dreamweaver as separate pieces of transpar-
ent paper that you fill with content (images, text, and so on) and shuffle, stack,
position, and overlap until your Web page looks exactly the way you want.

Dreamweaver AP Divs use a now common companion to HTML called
Cascading Style Sheets Positioning (CSS-P) in order to place your content
anywhere on the screen. However, you should be aware that Cascading Style
Sheets are supported inconsistently across browsers (what looks perfect in
Internet Explorer 7 might not look the same in Safari or Firefox). For more
information about Cascading Style Sheets, check out CSS Web Design For
Dummies, by Richard Mansfield (published by Wiley Publishing, Inc.).

One of the chief advantages of CSS-P is that you can use it to place elements in
Absolute Positions (the AP in AP Elements) on your Web page without using
tables. You can make any page element (an image or a block of text, for exam-
ple) into an AP Element in Dreamweaver by giving it an absolute position.

Distinguishing divs from AP Divs

If you have any familiarity with CSS, you might also know Divs by the name
they used to be called in Dreamweaver: AP Divs. Most commonly, when you
add an AP Element to a page, you're adding an AP Div. Much of the information
in this chapter about AP Divs may be applied to regular divs as well
(naming, nesting, and AP Diving, for example). We use the generic term div
when the information applies to both kinds of divs.
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Tracing a Design

You can add a regular old div to a page with a click of a button, but we

focus here on AP Divs because they’re easier for a beginner to work with.
Why'’s that? Because, unlike regular divs, you can draw AP Divs right on your
document, saving yourself the trouble of sizing and positioning the div after
adding it to your page.

Before you begin working with AP Divs, you may find it useful to have the
Insert panel open to the Layout category (click Layout in the Insert panel

to make it active) and the document in Design view (click Design in the
Document window). To open the AP Elements panel, if it’s not already open,
press F2 or choose Window=> AP Elements. When you have several AP Divs in
your document, the AP Elements panel may come in handy.

Tracing a Design

If you're using AP Divs to reproduce a page designed in Fireworks, Photoshop,
or Illustrator, you can take advantage of the tracing feature in Dreamweaver.
It works just like putting a piece of tracing paper on top of a photograph and
tracing the image (in that analogy, the tracing image is the photograph, on
top of which you’ll “trace” your AP Divs).

To trace a page design, follow these steps:

1. Choose Viewr>Tracing Imager>Load.
The Select Image Source window appears.
2. Navigate to the file and click the filename.
The tracing image can be a PNG, PSD, GIF, or JPEG file.
3. Click OK.
The Page Properties window appears, open to the Tracing Image category.

If the tracing image is not in your site root folder, you may see a window
asking if you want to copy the image to the site root folder. You don’t
need to do so, but you may. We usually click No.

4. Drag the Transparency Slider as needed.

If you drag it all the way to the left, your tracing image will be invisible —
not very useful as a tracing image. If you drag it all the way to the right
(the default setting), your tracing image will be totally opaque.

5. Click OK.

The tracing image appears in the Document window, allowing you to
“draw” your AP Divs directly on top of it. Note that the tracing image is
not a background image — it won’t appear in a browser.
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You can go back and adjust the transparency of the tracing image at any time
by choosing Modify=>Page Properties and clicking Tracing Image on the left
of the window that appears.

AP Element Preferences

To choose different default settings for when you add an AP Element to a
page, choose Edit>Preferences; the Preferences dialog box appears. Click
the AP Elements Category on the left to view the AP Element default settings
that you can change, as shown in Figure 5-1.

Figure 5-1:
Setting your
default
preferences
for AP
Elements.

Prefarences %]
AP Chnents
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oesting: [] Mest whven crested vithin an AP dv
Hetscape 4 compatiblity: [ Add resize fix when inserting AP element
oar
Lalurs Bar
o
o ) Cm

Adding an AP Div

You can add an AP Div to the workspace of your Document window, shown
through the drawing method in Figure 5-2, using one of the following two
methods:

4 Choose Insert~>Layout =>Objects=>AP Div. If nothing is on the page
already, as in this case, a new AP Div appears in the upper-left corner of
your Document window.

4 Click the Draw AP Div button (just to the right of the Insert Div Tag
button) on the Layout category of the Insert bar. (If the Insert bar is
not set to the Layout category, click Layout.) Position the cross-hair
cursor anywhere in your Document window and click and drag until the
AP Div obtains the dimensions you want. Release the mouse button.
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<\® If you set an AP Div’s visibility to Hidden, it may be invisible in the Document

window. To see it, simply click the name of the AP Div in the AP Elements
tab of the CSS panel. Now you can see the AP Div, even though its visibility
remains set to Hidden. See the “Changing the visibility of an AP Div” section,
later in this chapter, for details on Visibility settings.

Selecting an AP Div

Selecting an AP Div enables you to identify which AP Div you want to affect
when executing an AP Div operation, such as moving or naming the AP Div.
Use either of the following methods to select an AP Div:

4 In the Document window, click on the boundary of the AP Div. Before
you select the AP Div, your cursor will turn into a four-pointed arrow
(PC) or Grabber hand (Mac) when you place it over an AP Div boundary;
the cursor becomes a white arrow (PC) when you place it over a Div
boundary.

4 In the AP Elements tab of the CSS panel, click the name of the AP Div.



Changing AP Div Properties 81

The boundary becomes a thick blue line when the AP Div is selected. Also,
selection handles appear on the boundary of the AP Div to indicate that you
have selected it. The cursor becomes a double-sided arrow when you roll
over a selection handle.

Deleting an AP Div

A\

Deleting an AP Div removes the AP Div, the AP Div’s contents, and the AP Div
marker from the Document window. To delete an AP Div, select the AP Div
and press the Del or Backspace key.

Don’t delete an AP Div if you want to remove it from one page and add it to
another. Instead, cut the AP Div by choosing Edit=>Cut or by pressing Ctrl+X.
Open the page where you want to add the AP Div and choose Edit=>Paste or
press Ctrl+V.

Placing Objects in an AP Div

To add an object to an AP Div, click inside the AP Div and follow the normal
procedure for adding the object. For instance, add text to an AP Div by click-
ing inside the AP Div and typing text; add other objects to an AP Div by click-
ing inside the AP Div and choosing Insert>Object, where Object is the name
of the item you want to add to the AP Div.

Changing AP Div Properties

You can change lots of properties of AP Divs, including

4+ Background: You can add a background image or color to an AP Div.

4+ Name: Naming an AP Div can help you keep track of objects on a com-
plex page, and is necessary if you want to apply behaviors to the AP Div.

4+ Alignment: You can align AP Divs with each other.

+

Visibility: AP Divs (and the objects on them) can be visible or invisible.

4+ Position: AP Divs can be nested inside other AP Divs; they can also be
stacked in different orders.

4+ Size: You can change the AP Div’s height and width.

4+ Location: You can move an AP Div to any location on a page.
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We show you how to edit each of these AP Div properties in the following
sections.

Including a background image or color in an AP Div

By default, an unnested AP Div does not have a color or background image
and will just display what lies beneath it as if it were transparent. (A nested
child AP Div, if it’s empty, will show the color or background image of its
parent. For more about nested AP Divs, see the “Nesting AP Divs” section,
later in this chapter.)

You can change the background of any AP Div by adding a background image
or color as follows:

1. Select the AP Div whose background you want to change by clicking
the AP Div’s border on the document or clicking the AP Div name in
the AP Elements panel.

If the CSS-P Element Property inspector does not appear, open it by
choosing Window=>Properties.

2. In the CSS-P Element Property inspector, change one of the following:

¢ Bg Image: Click the folder to the right of the text field and browse to
select a background image from the Select Image Source dialog box
that appears. Click the Select button to accept your image choice
and close the dialog box. The path to and name of the background
image appear in the Bg Image field and the image is added to the
background of the AP Div. Figure 5-3 shows an AP Div with a back-
ground image.

If the image is smaller than the AP Div, the image will tile to fill the AP
Div; if the image is larger than the AP Div, the image will be cropped
to fit within the AP Div.

¢ Bg Color: Click the color box (the little gray box with an arrow on it)
and select a color from the color palette that appears. Alternatively,
you can enter a hexadecimal number for a color in the Bg Color field.
The new color appears in the background of the selected AP Div (as
long as there isn’t a background image in the AP Div already).

Naming an AP Element

The first AP Div you add to a page is automatically named AP Divl, the
second AP Div you add is named AP Div2, and so on. You can change these
default number names to other names that help you more easily distinguish
AP Divs when working with HTML and examining AP Divs with the CSS-P
Element Property inspector or AP Elements tab of the CSS panel.
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To name an AP Element using the AP Elements tab of the CSS panel, follow
these steps:
1. If the AP Elements tab of the CSS panel is not already visible, choose
Window=>AP Elements or press F2.
2. Double-click the Name column for the AP Element whose name you
want to change.
The current name is selected.
3. Enter a new name for the AP Element.
Remember that AP Element names can contain only letters and numbers
and must start with a letter.
You can also name an AP Element by double-clicking its name in the CSS-P
Element Property inspector and entering a new name. The name updates
automatically in the AP Elements tab of the CSS panel.
\\3

Get in the habit of appropriately naming your AP Divs as soon as you create
them. The name BlueprintimageMap helps you remember an AP Div’s content
much better than APDivi15.
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Aligning AP Elements

Aligning AP Elements with each other can help you precisely lay out visual
content in the Document window. You can align the top, left, right, or bottom
sides of AP Elements.

To align AP Elements, select the AP Elements you want to align by pressing
and holding the Shift key and then clicking each AP Element in the Document
window. Choose Modify=>Arrange and choose one of the following options
from the submenu:

4+ Align Left: Assigns the x-coordinate of the last selected AP Element to
all selected AP Elements.

4+ Align Right: Aligns the right side of all selected AP Elements with the
right side of the last selected AP Element.

4+ Align Top: Assigns the y-coordinate of the last selected AP Element to
all selected AP Elements.

4+ Align Bottom: Aligns the bottom of all selected AP Elements with the
bottom of the last selected AP Element.

4 Make Same Width: Gives all the AP Elements the same width as the last
selected AP Element.

4+ Make Same Height: Gives all the AP Elements the same height as the
last selected AP Element.

Changing the visibility of an AP Div

You can specify whether an AP Div is visible or hidden when a Web page
loads — first appears in the user’s browser window — and as a result of spe-
cific actions by the user. Visibility can change as many times as you want.
Visibility options consist of the following:

4 Default: The AP Div’s initial visibility is the default setting, which is
visible.

4 Inherit: For a nested AP Div, the AP Div’s initial visibility is the same as
the visibility of its parent. For an unnested AP Div, selecting the Inherit
option causes the AP Div to appear as visible.

4+ Visible: The AP Div’s initial visibility setting is Visible.
4+ Hidden: The AP Div’s initial visibility is Hidden.
You can use the CSS-P Element Property inspector or the AP Elements tab of

the CSS panel to set AP Div visibility. By setting AP Div visibility, you can
create scripts that cause images to appear (or disappear) in response to
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user interaction. For example, you can create an image of a gizmo that
appears on a Web page after a user clicks a link marked Click Here to See
Our Top-of-the-Line Gizmo!

To set the initial visibility of an AP Div via the CSS-P Element Property
inspector, select the AP Div in the Document window to open the CSS-P
Element Property inspector. If the inspector does not appear, open it by
choosing Window=>Properties. Choose a visibility option from the Vis drop-
down list.

AP Divving AP Divs: Setting the z-index

The z-index of an AP Div indicates the AP Div’s position in a stack of multiple
AP Divs. Z-indices are useful when you have a handful of AP Divs — some
containing transparent portions, some of different sizes — stacked one on
top of the other. Changing the z-index of your AP Div lets you “shuffle” the
AP Divs — much as you shuffle a deck of cards — to create interesting visual
effects.

Z-indices are measured in whole numbers and do not have to be consecutive —
for instance, you can have three AP Divs with z-indices of 1, 3, and 7, respec-
tively. The AP Div with the largest z-index sits on top of the AP Div stack and
the AP Div with the smallest z-index sits on the bottom of the AP Div stack.
AP Divs with larger z-indices obscure those with smaller z-indices. You can
change the z-index of an AP Div in either the CSS-P Element Property inspec-
tor or the AP Elements tab of the CSS panel.

To assign the z-index of an AP Div by using the CSS-P Element Property
inspector, follow these steps:
1. Select the AP Div to open the CSS-P Element Property inspector.

If the CSS-P Element Property inspector does not appear, open it by
choosing Window=>Properties.

2. Enter a new number in the Z-Index field of the CSS-P Element
Property inspector.

To assign the z-index of an AP Element using the AP Elements tab of the CSS
panel, follow these steps:

1. If the AP Elements tab of the CSS panel is not already visible, choose
Window=>AP Elements or press F2.
2. Click the Z column for the AP Div whose z-index you want to change.

The current z-index is selected.
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Figure 5-4:
Changing
the z-index
of the AP
Element
named
TextAndBg
Color.
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3. Enter a new z-index for the AP Div.

The new number appears in the Z column for the selected AP Div, as
shown in Figure 5-4.

4. Click anywhere outside the Z column or press the Enter key.

Note that you can have multiple AP Divs at the same z-index.
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To assign relative z-indices to AP Divs by reordering Divs in the AP Divs tab
of the CSS panel, follow these steps:

1. Open the AP Flements tab of the CSS panel by choosing Windowr>
AP Elements or by using the keyboard shortcut F2.

The AP Elements tab lists AP Elements in order of descending z-index.
Nested AP Divs are listed in descending order within their parent AP Div.

2. Click the name of an AP Element for which you want to change the
z-index.

3. Drag the AP Element name into a new list position and release the
mouse button.

As you drag, the selected AP Div is indicated by a thick line.

Figure 5-5 shows the effect of changing a z-index. In the top image, the z-index
of the bowling pins is higher than the starry background image. As a result,

the bowling pins are on top. Conversely, in the bottom image, the starry back-
ground image has the higher z-index value, and as a result, it’s on top of the

bowling pins. Dreamweaver reorders the list in the AP Divs tab and renumbers
AP Div z-indices to reflect your change. Also, Dreamweaver updates the asso-
ciated code for the AP Divs’ z-indices in the HTML source code for your page.

Because you don’t have to number the z-index of AP Divs consecutively, con-
sider leaving gaps between indices in case you later want to add new AP Divs
into the middle of the stack. For instance, use only even numbers for your
indices so that you can easily sandwich an AP Div with an odd-numbered
z-index in between.
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Figure 5-5:
The effect of
changing
z-indices.

Moving an AP Div

You may want to move an AP Div to another location in the Document
window or to a position relative to the grid or to other objects.

To move an AP Div, select the AP Div in the Document window and then
reposition your selection by using one of the following three methods:

4+ Click the AP Div’s border and drag the AP Div to a new location and
release the mouse button. The border highlights with a red line inside
the blue borderline to indicate that the AP Div can be moved.

4+ Press the arrow keys to nudge the AP Div up, down, left, or right one
pixel at a time. If you hold down the Shift key, every press of an arrow
key moves the AP Div by ten pixels.

4 In the CSS-P Element Property inspector, enter a new value in the T (top)
and L (left) fields to indicate the pixel coordinates of the AP Div’s top-left
corner.
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When moving AP Divs, you can choose to enable or prevent AP Div overlap,
depending on how you want the final image montage to appear. You enable
or prevent AP Div overlap by selecting or deselecting the Prevent Overlaps
check box in the AP Elements tab of the CSS panel.

Resizing an AP Div

Resizing an AP Div means changing its height and width dimensions. To resize
an AP Div, select the AP Div and perform one of the following tasks:

4+ Click and drag a selection handle — one of the large dots on the AP Div
boundary — until the AP Div is the size you want.

4+ In the CSS-P Element Property inspector, enter a new width in pixels in
the W field and a new height in pixels in the H field. If the CSS-P Element
Property inspector does not appear, open it by choosing Window=>
Properties.

You can change the height and width dimensions of multiple AP Divs at the
same time, provided the dimensions of the AP Divs you want to resize already
match. Simply follow these steps:

1. Press and hold the Shift key while selecting each AP Div you want to
resize.

If the Multiple CSS-P Elements Property inspector does not appear, open
it by choosing Window=>Properties.

2. In the Multiple CSS-P Elements Property inspector, enter a new width
in pixels in the W field and a new height in pixels in the H field.

Nesting AP Divs

A nested AP Div is an AP Div that has all of its HTML code lying within
another AP Div. The nested AP Div is often referred to as a child AP Div,
whereas the AP Div on which it depends is called the parent AP Div. A child
AP Div can be drawn completely inside its parent (as shown in Figure 5-6), in
an intersecting arrangement with its parent, or completely unattached to its
parent, depending on the effect you want to achieve. A nested AP Div inher-
its the same visibility of its parent and moves with the parent when the
parent AP Div is repositioned in the Document window.

Enabling nesting

To create nested AP Divs in the Document window, you must first enable
nesting. To do so, follow these steps:



Figure 5-6:
An AP Div
nested in
another
AP Div.

Nesting AP Divs 8 9

1. Choose Edit->Preferences to open the Preferences dialog box, or
press Ctrl+U.

2. In the Preferences dialog box, select AP Elements in the Category area.
3. Select the Nesting check box.
4. Click OK to close the Preferences dialog box.

5. In the Document window, choose Window=>AP Elements to open the
AP Elements tab of the CSS panel.

6. In the AP Elements tab, make sure that the Prevent Overlaps option is
deselected.

Creating a new nested AP Div

Use either of these methods to draw a nested AP Div after enabling nesting:

4+ Click inside an existing AP Div and choose Insert=>Layout Objects=>AP
Div. A child AP Div of default size appears inside the parent AP Div.

4+ Choose Layout Tools>Draw AP Div in the Layout category of the Insert
bar. Then click and drag your mouse in the parent AP Div, releasing the
mouse button when the AP Div has reached the dimensions you desire.
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Nesting an existing AP Div

To change the nesting of an existing AP Div, follow these steps:

1. Open the AP Elements tab of the CSS panel by choosing Window->
AP FElements or pressing F2.

2. In the AP Elements tab of the CSS panel, press and hold the Ctrl key
(38 key on the Mac) while using the mouse to click and drag the
intended child AP Div on top of its new parent.

The child AP Div is in the correct position when you see a box appear
around the name of its intended parent AP Div.

3. Release the mouse button.
The new child-parent relationship is shown in the AP Divs tab of the
CSS panel.

Dreamweaver draws the new child AP Div and updates the associated code
for changed AP Div-nesting in the HTML source code for your page.

Collapsing or expanding your
view in the AP Divs tab

You can change how you view the names of nested AP Divs in the AP
Elements tab of the CSS panel by collapsing or expanding your view:

4+ To collapse your view: Click the minus sign (-) in front of a parent AP
Div. Names of nested child AP Divs for that parent are hidden.

4+ To expand your view: Click the plus sign (+) in front of a parent AP Div.
Names of nested child AP Divs appear underneath that parent AP Div.



Chapter 6: Advanced Web
Page Design Techniques

In This Chapter

+ Creating hotspots

v~ Adding Flash text and button rollovers

v+~ Adding a rollover behavior to an image
+ Creating a navigation bar

v Inserting audio and video into your pages
v+~ Using templates

v Validating your code

In previous chapters of Book I, we focus on providing a good working
knowledge of Dreamweaver CS3. Now we need to spend some time look-
ing at the more advanced uses of Dreamweaver in Web development. In this
chapter, we show you how to make images a bit more striking and how you
can bring some other multimedia elements to life.

Creating Clickable Image Maps with Hotspots

You can designate certain areas of an image as hotspots — active areas that
a user can click to open a link to another Web page or activate some other
behavior. Hotspots can be shaped like rectangles, circles, or polygons (irreg-
ular objects). The coordinates of the hotspots are grouped into chunks of
HTML code called image maps.

Creating a hotspot

Check out Figure 6-1. It shows a typical navigation bar for a site as a single
JPEG image, with hotspots added. The following procedure shows you how
to create an image map for that image by adding hotspots:
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Figure 6-1:
A typical

JPEG | [reout us|i bur Goacy |EonTacT us

navigation
image with
hotspots.

. Select the image to which you want to add a hotspot.

The Image Property inspector appears. If the bottom half of the Image
Property inspector is not visible, click the Expander button, which is the
down arrow in the bottom-right corner.

. In the Map area of the Image Property inspector, click the Hotspot
button for the shape you want to draw.

You can choose a rectangle, a circle, or a polygon. Your mouse pointer
becomes a cross-hair cursor when you move it over the image.

3. Draw the hotspot according to the shape you select:

¢ Circle or rectangle: Click your cross hair cursor on the image and

drag diagonally to create a hotspot. Release the mouse button when
the hotspot reaches your desired dimensions. The area you draw is
highlighted light blue, and the Hotspot Property inspector appears.

Polygon: Click your cross hair cursor on the image once for each
point. The area you draw is highlighted light blue and the Hotspot
Property inspector appears.

Depending on your preference settings, you may see a window remind-
ing you to supply Alternate text for the hotspot. Click OK.

4. In the Hotspot Property inspector, supply the following information:

e Map: Enter a unique name for the image map.

e Link: Enter a URL or the name of an HTML file you want to open when

the user clicks the hotspot. Alternatively, you can click the folder
icon and browse to select the link from your files. Note: Completing
this field is optional. Instead, you may choose to attach a behavior
to the hotspot.

Behaviors: To attach a behavior other than a link to the hotspot, open
the Behaviors tab of the Tag panel by choosing Windowr>Behaviors
or by pressing Shift+F4. Then click the Add (+) button in the Behaviors
panel, which opens a pop-up menu of available behaviors, including
Check Plugin, Effects, Popup Message, Preload Images, and many
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others. Choose a behavior from the pop-up menu, complete the infor-
mation in the dialog box that appears for your selected behavior, and
click OK.

e Target: Complete this field if you entered a link in the Link field and
you want the link to open in a window or frame other than the one
you're linking from. Click the arrow and select from the drop-down
list a target window where you want your selected link to appear.
You can select from the following choices: _blank (opens the link in
anew window); _parent (opens the link in the parent of the currently
opened window; if the currently opened window was opened from
another frame, the link will open in that frame); _self (the default;
opens the link in the currently opened window; not selecting a Target
produces the same effect); and _top (opens the link in the top-level
window, replacing frames, if any). If you have created frames, you
can also select a frame name from this list. (See Book I, Chapter 4 for
more information about frames.)

e Alt: Enter the text you want to show when the user moves the mouse
pointer over the hotspot. Alt text also makes information about the
hotspot accessible to vision-impaired users.

Modifying or deleting a hotspot

If you need to change the size or shape of a hotspot after you've created it,
or you need to change the link, target, or Alt information for the hotspot, use
the following procedure to edit the hotspot:

1. On an image in the Document window, click the hotspot you want to
modify.

The Hotspot Property inspector appears. If the inspector does not
appear, open it by choosing Window=>Properties.

2. Edit the Link, Target, or Alt information you want to change in the
Hotspot Property inspector.

3. If you want to reshape or resize the hotspot, select the Arrow tool in
the Hotspot Property inspector and then click any handle of the
selected hotspot and drag the handle to a new location.

4. If you want to reposition the hotspot, select the Arrow tool in the
Hotspot Property inspector, click anywhere within the hotspot, and
drag it to a new location.

You can delete a hotspot by selecting it and pressing the Del key on your
keyboard.
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Adding Flash Text Rollovers

A text rollover is text that changes color when users move their mouse
pointer over it. One way to create text rollovers in Dreamweaver is by
adding Flash text to your pages, as described in the following section.

Q\Q’N- S Tg‘k

Flash text and Flash buttons are so named because Dreamweaver implements
these features using the same code that Adobe Flash CS3 (the animation pro-
gram included in Creative Suite 3) uses.

Adding Flash text

To add hyperlinked Flash text that changes color when users roll their
mouse over it, follow these steps:

1. Click in the Document window where you want to add Flash text.

2. Choose Insert->Media=>Flash Text.

Your page must be saved before you can insert Flash text. If the page
hasn’t been saved at least once, an alert pops up to remind you to save
the page so you can insert the Flash text.

3. In the Insert Flash Text dialog box, shown in Figure 6-2, select a font
from the Font drop-down list.
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. Enter a point size for your text in the Size text field.

. If you want, you can also format the text.

You can click the Bold button and/or Italics button. You can also click an
alignment button. Alignment choices are Left, Center, and Right.

. Select a Color (the initial color) and a Rollover Color (the color the

text changes to when users move their mouse pointer over it) by click-
ing the color swatch in each area and selecting a color from the color
palette that appears.

Enter your text in the Text field. Select the Show Font option if you
want to preview the characters in the Text field in your selected font.

In the Link field, enter a URL or the name of the page you want to
appear when the user clicks the Flash text.

Alternatively, you can click the Browse button to select a page from your
files.

. In the Target area, click the arrow and select from the drop-down list

a target window where the linked page will appear.

If you have created frames, you can select a frame name from this list, or
you can select from the following choices:

e _blank: Opens the link in a new window.
e _parent: Opens the link in the parent of the currently opened window.

e _self: Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing any existing
frames.

Select a Background color by clicking the Bg Color swatch and selecting
a color from the color palette that appears, or type in a hexadecimal
number.

Your Flash text appears over the background color you choose.

Enter a name for your Flash text component in the Save As field or
click the Browse button to select a name from your files.

You must save Flash text with an . swf extension.
Click OK to create your Flash text and close the dialog box.

Depending on your preferences, you may see the Flash Accessibility
Attributes window. Enter the Title, Access key, and Tab index informa-
tion as needed and click OK. You can click OK without entering any
information.
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Adding Flash Button Rollovers

To preview the rollover effect of your Flash text, select the Flash object in
the Document window to open the Flash Text Property inspector. In the
Property inspector, click the Play button to view your Flash text as it will
appear in the browser window. Click the Stop button when you’re done.

Changing Flash text

You can change an existing Flash text object by simply double-clicking the
object in the Document window or by clicking the object and then clicking
the Edit button in the Property inspector. Doing so opens the Insert Flash
Text dialog box, where you can change various attributes of the object as we
describe in the previous section.

Adding Flash Button Rollovers

\\3

Buttons that change appearance when users move their mouse pointer over
them — called button rollovers — are so popular that Dreamweaver gives you
a way to create them quickly and easily as Flash movies. To find out how to
create button rollovers using images and behaviors instead of Flash button
rollovers, see the “Inserting Image Rollovers” section, later in this chapter.
(Book III, Chapter 5 describes how to make rollovers in Fireworks CS3 using
images and behaviors.)

Adding a Flash button

To add a Flash button, follow these steps:

1. Click in the Document window where you want to add a Flash button.

2. Choose Insert->Media->Flash Button to open the Insert Flash Button
dialog box, as shown in Figure 6-3.

Your page must be saved before you can insert a Flash button. If the
page hasn’t been saved at least once, an alert pops up to remind you to
save the page so you can insert the Flash button.

3. In the Insert Flash Button dialog box, scroll through the button selec-
tions in the Style list and click to select a style.

You can preview the style in the Sample area of the dialog box — just
point to the sample with your mouse to see the Flash button in action.

You can get new Flash buttons on the Dreamweaver Web site by clicking
the Get More Styles button in the Insert Flash Button dialog box. A Web
page on Adobe’s site opens in your browser. Select the Flash Media
option from the Categories drop-down list and scroll through the results
as needed.
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4. If your selected button has a placeholder for text, enter the text that
you want to appear on the button in the Button Text field.

Text centers within the button automatically. Button size is fixed,
though, so you must make sure your text is brief enough to fit on the
button.

5. Select a font for your Flash button text from the Font drop-down list.
6. Enter a point size for your text in the Size field.

7. In the Link field, enter a URL or the name of the page that you want to
appear when the user clicks the Flash button.

Alternatively, you can click the Browse button to select a page from your
files.

8. From the Target drop-down list, select a target window where the
linked page will appear.

If you have created frames, you can select a frame name from this list, or
you can select from the following choices:

e _blank: Opens the link in a new window.
e _parent: Opens the link in the parent of the currently opened window.

e _self: Opens the link in the currently opened window; this is the
default. Leaving the Target area empty produces the same result.

e _top: Opens the link in the top-level window, replacing any existing
frames.
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9. Select a Background color by clicking the Bg Color swatch and select-
ing a color from the color palette that appears.

Alternatively, you can enter a hexadecimal color code in the Bg Color field.
Your Flash button displays with the background color you select.

10. Enter a name for your Flash button in the Save As field or click the
Browse button to select a name from your files.

The Flash button filename requires an . swf extension. Dreamweaver
will add the extension automatically if you don’t enter it.

11. Click OK to create your Flash button and close the dialog box.

Depending on your preferences, you may see the Flash Accessibility
Attributes window. Enter the Title, Access key, and Tab index informa-
tion as needed and click OK. You can click OK without entering any
information.

To see what a Flash button looks like in action, select the button in the
Document window to open the Flash Button Property inspector. In the
Property inspector, click the Play button to view your Flash button as it
appears in the browser window. Click the Stop button when you finish.

Changing a Flash button

To change an existing Flash button object, simply double-click the object in
the Document window, or click the object and then click the Edit button in
the Property inspector. Doing so opens the Insert Flash Button dialog box,
where you can change your button as we describe in the previous section.

Inserting Image Rollovers

An image rollover (often just referred to as a rollover) is a behavior that
changes an image whenever users move their mouse pointer over the image.
Rollovers add interactivity to a Web page by helping users to see what parts
of the page are links to other Web pages.

A rollover is actually two images — one for normal display on a page (the
original image) and one that is slightly modified for display when the image
is rolled over (the rollover image). You can modify an image by changing the
color or position, adding a glow or a shadow, or adding another graphic —
such as a dog changing from sleeping to wide-awake. For a rollover to work
best, the normal and rollover states of the image should share the same
width and height.
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Inserting Image Rollovers

As with all images, you can’t create the original image or the rollover image
directly in Dreamweaver; you must use an image-editing program, such as
Fireworks or Photoshop, to generate the images.

Insert a rollover by following these steps:

1.

2.

Click inside the Document window where you want to insert the
image rollover.

On the Common category of the Insert bar, click and hold the Image
button and select Rollover Image from the pop-up menu.

The Insert Rollover Image dialog box appears, as shown in Figure 6-4.
Alternatively, you can choose Insert>Image Objectse>Rollover Image.

3

| Insert Rollover Image >
Image name: | hark l ok ]
Crignal image: | .. jimages,back-btn.git | Browse... [E
Rollover mage: | ../images/back-bn-ro.gf Hromese. .. |LJ
[#] Prednad rolinver image
Aktermnate bext; | Dok
when rlicked, Gnbn LR | arart_himl Browese. .

In the Insert Rollover Image dialog box, enter a unique name for the
rollover in the Image Name field, making sure there are no spaces in
the name.

The rollover is referred to by this name in the HTML page code. Keep in
mind that this rollover name refers to the combined original image/
rollover image pair.

Enter the name of the original image file in the Original Image field,
or click the Browse button to select an image from your files.

The original image appears on the page when the user’s mouse pointer
is not over the image.

Enter the name of the rollover image file in the Rollover Image field,
or click the Browse button to select an image from your files.

The rollover image appears on the page when the user’s mouse pointer
is over the image.
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6. Select the Preload Rollover Image check box.

This feature makes the rollover action appear without delay to users as
they move the mouse pointer over the original image. It is selected by
default.

7. Enter alternate text for the image to make it accessible to vision-
impaired visitors to your site.

This step is optional but recommended.

8. If you want to make the rollover image a link, enter a URL of the page
in the When Clicked, Go to URL text field.

Alternatively, you can click the Browse button to select a page from your
files.

9. Click OK to accept your choices and close the dialog box.

To check the rollover, preview your page in a browser by choosing
Filew>Preview in Browser or by clicking the Preview in Browser button, and
then use your mouse to point to the original image. You can also press F12
(on the PC, not on the Mac) to preview the rollover in the default preview
browser. If you haven’t set a default preview browser, you will have to do so
using the Preview in Browser category in Dreamweaver’s Preferences dialog
box. See Dreamweaver’s help documentation for details.

Setting Up a Navigation Bar

A navigation bar is a group of buttons that users can access to move through-
out your Web site. Buttons within a navigation bar may present users with
options, such as moving backwards, moving forwards, returning to the home
page, or jumping to specific pages within the site.

Each button in a navigation bar possesses properties similar to a rollover in
that the button changes state — or appears differently — based on where the
user is positioning the mouse pointer. However, a navigation bar button can
possess as many as four different states:

4+ Up: The original state of the button

4+ Over: How the button appears when a user moves their mouse pointer
over it

4+ Down: How the button appears as a user is clicking it

4 Over While Down: How the button appears when the user moves
their mouse pointer over it after clicking it and arriving on the page it
represents
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A navigation bar differs from individual rollovers in that clicking a navigation Book |
bar button in the Down state causes all other buttons in the bar to revert to Chapter 6
the Up state.

To create a navigation bar, just follow these steps:

1. Select the Navigation Bar button from the Common category of the
Insert bar or choose Insert=>Image Objects=>Navigation Bar.
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Whichever method you choose, the Insert Navigation Bar dialog box
appears, as shown in Figure 6-5.
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2. In the Insert Navigation Bar dialog box, enter a name for the first
button in the Element Name field.

The new button appears in the Nav Bar Elements field. Don’t use spaces
in the names of any of these elements.

3. For each state of the button — Up Image, Over Image, Down Image,
and Over While Down Image — enter the name of the image file that
you want to use in the associated field.

Alternatively, you can click the Browse button for each field and select
an image from your files. You must supply the Up Image. All other states
o are optional and can be left blank.

You don’t need to use all four navigation bar button states — creating
only Up and Down states works just fine.

4. Enter alternate text for the image to make it accessible to vision-
impaired visitors to your site.

This step is optional but recommended.
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5.

10.

11.

12.

In the When Clicked, Go to URL text field, enter a URL or the name for
the page you want to appear when the user clicks the navigation bar
button.

Alternatively, you can click the Browse button to select a page from your
files.

. From the In drop-down list, select a target window where you want

the linked page to appear.

If you aren’t using frames, the only option is to use the Main window.

. Click the Add Item (+) button to add another navigation bar button.

Repeat Steps 2 through 6 to format the new button.

Note: You can remove any button already created by clicking its name
in the Nav Bar Elements field and clicking the Remove Item (=) button.
You can also reorder the sequence of the buttons as they will appear on
the page by clicking a button name in the Nav Bar Elements field and
clicking the up- or down-arrow button.

. In the Options area, select the Preload Images check box if you want the

rollover effects to appear without delay when the user triggers them.

. To set the current button to appear in the Down state when the user

first sees the navigation bar (which you might do to indicate that the
current page is the one represented by the button), select the Show
“Down Image” Initially check box in the Options area.

The Over While Down state works in combination with this option.

Select Horizontally or Vertically from the Insert drop-down list to
position the navigation bar horizontally or vertically.

To set up the button images in a table format, select the Use Tables
check box.

This option is checked by default.

Click OK to accept your choices and close the dialog box.

To check the navigation bar, you must preview your page in a browser.
Choose Filem>Preview in Browser or click the Preview in Browser button and
use your mouse to point to the buttons.

To change elements of an existing navigation bar, choose Modify~>
Navigation Bar. The Modify Navigation Bar dialog box is nearly identical

to the Insert Navigation Bar dialog box shown in Figure 6-5, except that

you can no longer change the orientation of the bar or access the Use Tables
check box.
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Adding Audio and Uideo to Vour Pages

You have two basic options, which are described in detail in the following
sections, for adding downloadable audio and video to your Web pages:
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Embedding: You can embed an audio or video file to display a playback

console on a Web page that users can use to play, rewind, and fast-forward
the media file. (You can also embed an audio file and make it invisible to

create a background audio effect.)

Users must have an appropriate plug-in installed on their machines to
play the embedded audio or video file. To ensure maximum compatibility;,
you may want to use Flash to create SWFs with audio and video (check
out Book IIl, Chapter 6 for details on adding audio and video to SWFs).

Linking: You can link to an audio or video file to give users the choice of
whether or not to view that media file.

Keep in mind that most audio and video files are large — large enough that
many folks impatiently click the Stop button on their browsers before a Web
page chock-full of audio or video effects has a chance to finish loading. Keep
the following basic rules in mind to help you use audio and video effectively
in your Web pages:

+
+

Use audio and video only when plain text just won’t do.

Keep your audio and video clips as short (and corresponding file sizes
as small) as possible.

Embedding an audio or video clip

You can embed an audio or video file by following these steps:

1.

2.

In the Document window, click the location in your page where you
want to add an embedded audio or video file.

Click and hold the Media button in the Common category of the Insert
bar and select Plugin from the pop-up menu, or choose
Insert->Media~>Plugin.

The Select File dialog box shown in Figure 6-6 appears.

. In the File Name field in the Select File dialog box, enter the path or

browse to the audio or video file that you want to embed, and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site’s root directory. Click Yes.

Book |
Chapter 6
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4. In the Plugin Property inspector, size the Plugin placeholder to any
dimensions you prefer.
You can either enter a width and height in the W and H text fields in the
Plugin Property inspector, or you can drag a handle on the placeholder
to manually resize.
Test in all your target browsers (the browsers your users are likely to
view your site with) to ensure that users can view all the audio playback
controls or video area and controls.
\\J

You can click the Play button in the Plugin Property inspector to play your
media file without previewing your page in a browser.

Embedding background music

Embedding background music (music that plays automatically after the user
opens a page) in your page can be controversial because users may be
unpleasantly surprised by audio when they are expecting silence, and
because users have no way to turn off the music from within the browser. If
you still want to embed background music in your page, follow these steps:

1. In the Document window, click the location in your page where you
want to add an embedded audio file.

This should be an out-of-the-way location, like the bottom of your page,
so the embedded audio doesn’t create an awkward space in your design.

2. Click and hold the Media button in the Common category of the Insert
bar and select Plugin from the pop-up menu, or choose Insert->Media~>
Plugin.
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The Select File dialog box appears. Book |

3. In the File Name field in the Select File dialog box, enter the path to Chapter 6

the audio file that you want to embed, and click OK.

If the file is outside your current root directory, Dreamweaver asks
whether you want to copy the file to your site’s root directory. Click Yes.

4. Enter a width and height of 2 in the W and H text fields in the Plugin
Property inspector.
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5. Click the Parameters button to open the Parameters dialog box.

6. In the Parameters dialog box, click the Add (+) button to add a new
parameter.

7. Click in the Parameter column and type hidden.
8. Type true in the Value column.
Steps 7 and 8 hide the audio playback controls.
9. Click OK to complete the process and close the dialog box.

Linking to an audio or video clip

A simple and relatively trouble-free way to include audio and video clips on a
Web page is to link the page to an audio or video file. Users can click the link
if they want to hear or watch the clip. This selection opens a player outside
the browser where the user can control playback.

You follow the same steps to create a link to an audio or video file that resides
in your root folder as you do to create a link to a Web page (see Book I,
Chapter 2 for information on adding links); the only difference is that you
specify a media file instead of a URL for the link.

Adding Other Media

Dreamweaver enables you to easily insert a number of other multimedia
formats into your Web pages, including ActiveX, Java Applets, Adobe Flash,
and Shockwave. After inserting any of these media formats, you can set the
control and playback features of the media in the Parameters dialog box.
Additionally, you can fine-tune the media action on your page by using the
Behaviors panel to create triggering actions that cause the media to play,
stop, and execute other functions.

Follow these directions to insert other media:

1. In the Document window, click the location in your page where you
want to add a multimedia file.
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Figure 6-7:
Your embed-
ded media
options.

2. Click and hold the Media button in the Common category of the
Insert bar to view all the object types that you can insert, as shown in
Figure 6-7, and click the icon of the type of media file you want to
insert.

Alternatively, you can choose Insert=>Media=>Media Type, where Media
Type is the type of media file you want to insert.

The Select File dialog box appears.

For Applet, Macromedia Flash, and Shockwave files: In the File
Name field in the Select File dialog box, enter the path to the media
and click OK. Your file is inserted and the associated Property
inspector appears. You can change the selected file in the Plugin
Property inspector by typing a new name in the File text field or by
browsing in the File folder to select a file (for Applets, use the Code
text field). Select the Embed check box if you want Netscape
Navigator users to have access to the Applet.

For ActiveX: An ActiveX placeholder is inserted and the ActiveX
Property inspector appears. Enter the name of the ActiveX object
you want to play in the Class ID text field. Select the Embed check
box if you want Netscape Navigator users to have access to the
ActiveX object.
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3. In the Property inspector for your selected media, enter dimensions
in the W and H text fields to size the Media placeholder to any dimen-
sions you choose.

4. In the Property inspector for your selected media, click the Parameters
button to open the Parameters dialog box, where you can add parame-
ters (like width, height, loop, and autoplay) appropriate to the selected
media type.

Using Dreamweaver Templates

Figure 6-8:
The
Entertain-
ment:
Calendar
sample
pageis
selected.

Dreamweaver comes with many built-in layouts that you can use to create
pages or Dreamweaver templates quickly. The layouts are predesigned pages
with placeholder content. Make a new page from a layout, replace the place-
holder content with real content, and voila — a professionally designed page!

To create a new page based on a built-in layout, just follow these steps:

1. Choose FilecoNew.
The New Document dialog box appears.
2. Select Page from Sample in the Category list on the left.
The Sample Folder and Sample Page columns are updated.
3. Select Starter Page (Theme) or Starter Page (Basic).

The Sample Page column is updated. Click any page in the Sample Page
column to see a preview in the Preview area, as shown in Figure 6-8.
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4.

When you’ve found the layout you want, select the Document option
in the lower-right corner and click the Create button.

The Save As dialog box appears.

. Name the file and click Save.

An untitled HTML page opens in the Document window with placeholder
content that you can replace with real content.

If the Copy Dependent Files dialog box appears, click Copy. The styles
and images used in the template will be copied to your site’s root folder.

You don’t have to use a built-in layout to create a Dreamweaver template:
You can make a Dreamweaver template based on any Web page. One cool
thing about Dreamweaver templates is that if you make a whole bunch of
pages based on a template, you can change the template, and all the pages
based on it will be updated to match the template automatically. Another
cool thing is that you can make a template that other people can use in com-
bination with either Dreamweaver or Contribute to create new pages that
conform to the template’s design.

To create a Dreamweaver template based on an existing HTML page, just
follow these steps:

1.
2.

Open the HTML page you want to use as a template.
Choose Filer>Save As Template.
The Save As Template dialog box appears.

. Select the site you want to use the template in.

By default, the current site is selected.

. If desired, input a description of the template.

This step is optional.

. In the Save As field, input a name for the template.
. Click Save.

If the Update Links dialog box appears, click Yes. When you’'ve saved the
template, you need to add editable regions. See Steps 4-6 in the next set
of steps to find out how.

To create a Dreamweaver template from scratch, follow these steps:

1.

2.

Choose Filec>New.
The New Document dialog box appears, with the General tab selected.

Select Basic Page from the Category list on the left and then select HTML
Template from the list of Basic Pages that appears in the middle.
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You can also select Template Page from the Category list and choose
HTML Template from the Template Page list that appears in the middle.

Create your page layout.

By default, nothing in the design of pages based on your template is
editable. You must create editable regions in order to make a useful
template.

Click a table cell or other part of your layout that you want users to
be able to fill with content, and choose Insert=>Template Objects=>
Editable Region, or press Ctrl+Alt+V (36+Opt+V on a Mac).

The New Editable Region dialog box appears. If you have a placeholder
image already in the layout, you can right-click the image and choose
Templates>New Editable Region from the context menu that pops up, or
you can select the image and press Ctrl+Alt+V (88+Opt+V on a Mac).

5. Name the region and click OK.

S

You can use the default name Dreamweaver gives to the region, but it’s
better if you name the region to reflect the content that will go into it
(for example, name the region Product Description). Figure 6-9 shows a
template with three editable regions. Editable regions are bound by a
light blue box with the region name at the top left.

Repeat Steps 4 and 5 until you have made editable regions out of all
the areas of the page that you want to be editable in new pages based
on the template.

Anything inside an editable region can be replaced in a page based on
the template; anything outside the editable regions is locked and can’t
be changed in pages based on the template.
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Figure 6-10:
Creating a
new page
based on a
template.

7. Choose File->Save.
The Save As Template dialog box appears.

8. Choose the site the template belongs to from the drop-down list, enter
a name for the template in the Save As field, and click the Save button.

The template will now be available to anyone who has access to the
Dreamweaver site, either through Dreamweaver or with Contribute.

To create an HTML page based on an existing user-created template, follow
these steps:

1. Click the Templates icon in the Assets tab of the File panel. All avail-
able templates for the selected site appear.

If the Files panel is closed, choose Windowr>Assets or press F11 (on the
PC only, not the Mac).

2. Right-click the template you want to create the new page from and
choose New from Template, as shown in Figure 6-10.

The page opens as an HTML page in the Document window.
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Figure 6-11:
Choosing a
user-created
template.
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You can also create an HTML page based on a user-created template by
choosing File>)New and choosing the template from the Page From
Template category of the New Document dialog box. (When you select the
Page from Template category, the Templates options appear, as shown in
Figure 6-11.)
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Validating Your Code

Dreamweaver CS3 has a built-in code validator. The validator checks your
HTML for errors (for example, unclosed <TD> tags or tags with invalid attrib-
utes, such as <FONT width=113>). If you work exclusively in Design view,
you may never need to use the validator. If you work in Code view, though,
and you are creating long, complex pages, you may find it worthwhile to run
the validator.

To validate your code on a page that’s open in the document window (unless
it’s XML), choose Filem>Validate Markup or press Shift+F6. The Results panel
opens and shows a list of warnings for any faults in the code. Double-click a
result in the list to highlight the problem in the code.

To validate XML code, choose File=>Validater>As XML. Because XML has
stricter requirements for well-formed code, you should take advantage of
Dreamweaver’s built-in validator if you're writing XML or XHTML.
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Figure 6-12:
The results
arein!

You can validate the code for an entire site at one time by following these
steps:

1. If the Results panel isn’t open already, choose Windowr>Results or
press F7.

The Results panel appears under the Properties panel at the bottom of
the screen.

2. Click the Validation tab.

3. Click and hold the green arrow at the left of the Results panel and
choose Validate Entire Current Local Site, as shown in Figure 6-12.

The results of the validation check appear in the Results window.
Double-click a result to highlight the problem in the code.
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Chapter 7: Adding Interactivity
with Spry

In This Chapter

v+ Introducing the Spry Framework

v Adding Spry data widgets

1~ Validating user input with Spry widgets
+~ Adding Spry navigation widgets

v+~ Dazzling users with Spry effects

Fle Spry Framework is a collection of JavaScript functions and Cascading
Style Sheet instructions that allow you to add sophisticated — and often
eye-catching — widgets to your Dreamweaver pages. The widgets range in
purpose from the practical (form validation) to the decorative (animation
effects).

In this chapter, we introduce you to the uses of the Spry widgets that ship
with Dreamweaver CS3. If the past is any indicator, new widgets will become
available from Adobe’s Web site as power users share their work with the
Adobe community.

If you can’t find what you’re looking for in this chapter, fear not. You can
always check out Dreamweaver’s built-in help files by choosing Help=>
Dreamweaver Help or pressing F1. You can also find more information on
the Web by choosing Help=>Spry Framework Help.

Adding Spry Data Set Widgets

Data set widgets allow you to display XML data on your page in ways that
reproduce the feel of dynamic pages; the user can sort data in tables by
clicking column headers, for example, or click a link to display, replace, or
hide an image or text anywhere on that same page. The best part is that the
user doesn’t have to wait for the page to refresh. It all appears pretty much
instantly. XML (or eXtensible Markup Language) looks a lot like HTML but
has a very different purpose. XML allows you to organize data so that it can
be stored in a single text file, exchanged between different systems, and dis-
played in multiple ways (including standard Web pages and cell phones).

If you need more information about XML, see XML For Dummies, 4th Edition,
by Lucinda Dykes and Ed Tittel (Wiley Publishing, Inc.).
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If you want to display the data from an XML file in a Spry Region, list, or
table, the first step is to tell Dreamweaver where the XML data is and how it
is structured. Read on to discover how to build the line of communication
between Dreamweaver and your XML file.

Defining a Spry XML data set

If you want to display on a Web page data that you have stored in an XML
file, the first step is to reference the XML data in Dreamweaver. To do so,
simply follow these steps:

1. If it’s not already selected, click the Spry tab in the Insert bar.

The Spry category of the Insert tab gives you one-click access to all the
Spry widgets available in Dreamweaver, as shown in Figure 7-1.
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2. Click the Spry XML Data Set button on the Insert bar.
The Spry XML Data Set window appears, with a default Data Set name.

3. If you'll be referencing more than one data set on your site, you may
want to input a custom name in the Data Set name field.

Data Set names can contain only letters and numbers and can start only
with a letter.
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4. Click the browse button and navigate to the XML file in the Select XML Book |
Source window that appears. Click the file and click OK. Chapter 7

The Select XML Source window disappears and the selected file appears
in the XML Source field.

Click the Get Schema button and click the Row Element that you want
to use as the basis for display.

N

For example, we want to show bowling balls but not other products

in the XML file, so we've selected “ball,” as you can see in Figure 7-2.
The data hierarchy is reflected in the Row Element window, which
shows subordinate elements as indented. The XPath, Data Set Columns,
Data Type, and Direction fields update automatically to their defaults.
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You can click the Preview button to see how the data would appear in a
simple table in your browser. (Note: The Preview window shows only
the top 20 rows.)
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0.

10.

Optional: If you have XML elements for which you want to specify the
data type, click the element in the Data Set Columns area and choose
a data type from the Data Type select menu.

Specifying the data type can allow for sorting and formatting. The Data
Type choices are as follows:

e String: The data is treated as a generic string of characters, even if
the data consists of numerals only. This is the default setting.

e Number: The data is treated as a number.
¢ Date: The data can be formatted as a date.

¢ Image link: The data will be treated as a link to an image file.

. Optional: Choose a sort method from the Sort select menu and a sort

direction from the Direction select menu.

The contents of the Sort menu depend on the Data Set Columns. You can
choose to sort the data by any of the columns shown in the Data Set
Columns section.

Your choices for sort direction are Ascending (low value to high value,
as in 1-100 or A-Z) or Descending (high value to low value, as in 100-1
or Z-A).

. Optional: Select the Distinct On Load check box if you don’t want

duplicate columns in your display of the data.

. Optional: Select the Turn XML Data Caching Off check box.

This option and the Auto Refresh Data option apply only if you have data
that updates constantly on your site. For our purposes, we’re assuming a
fairly static XML data source, so you wouldn’t want to select these options.

Click OK.

Dreamweaver inserts the Spry code in your document and the neces-
sary JavaScript files in a SpryAssets directory on your site. If you're in
Design view, you won’t see the code (you can click the Code button in
the Document window to view the code).

Creating a Spry Region

After you have a defined Spry data set, you need to create a container on
your page that can hold Spry elements. This container is called a Spry
Region. There are two types of Spry Regions:

+

+

Spry Region: The regular type of region, a div tag that “wraps around”
(contains) Spry data elements such as tables, tabbed panels, and so on.

Spry Detail Region: A region dependent on, and dynamically updateable
by, a regular Spry Region.
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You'll be prompted to create a Spry Region if you attempt to insert a Spry
list or table in your document without first creating a Spry Region. In other
words, you don’t need to create a Spry Region as a stand-alone step in the
process of building your page. You can do so if you want.

To create a Spry Region on your page, just follow these steps:

1. Click the Spry Region button on the Spry category of the Insert bar.
The Insert Spry Region window appears.

2. Choose a container type by clicking either DIV or SPAN.
The default, DIV, is the better option in most cases.

3. Choose a type by clicking either Region or Detail Region.

Choose Detail Region if you're creating a region that will update based
on feedback from an object in another region on the page. If so, you
need to create the other region and object first. Otherwise, leave the
default (Region) selected.

4. Choose the applicable Spry Data Set from the select menu.

To learn how to define a Spry data set, see “Defining a Spry XML data set,”
earlier in this chapter.

5. Click OK.

The Insert Spry Region window disappears. A box with a dotted-line
border and the sentence “Content for Spry Region Goes Here” shows the
Spry Region.

Creating a Spry Repeat

You can use the Spry Repeat function to display repeating elements in your
data set in whatever display format you want (as items stacked vertically in
a div or table cell, for example). If you want to display the data in a bulleted
or numbered list, use the Spry Repeat List function, described later in this
chapter.

To add a Spry Repeat, create your data set and add a Spry Region as
described previously. (If you haven’t done so ahead of time, you’ll be
prompted to do each as part of the process of creating a Spry Repeat.)

1. Click the spot in the Spry Region where you want the repeating ele-
ments to start.

2. Insert a binding for the repeating element you want to display by
selecting it and clicking the Insert button in the Bindings category of
the Application panel.

If you can’t see the Bindings panel, choose Window Bindings or press
Ctrl+F10. The element will appear in the document in curly brackets.
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Figure 7-3:
Inserting a
Spry Repeat.

3. Click the element in the document window to select it, and click the
Spry Repeat button in the Spry category of the Insert bar.

The Insert Spry Repeat window appears, as shown in Figure 7-3.

 Insert Spry Repeat o
Type: () papear l Help J
Q Repeat chidren
Spry Data Sct: | dsBE £

Tnsert: () wrap selection
0 Replace selsction

when to use Repeat chidren:

4. Choose either DIV (the defaulf) or SPAN to contain the repeating data.
In most cases, you’ll want to use a DIV as your container.

5. Choose either Repeat (the defaulf) or Repeat Children.
Beginning users will probably want to stick with the default.

6. Select a data set from the Spry Data Set select menu.

If you have only a single data set associated with your page, it will
appear as the default, and only, choice.

7. Choose either Wrap Selection (the default; wraps the repeat div tag
around the element selected in the document window) or Replace
Selection (replaces the selected element with a div tag).

8. Click OK.

The Insert Spry Repeat window closes and the Spry Repeat div is added
to your page’s code.

Creating a Spry Repeat List
As you might guess from the name, a Spry Repeat List is a variation on the
Spry Repeat function. A Spry Repeat List simply lets you set up the repeating
display element in a list. You can create four types of lists, as follows:

4 UL: An Unordered List (a.k.a. a bulleted list)

4 OL: An Ordered (numbered) List



Figure 7-4:
Inserting a
Spry Repeat
List.
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4 DL: A Definition List
4+ Select: A list of options for an HTML Select menu

To insert a Spry Repeat List into an existing Spry Region, simply follow these
steps:

1. Click the spot in the Spry Region where you want the list to start.

2. Click the Spry Repeat List button in the Spry category of the Insert bar.

The Insert Spry Repeat List window appears, as shown in Figure 7-4.

Insert Spry Nepeat List

>}
Conkainer tag: | UL {Unordered List) | E

Spry Diaka set: | debi w | [ rance |

Dispbery column: | bravad i | Halp

3

4.

5a.

56.

5c.

Choose a type of list from the Container Tag select menu.
The four choices are listed at the beginning of this section.
Select a data set from the Spry Data Set menu.

If you have only a single data set associated with your page, it will
appear as the default, and only, choice.

If you chose UL or OL in Step 3, choose which data element you want
to display on your page from the Display Column menu.

The menu contains all the columns in the data set that you selected in
Step 4.

If you selected DL in Step 3, select a term from the DT Column menu
and a definition from the DD Column menu.

If you selected Select in Step 3, select what the user will see in the
menu you'’re creating from the Display Column menu and what will
be processed by the form from the Value Column menu.

. Click OK.

The Insert Spry Repeat List window disappears, and Dreamweaver adds
the necessary code to your page.
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Figure 7-5:
Inserting a
Spry Table.

Creating a Spry Table

A Spry Table is a nifty way to display a data set on your page. One cool fea-
ture of Spry Tables is that you can choose to make any column sortable
alphabetically or numerically: When the user clicks on a column header, the
data is instantly re-sorted based on the data in the selected column. Not only
that, but the user can toggle the results between ascending order (A-Z, or
1-100, say) and descending order (Z-A or 100-1, for example).

To add a Spry Table to an existing Spry Region, follow these steps:

1. Click the spot in the Spry Region where you want the table to go.
2. Click the Spry Table button in the Spry category of the Insert bar.

The Insert Spry Table window appears, as shown in Figure 7-5.
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3. Select a data set from the Spry Data Set menu.

If you have only a single data set associated with your page, it will
appear as the default, and only, choice. The columns in that data set
appear in the Columns section of the Insert Spry Table window.

4. Optional: To change the display order of a table column, click to
select it and click the Up arrow to move it up in the list or click the
Down arrow to move it down in the list.

You can also click the Add Column (+) button to add a column or the
Remove Column (-) button to remove the column.

5. Optional: To make it possible for the user to sort the data in the table
by clicking a column header, select the column in the Columns section
and select the Sort Column When Header is Clicked check box.
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You can do this for as many columns as you have in your table, for none
of the columns, or for anything in between. After you finish inserting the
table, you’ll have to add empty links to the column headers in order to
make them trigger the sort action. To add an empty link to an object (a
link that doesn’t go anywhere), select the object and input the pound
sign (#) in the Link field in the Properties panel.

6. Optional: If you already have a stylesheet set up, you can apply exist-
ing classes to odd and even rows in your table and for hover and
selected states for links.

If you want to control these aspects of the look of the table with CSS, it’s
better to set up the styles before you create the table so that you can
easily set the display options from the select menus in the Insert Spry
Table window.

7. Optional: If you are using the table to control a Spry Detail Region
elsewhere on the page, select the Update Detail Regions When Row Is
Clicked check box.

8. Click OK.

The Insert Spry Table window disappears and Dreamweaver inserts the
necessary code in your page. After that’s done, you can select the table
and apply width, cellpadding, and all the usual table attributes as
needed.

Validating User Input with Spry Widgets

In case you want to put user feedback forms on your site, Dreamweaver
gives you an easy way to make those forms smarter, thanks to Spry’s

form field validation widgets. You can set up the widgets to change color
and/or display an error message when a user enters information you've
defined as invalid. The widgets add client-side validation capabilities to the
following:

4+ Text Input fields: You can set the minimum/maximum amount of charac-
ters allowed in the field, and you can declare certain characters as
either not allowed or required.

4+ Select menu: You can make selecting an option required, and you can
declare a selection invalid (such as when you have horizontal lines sepa-
rating the menu options into groups).

4+ Check boxes: You can make any number of check boxes required (for
example, you might say that the user must select a minimum of three
boxes out of nine).

4+ Textareas: You can make a textarea required, and you can set a mini-
mum and maximum number of characters that the user must enter.
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No matter which type of form validation widget you use, you must place it
inside a form. You can either put a form in your page as a separate step (see
Book II, Chapter 4 for details), or you can simply add the form as part of the
process of adding the first Spry form validation widget to your page, as we
show below.

Adding a Spry text input field

To add a Spry text input field to your document, follow these simple steps:

1.

2.

Place your cursor in your document where you want the text input
field to go.

Click the Spry Validation Text Input button in the Spry category of the
Insert bar.

Depending on your preferences settings, the Input Tag Accessibility
Attributes window may appear. If it does, enter information as you see
fit. It’s a good practice to make your forms accessible to people with
impaired sight. For information about the accessibility attributes, see
your documentation. Whether you enter attributes or not, click OK to
close the window.

If you haven’t yet created a form on your page, a dialog box may appear
asking if you want to add a form tag. Click Yes. The dialog box will disap-
pear, and the Spry text input field will appear in your document, as
shown in Figure 7-6.

. Depending on what type of information users might be putting in the

field, you may find preset validation scripts by selecting an option in
the Type select menu.

For example, if you want users to enter their e-mail address in the field,
you can select Email Address. The field will be checked to make sure
there is an @ sign and dot () in the data the user enters.

. Depending on the Type you select, the Format menu may become

active. If the menu is not grayed out, select a required format for the
field.

For example, if the Type is Date, the required format could be mm/dd/yy,
mm/dd/yyyy, or another. If you chose the first one, and a user input
07/18/2000, the field would turn red and an error message would appear.

. Select a Preview state from the Preview States select menu to see

what the field will look like in each of three states if you make the
field required (which it is by default). You must be in Design view to
see the Preview state.
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The states may include:

¢ Initial: What the field looks like when the user first loads the page in
a browser.

¢ Required: What the field looks like when the field is required but is
left blank.

¢ Invalid Format: How the field appears when the user enters informa-
tion in a format invalid for the type (for example, an e-mail without
an @ sign).

¢ Valid: What the field looks like when the user has entered valid infor-
mation.

Other states may appear depending on what you choose elsewhere in
the Property inspector.

6. Choose an action that triggers the field’s validation by checking one of
the Validate On check boxes.

By default, fields are validated on Submit, that is, when the user clicks
the form’s Submit button. You can also choose Blur (when the user
clicks anywhere else on the page after entering information in the field)
or Change (when the user begins inputting data in the field).
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7. Optional: If you wish to specify a minimum number or maximum
number of characters that the user can input into the text field, enter
the numbers in the Min Chars or Max Chars field, respectively.

8. Optional: Depending on the Type you select, the Min Value and Max
Value fields may become active.

For the Integer type, for example, you could set minimum or maximum
(or both) allowable numerals for the field. (The numeral the user inputs
must be at least 5, say, or no greater than 100.)

9. Optional: You can prepopulate the field with a temporary value that
shows the correct format by entering the value in the Hint field.

For example, if you're asking the user to fill in a phone number, you
could enter (111) 222-3456.

10. Optional: Select the Enforce Pattern check box if you want to ensure
that no illegal characters can be put in the text field.

For example, for the Email Address type, the user would not be able to
input characters such as < or /.

11. Optional: Deselect the Required check box if you don’t want the user
to have to fill in the field in order to submit the form.

Otherwise, leave Required at the default setting, which will prevent the
user from submitting the form unless the user puts a value in the text
field.

You can change the error messages or the default colors for the different
states of the text field, but that’s a little too advanced to describe here.
Click the Customize This Widget link in the Properties panel to learn more.

Adding a Spry Select menu

What makes a Spry Select menu different from a regular old select menu?
Three things:

4 You can make choosing an option mandatory for the user.

4 You can make options invalid.

4+ The menu will change color based on user feedback and will display an
error message if the user makes an invalid selection (or, if the menu is
required and the user makes no selection).

To insert a Spry Select menu into a form, follow these steps:

1. Place your cursor in the form where you want the select menu to go.

If you don’t already have a form on the page, Dreamweaver will prompt
you to create one.



Figure 7-7:
Adding
Accessibility
attributes
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Click the Spry Validation Select button in the Spry category of the
Insert bar.

Depending on your preferences, the Input Tag Accessibility Attributes
window may appear. Fill in the fields as needed (see Figure 7-7 for an
example of one possibility). Click OK. The window will disappear, even if
you didn’t add any information.
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4.

If you want choosing an option to be mandatory, leave the Do Not
Allow Blank Value check box selected, as it is by default.

If you have options in your select menu that you don’t want users to
be able to select, select the Do Not Allow Invalid Value check box and
enter an invalid value (the default, -1, should work just fine).

. Select a Preview state from the Preview States select menu to see

what the field will look like in each of three states if you make the
field required (which it is by default). You must be in Design view to
see the Preview state.

The states may include:

¢ Initial: What the field looks like when the user first loads the page in
a browser.

¢ Required: What the field looks like when the field is required but is
left blank.

¢ Invalid Format: How the field appears when the user enters informa-
tion in a format invalid for the type (for example, an e-mail without
an @ sign).

e Valid: What the field looks like when the user has entered valid
information.
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Figure 7-8:
Adding list
values to the
Spry Select
menu.

Other states may appear depending on what you choose elsewhere in
the Property inspector.

6. Click the select menu in your form in the Document window.
The Property inspector updates to show the List/Menu options.
7. Click the List Values button.
The List Values window appears.
8. Click in the Item Label column and enter an Item Label.
The Item Label is the option as it will appear to the user.

9. Click the same line in the Value column and enter a value for the
option.
The value is what the form will return when the user clicks the Submit
button.

10. Click the Plus (+) button to add another list value, and continue until
you have entered all the values; then click OK to close the window.

Note that in Figure 7-8, we’ve assigned “Select one” a value of -1 so that
a user may not submit the form if he or she chooses that option.
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11. If you want a particular option to be selected when the user first loads
the page in a browser, click the option in the Initially Selected menu.

12. Click anywhere in the document page to deselect the Select menu.

You can press F12 to preview the Select menu in a browser. You may be
prompted to save the page. If so, click Yes. The dialog box will disappear
and the page will load in your default browser.

Adding a Spry Checkbox

If you want an easy way to make a certain number of check boxes required,
create Spry Checkboxes on your page. To do so, follow these steps:

1. Click in the canvas where you want the check box to go.



Figure 7-9:
Adding
a Spry
Checkbox.
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2. Select the Spry Validation check box in the Spry category of the
Insert bar.

Depending on your preference settings, the Input Tag Accessibility
Attributes window may appear. If it does, enter information as you see
fit. It’s a good practice to make your forms accessible to people with
impaired sight. For information about the accessibility attributes, see
your documentation. Whether you enter attributes or not, click OK to
close the window.

If you haven’t yet created a form on your page, a dialog box may appear
asking if you want to add a form tag. Click Yes. The dialog box will disap-
pear and the Spry Checkbox will appear in your document, as shown in
Figure 7-9.

3. Select Required (Single) if you want users to have to select at least one
check box; select Enforce Range (Multiple) if you want users to have
to select at least two check boxes.

If you select Enforce Range, enter a minimum number of boxes the user
must select in the Min # of Selections field. If you don’t want users to be
able to select more than a certain number of boxes, enter that number in
the Max # of Selections field.
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4. Select a Preview state from the Preview States select menu to see
what the field will look like in each of three states if you make the
field required (which it is by default).

You must be in Design view to see the Preview state.
See Step 5 in “Adding a Spry Select menu” for details.

5. Choose an action that triggers the field’s validation by selecting one of
the Validate On check boxes.

By default, fields are validated on Submit, that is, when the user clicks
the form’s Submit button. You can also choose Blur (when the user
clicks anywhere else on the page after entering information in the field)
or Change (when the user begins inputting data in the field).

6. Add more check boxes as necessary by starting again at Step 1. Press
the Enter key or click anywhere in the Document window when
you’re finished.

If you're enforcing a range, be sure to match the Min # of Selections and
Max # of Selections for each check box you create.

Adding a Spry Textarea

When you create a Spry Textarea in your form, you make a multiline input
field in which users can enter several lines of text. You can set minimum and
maximum character amounts, add a character counter, and make the field
required. To create a Spry Textarea in your form, simply follow these steps.

1. Click in your Document where you want the Textarea to go.

2. Click the Spry Validation Textarea button in the Spry category of the
Insert bar.

Depending on your preference settings, the Input Tag Accessibility
Attributes window may appear. See Step 2 in “Adding a Spry Checkbox,”
the preceding section, for more information.

If you haven’t yet created a form on your page, a dialog box may appear
asking if you want to add a form tag. Click Yes. The dialog box will disap-
pear, and the Spry Textarea will appear in your document.

3. In the Property inspector, leave the Required check box selected if
you want to require users to enter text in the textarea.

4. Select a Preview state from the Preview States select menu to see
what the field will look like in each of three states if you make the
field required (which it is by defaulf). You must be in Design view to
see the Preview state.

The states may include:
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e Initial: What the field looks like when the user first loads the page in
a browser.

¢ Required: What the field looks like when the field is required but is
left blank.

¢ Invalid Format: How the field appears when the user enters informa-
tion in a format invalid for the type (for example, an e-mail without
an @ sign).

¢ Valid: What the field looks like when the user has entered valid
information.

Other states may appear depending on what you choose elsewhere in
the Property inspector.

5. Choose an action that triggers the field’s validation by selecting one of
the Validate On check boxes.

By default, fields are validated on Submit, that is, when the user clicks
the form’s Submit button. You can also choose Blur (when the user
clicks anywhere else on the page after entering information in the field)
or Change (when the user begins inputting data in the field).

6. If you want to set a minimum number of characters that users must
enter in the textarea, enter the number in the Min Chars field.

7. If you don’t want users to input more than a certain number of charac-
ters in the textarea, enter that number in the Max Chars field.

By default, if you enter a Max Chars limit, the Block Extra Characters
check box is selected. When this box is selected, users cannot enter
more than the maximum number of characters you specify.

Also, if you enter a Max Chars limit, you can add a character counter
that will appear in the user’s browser indicating either the number of
characters entered (Chars Count) or the number of allowed characters
not yet entered (Chars Remaining).

8. Optional: If you want to include instructions in the textarea itself,
enter text in the Hint field in the Spry Textarea Property inspector.

We put the hint “ Up to 200 characters,” as shown in Figure 7-10.

If you want to edit the non-Spry properties of any of your Spry Validation
form elements, simply click the element to select it and enter the properties
in the Property inspector. You can mix non-Spry form elements with Spry
form elements. In fact, there’s no Spry Submit button, so you need to add the
button from the Forms category of the Insert bar. See Book II, Chapter 4 for
more information about creating and modifying forms.
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Adding Spry Navigation Widgets

Spry Navigation widgets offer you a simple way to add flashy navigation to

your site. Apart from being cool, the chief advantage of Spry navigation

widgets is that they save plenty of space. You can have

4+ Multilevel menus that appear only when a user rolls over a specified

area, with the extra levels appearing to hover above the page

4+ Panels that share the same space on a page, which users can activate by

clicking the associated tabs

4+ Panels with detail areas that appear to slide open while other detail

areas appear to close

4+ Panels with detail areas that the user can make appear and disappear,

affecting other elements on the page

Inserting a Spry Menu Bar

A Spry Menu Bar is essentially a multilevel pop-up menu of the kind that first
appeared on the Web scene with the advent of DHTML. If you are building a
site that has two or more levels of navigation and much information to

squeeze on every page, Spry Menu Bars are for you.
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To create a Spry Menu Bar on a page, follow these steps:

11.

. Click in your document where you want to put the menu bar.

. Click the Spry Menu Bar button in the Spry category of the Insert bar.

The Spry Menu Bar window appears.

. Choose either Horizontal (menu items appear side by side) or Vertical

(menu items arranged top to bottom) and click OK.

The Spry Menu Bar window closes and the menu bar appears in your
document, with placeholder text for each top-level menu item and three
second-level items for each top-level item.

. Click the first item in the left-hand list (top-level items); then, click in

the Text field on the right and enter what the menu item should say.

. Enter a link for the menu item by typing it in the Link field or clicking

the Folder icon and browsing to the page you want to link to.

. Click the first item in the middle list (second-level items); then, click in

the Text field on the right and enter what the menu item should say.

. Enter a link for the second-level menu item.

Click each of the second-level items in turn and follow the same procedure.

. If you have third-level links, click the top-level menu item in the first

column, the second-level link in the second column, and the Add
button (+) in the third column.

A new Untitled Item appears in the third column, highlighted, as shown
in Figure 7-11.

. Enter Text and Link information in the Text and Link fields on the right.

10.

Continue until you have fully populated your menu as needed.

To remove an item from any column, click to select it and click the
Remove Menu Item (-) button above that column.

Choose File=>Save or press Ctrl+S to save your changes.

If this is the first Spry Menu Bar widget you’'ve added to your site,
Dreamweaver will let you know that the applicable Spry Assets will be
copied to the SpryAssets directory in your site.

After you’ve saved your document, you can preview it in a browser by
choosing Filec>Preview in Browserw Browser Name or by pressing F12.

When you remove a top-level or second-level link, all links below it in the
hierarchy (also known as child links) are removed at the same time. If you
try to remove a parent link, Dreamweaver will alert you that the child links of
that parent will also be deleted.
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To change the position of an item, click to select it and use the Up arrow to
put the item before others or the Down arrow to put the item after others.

Inserting a Spry Tabbed Panel

If you use a modern browser — Safari, Mozilla, or Internet Explorer 7, for
example — you know about the advantages of tabbed browsing. You can go
to a new page in the browser without opening a new window or browsing
away from your previous page. Spry Tabbed Panels provide the same effect
but do so on a single Web page. The user can’t look at the contents of two
Tabbed Panels simultaneously, but the user can click different tabs to see
the contents of their associated panels in a single space on the page, without
the page having to reload in a browser.

To create a Spry Tabbed Panel, follow these steps:

1. Click in the canvas where you want the tabbed panel to go.

2. Click the Spry Tabbed Panel button on the Spry category of the
Insert bar.

A Spry Tabbed Panels widget appears in the document, with two tabs,
and the Property inspector updates to show the Tabbed Panels options,
as shown in Figure 7-12.
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3. Click and drag across the Tab 1 text in the document to select it, and
enter your own text for the first tab.

4. Click and drag across the Content 1 placeholder text and insert the
content that should appear on the page when the user clicks the tab
on the left.

You can insert nearly anything in a panel that you’ll find in the Common
tab of the Insert bar.

5. Repeat the preceding Steps 3 and 4 for Tab 2.

6. If you want to add another tab, click the Spry Tabbed Panels label in
the document to select the widget; otherwise, skip to Step 8.

You can also click anywhere along the light-blue border of the widget to
select it. The border will be highlighted and the Property inspector will
be updated to display the Tabbed Panels options.

7. Click the Add Panel (+) button in the Tabbed Panels Property
inspector.

A new tab (named Tab 3 by default) appears in the document and in
the panels column. Repeat the preceding Steps 3 and 4 for the third tab.
If you want to add another panel, repeat this step until you have as
many tabs as you want.



’3 4 Adding Spry Navigation Widgets

8.

If you don’t want the left panel to be the one that’s visible when the user
first loads the page in a browser, you can select a different Default panel
from the menu on the right of the Tabbed Panels Property inspector.

. Choose Filer>Save or press Ctrl+S to save your changes.

If this is the first Spry Tabbed Panels widget you’'ve added to your site,
Dreamweaver will let you know that the applicable Spry Assets will be
copied to the SpryAssets directory in your site.

After you’'ve saved your document, you can preview it in a browser by
choosing File>Preview in Browser= Browser Name or by pressing F12.

Inserting a Spry Accordion

The Spry Accordion widget works in a similar way to the Spry Tabbed Panels
widget. The Accordion has two main differences:

<+

+

The tab that a user clicks to view a different panel is a long, narrow strip
by default.

The selected panel appears to slide open, obscuring the previously open
panel.

To add a Spry Accordion to your page, simply follow these steps:

1.
2.

Click in the canvas where you want the tabbed panel to go.
Click the Spry Accordion button on the Spry category of the Insert bar.

A Spry Accordion widget appears in the document, with two labels, and
the Properties panel updates to show the Accordion options. Label 1,
the top strip, is selected by default.

. Click and drag across the Label 1 text in the document window and

insert the content you want the user to click in order to view the con-
tents of the top panel.

You can put any element in the tab. Try to use something that describes
the contents of the panel.

. Click and drag across the Content 1 text to highlight it and enter con-

tent in the first panel, as shown in Figure 7-13.

You can insert pretty much any content in the panel that you can find in
the Common category of the Insert bar. In Figure 7-13, we’ve included
only text.

. Click and drag to select the Label 2 text in the document window and

enter the descriptive text a user will click to view the second panel.

Notice that when the tab is active in the document window, an eye icon
appears at the far right of the tab. Click the eye icon to view the panel
content for the tab.



Figure 7-13:
Adding
content to
panel 1

of a Spry
Accordion
widget.
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6. Insert content in the second panel.

7. If you want to add another tab, click the Spry Accordion label in the

document to select the widget. Otherwise, skip to Step 9.

You can also click anywhere along the light-blue border of the widget to
select it. The border will be highlighted and the Property inspector will

be updated to display the Tabbed Panels options.
8. Click the Add Panel (+) button in the Accordion Property inspector.

A new tab (named Label 3 by default) appears in the document and in

the panels column. Repeat the preceding Steps 3 and 4 for the third tab.

If you want to add another panel, repeat this step until you have as
many tabs as you want.

9. Choose Filer>Save or press Ctrl+S to save your changes.

If this is the first Spry Accordion widget you've added to your site,
Dreamweaver will let you know that the applicable Spry Assets will be
copied to the SpryAssets directory in your site.

After you’'ve saved your document, you can preview it in a browser by

choosing Filec>Preview in Browser—~>Browser Name or by pressing F12.
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Inserting a Spry Collapsible Panel

As with the Spry Tabbed Panels and Accordion widgets, the Spry Collapsible
Panel allows you to hide content on your page until the user does something
to make the content visible. When the panel expands, it pushes everything
below it on the page down; when the panel collapses, anything below it on
the page moves up.

To add a Spry Collapsible Panel to your page, follow these steps:

1. Click in the canvas where you want the Collapsible Panel to go.

2. Click the Spry Collapsible Panel button on the Spry category of the
Insert bar.

A Spry Collapsible Panel widget appears in the document, with a tab
labeled “Tab” and a panel with the default text “Content.” The Properties
panel updates to show the Collapsible Panel options. By default, Display
and Default State are set to Open, and the Enable Animation check box is
selected, as shown in Figure 7-14.
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3. Click and drag to select the Tab text in the document window and
insert your own descriptive text that the user will click to open and
close the panel.

The text might be something like “Details” or it might be a more generic
“Show/Hide.”

4. Click and drag to select the Content default text and insert content
into the panel.

Content may include anything you can add to a document via the
Common tab of the Insert panel, as well as any other Web content.

5. If you want to preview the Open or Closed state of the panel within the
document window, change the Display select menu to Open or Closed.

You can also roll over the tab and click the eye icon at the right of the
tab to display or hide the panel.

6. Choose either Open or Closed in the Default State menu to make the
panel appear open or closed when the user loads the page in a browser.

7. If you want to disable the animation effect of the panel sliding open
and closed when the user clicks the tab, deselect the Enable Animation
check box.

If you disable the animation, the panel will appear and disappear
abruptly when the user clicks the tab.

8. Choose Filer>Save or press Ctrl+S to save your changes.

If this is the first Spry Collapsible Panel widget you've added to your
site, Dreamweaver will let you know that the applicable Spry Assets will
be copied to the SpryAssets directory in your site.

After you’ve saved your document, you can preview it in a browser by
choosing File>Preview in Browser=>Browser Name or by pressing F12.

Dazzling Users with Spry Effects

Elsewhere in this chapter, we show you how to use Spry widgets to display
XML data sets, to create multilevel navigation bars, and to show and hide
content. In this section, we discuss the Spry widgets that add pizzazz to your
page without necessarily having a more practical purpose (except perhaps
drawing attention to a particular chunk of content). As with the Spry widg-
ets, the changes in appearance happen without any reloading of the page in
the browser.
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Dreamweaver CS3 ships with Spry effects widgets that make content appear
to do the following:
4 Fade in and out
Appear and disappear as if being revealed/obscured by a blind
Grow and shrink
Highlight
Shake
Slide up and down

Squish

AR IR IR IR e

Any combination of the preceding

Spry effects don’t work on all objects. For example, you can add a Fade
effect to an image, but you can’t add a Blind effect to an image. You can add
a Blind effect to a div that includes an image, though. If you apply an effect
and it doesn’t seem to be working, check the Help files to make sure that the
effect you're applying can be applied to the object you're trying to affect.

Effects depend on two objects:

4+ The triggering object: The linked text or button that triggers the effect
based on a user action such as clicking the mouse. To add an empty link
to an object (a link that doesn’t go anywhere), select the object and
input the pound sign (#) in the Link field in the Properties panel.

4+ The affected object: The object that changes when triggered. This
object must have an ID (you can add an ID in the Properties panel or the
Attributes panel).

After you've added a Spry effect, you must save your document in order to
preview the effect in a browser. The first time you save after adding a Spry
effect, the Copy Dependent Files window appears, letting you know that

the spryEffects. js file will be placed in the SpryAssets directory in
your site. Click OK to add the file and close the window. Do not delete the
SpryEffects. js file from your site—it’s required to make the effects work.
And don’t forget to copy the Spry directories to your Web server with the
rest of your site files.

Making objects fade in and out

You can make objects fade in or out when a user performs a specified action,
or when the page first loads in a browser. You could think of the Spry fade
effect as kind of a slow-motion button rollover.
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Figure 7-15:
Adding the
Appear/Fade
Spry effect
to an image.
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The Appear/Fade effect won’t work with the following objects: applet,
body, iFrame, object, tr, tbody, and th.

We're assuming that the object you want to add the effect to, and the trigger
for the effect, are in your document already. The object you want to add the
effect to must have an ID, which you can add by selecting the object and
entering characters in the ID field of the Properties panel. To add a fade to
an object (text, an image, or a div, for example), follow these steps:

1. In the document window, select the object you want to use as a
trigger.

2. Click the Add (+) button in the Behaviors panel (you can find
Behaviors as a category of the Tag panel).

If the Behaviors panel isn’t open, choose Window Behaviors or press
Shift+F4.

3. Choose EffectscoAppear/Fade from the pop-up menu.

The Appear/Fade window appears, as shown in Figure 7-15.

| Appear’Fade i=<h
Target Elamank:  <Current Selaction:- |
Ettect duration: 1000 miliseconds IEJ
Effecl:  Fale ¥ Hely

Fada from: 100 )
Fadeto; 0O %

|| Toggie affert

4. For target element, select the object that you want to apply Appear/
Fade to.

If you don’t see the object in the select menu, check to make sure that it
has an ID and that the effect can be applied to its type of object.

5. Enter a number in milliseconds for the amount of time you want the
effect to last in the Effect Duration field.

One thousand milliseconds equals 1 second; 2000 milliseconds is 2 sec-
onds; 500 milliseconds is, you guessed it, half of one second. You want
the effect to last long enough to be noticeable but not so long that the
user gets frustrated waiting for the effect to end.
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\NG/
S

6. Choose an effect from the Effect select list.

Your choices are Fade (start visible and slowly become less visible
or invisible) or Appear (start less visible or invisible and become more
visible).

7a. If you selected Fade in Step 6, you can set the visibility at the start
(Fade From) and end (Fade To) of the effect by entering a number
from 0 to 100 in the Fade fields.

One hundred would be totally visible; 0 is totally invisible.

7b. 1f you selected Appear in Step 6, you can set the visibility at the start
(Appear From) and end (Appear To) of the effect by entering a
number from 0 to 100 in the Appear fields.

Zero is totally invisible; 100 is totally visible.

8. If you want the user to be able to toggle the effect on and off, select
the Toggle Effect check box.

9. Click OK.

The Appear/Fade window disappears and the behavior shows in the
Behaviors panel. By default, the behavior is triggered when the user
clicks the trigger with the behavior applied to it. You can click onClick
in the action column of the Behavior panel and choose a different trigger
from the select menu that appears.

Applying the Open/Close Blind effect

When you add the Blind effect, the user can see an object seem to appear or
disappear as if it is behind a blind or curtain.

This effect cannot be applied to images. It can be applied to the following
HTML objects: address, dd, div, 41, dt, form, hl through heé, p, o1, ul,
1i, applet, center, dir, menu, and pre.

Adding the effect to an object is essentially identical to making objects fade
in or out (see the steps in the preceding “Making objects fade in and out”
section), so we're saving some space here as we describe how to apply the
Blind effect:
1. Follow Steps 1 and 2 in the preceding set of steps.
2. Choose Effects->Blind from the pop-up menu.
The Blind window appears.

3. Select a Target Element and enter an amount in the Effect Duration
field, as per Steps 4 and 5 above.
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4. Choose an effect from the Effect select menu.

Your choices are Blind Up (the object is visible) and Blind Down (the
object seems to disappear behind the blinds).

5a. If you selected Blind Up in Step 4, you can set the visibility at the start
(Blind Up From) and end (Blind Up To) of the effect by entering a
number from 0 to 100 in the Blind Up fields.

One hundred is totally visible; 0 is totally obscured.

5b. 1f you selected Blind Down in Step 4, you can set the visibility at the
start (Blind Down From) and end (Blind Down To) of the effect by
entering a number from 0 to 100 in the Blind Down fields.

Zero obscures the object completely; 100 makes the object completely
visible.

0. If desired, select the Toggle Effect check box and click OK.

See Step 9 in the steps in the preceding “Making objects fade in and out”
section for details.

Matking objects grow and shrink

The Spry Grow/Shrink effect doesn’t simply make objects grow or shrink in
place. Instead, it moves them as it shrinks, either diagonally to the bottom-
left or top-left corner, or toward/from the center.

To save space, we refer to the previous steps for “Making objects fade in and
out” where they apply equally to making objects grow and shrink.
1. Follow Steps 1 and 2 in “Making objects fade in and out.”
2. Choose Effects=>Grow/Shrink from the pop-up menu.
The Grow/Shrink window appears.

3. Select a Target Element and enter an Effect Duration, as per Steps 4
and 5 from “Making objects fade in and out.”

4. Choose an Effect from the Effect select menu.
Your choices are Shrink and Grow.

5a. 1f you selected Shrink in Step 4, you can set the size at the start
(Shrink From) and end (Shrink To) of the effect by entering a number
from 0 to 100 in the Shrink fields; then, select either Shrink to Center
or Shrink to Top Left Corner.

One hundred is full size; 0 is invisibly small.

Book |
Chapter 7

Axdg yum
Auanoesayuy buippy



’42 Dazzling Users with Spry Effects

56.

If you selected Grow in Step 4, you can set the size at the start (Grow
From) and end (Grow To) of the effect by entering a number in the
fields; then, select either Grow to Center or Grow to Top Left Corner.

Zero obscures the object completely; 100 makes the object full size. You
can use a number higher than 100 (200, for example, would be double-
size), but be aware that you might grow your object right off the page!

. If desired, select the Toggle Effect check box and click OK.

See Step 9 in the previous “Making objects fade in and out” section for
details.

Highlighting with color

The Highlight effect makes an object change from one color to another
(typically, you would use this effect to change the background color of a
paragraph, a div, or even a whole page). As with other Spry effects, you can
set how quickly or slowly the change takes place and whether the user can
toggle the effect back and forth.

To use the highlight effect to change the background color of a div, follow
these steps:

1.
2.

In the document window, select the object you want to use as a trigger.

Click the Add (+) button in the Behaviors panel (you can find
Behaviors as a category of the Tag panel).

If the Behaviors panel isn’t open, choose Window Behaviors or press
Shift+F4.

. Choose Effects Highlight.

The Highlight window appears.

. For Target Element, select the div whose background color you want

to change.

If you don’t see the object in the Target Element select menu, check to
make sure it has an ID and that the effect can be applied to its type of
object.

. Enter a number in milliseconds for the amount of time you want the

effect to last in the Effect Duration field.

One thousand milliseconds equals 1 second; 2000 milliseconds is 2 sec-
onds; 500 milliseconds is half of one second. You want the effect to last
long enough to be noticeable but not so long that the user gets frustrated
waiting for the effect to end.
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6. Set the Start Color either by clicking the color box and choosing a
color via the color picker or by entering the color’s hexadecimal
equivalent in the Start Color text field.

See Book IV, Chapter 3 for details on using the color picker. If the start
color is different from the existing background color of the div, the div
will change color abruptly to the start color and then proceed to the end
color at the rate you set in the Effect Duration field.

7. Set the End Color either by clicking the color box and choosing a
color via the color picker or by entering the color’s hexadecimal
equivalent in the End Color text field.

8. Set the Color After Effect either by clicking the color box and choos-
ing a color via the color picker or by entering the color’s hexadecimal
equivalent in the Color After Effect text field.

The Color After Effect is the color that the object retains at the end of the
effect. That color does not have to be the same one as the original color of
the object, but that would be a typical implementation. The switch from
the End Color to the Color After Effect is abrupt (unless the Color After
Effect is identical to the end color, in which case there’s no switch at all).

9. If you want the user to be able to toggle the effect on and off, select
the Toggle Effect check box.

10. Click OK.

The Highlight window disappears and the behavior shows in the
Behaviors panel. By default, the behavior is triggered when the user
clicks the trigger with the behavior applied to it. You can click onClick
in the action column of the Behavior panel and choose a different trigger
from the select menu that appears.

Shaking up an object

The Shake Spry effect moves an object back and forth three times. It’s one of
the simplest Spry effects to apply to an object because it doesn’t permit you
to choose any options (at least not in the current implementation of Spry as
of this writing). To add the effect to an object, simply click the Add Effect
button (the + sign) in the Behaviors panel, select a Target Element (the object
you want to shake), and click OK.

Sliding an object up or down

Sliding is similar to the Blind effect, except that instead of remaining station-
ary while the effect obscures or shows the element, sliding makes everything
in a div move up as it disappears or down as it appears. The Slide effect can
be applied only to a single “container” div.
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Figure 7-16:
We gave
our targeted
div the id
“container.”

To add the Slide effect to a div, follow these steps:

1.

2.

3

In the document window, select the object that you want to use as a
trigger.

Click the Add (+) button in the Behaviors panel (you can find
Behaviors as a category of the Tag panel).

If the Behaviors panel isn’t open, choose Window Behaviors or press
Shift+F4.

Select the div from the Target Element menu, as shown in Figure 7-16.

(Slide

%]
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4.

5a.

56.

Choose either Slide Up or Slide Down in the Effect menu.

Slide Up will start with the div fully or partially visible and end with the
div partially or fully hidden. Slide Down will do the opposite.

If you choose Slide Up in Step 4, enter a number in the Slide Up From
field, and select either % or pixels for the number. Proceed to Step 6a.

The default of 100% means that the full div appears before the effect is
applied. If you choose pixels, and you choose a lower number than the
actual height of the div, the top of the div will seem to be hidden at the
start of the slide.

If you choose Slide Down in Step 4, enter a number in the Slide
Down To field and select either % or pixels for the number.
Proceed to Step 6b.

The default of 0% means that the div would be totally hidden at the end
of the effect. If you choose a pixel number instead, and the number is
lower than the height of the div, some of the div will remain visible at the
end of the effect.



Dazzling Users with Spry Effects ’45

6a. If you choose Slide Up in Step 4, enter a number in the Slide Up To
field and select either % or pixels for the number.

The default of 0% means that the div would be totally hidden at the end
of the effect. If you choose a pixel number instead, and the number is
lower than the height of the div, some of the div will remain visible at the
end of the effect.

6b. 1f you choose Slide Down in Step 4, enter a number in the Slide Down
From field and select either % or pixels for the number.

The default of 100% means the full div appears at the end of the effect.
If you choose pixels, and you choose a lower number than the actual
height of the div, the top of the div will seem to be hidden at the end of
the slide.

7. If you want the user to be able to toggle the div up and down by click-
ing repeatedly, select the Toggle Effect check box.

8. Click OK.

The Slide window disappears and the behavior shows in the Behaviors
panel. By default, the behavior is triggered when the user clicks the trig-
ger with the behavior applied to it. You can click onClick in the action
column of the Behavior panel and choose a different trigger from the
select menu that appears.

Squishing an object

Squish lets a user toggle an object so that it appears to move up and away
into the top-left corner. It’s one of the simplest Spry effects to apply to an
object because it doesn’t permit you to choose any options (at least not in
the current implementation of Spry as of this writing). To add the effect to an
object, simply click the Add Effect button (the + sign) in the Behaviors panel,
select a Target Element (the object you want to squish) and click OK.

Combining effects

You can combine effects easily by simply selecting the trigger object and
clicking the Add Behavior (+) button. Then just follow any of the previous
sets of steps. It is possible to “chain” effects (make them happen one after
the other instead of simultaneously), but that takes some programming
know-how that’s beyond the scope of this book. As you work with Spry
Effects, you can always check out much of how things work by using Code
view in the Document window. For now, though, celebrate how easy it is in
Dreamweaver to add dynamism to your Web pages with Spry widgets!
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Chapter 1: Exploring New Features
in Photoshop CS3

In This Chapter

1+ Working with the new interface

v Getting smart with filters

v+~ Improving curve corrections

p hotoshop CS3 includes significant improvements to the workspace,
filters, and selection tools. In this chapter, you take a quick tour of
some of most exciting new capabilities. The features you see depend on the
Photoshop that you have (Standard or Extended).

This quick rundown of what is new and exciting in Photoshop CS3 is hopefully
a help to you as you start experimenting with the new tools and features.

If you really want to dive into the new features, choose Windows>Workspacew>
What’s New In CS3. Instantly all new features are highlighted in the menus!

A New Efficient Workspace

A\

As soon as you launch Photoshop CS3, the more efficient workspace —
meaning more space is available for you to work on your images — is
apparent (see Figure 1-1).

The toolbar is now single column. If you don’t like the change in the toolbar,
you can return to the old two-column display by clicking the gray bar at the
top of the toolbar.

Additionally, palettes are collapsed to a compact view and represented by
icons, saving even more space. The new workspace makes focusing on the
images easier, and the tools become a natural extension of your work.
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The new
space-
saving
Photoshop
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Photoshop continues to make extensive use of palettes. To activate a palette
in this new version, simply click the appropriate palette icon. If you select
another palette icon, its pane is brought to the front of the display. You can
return them to icons by clicking the Collapse To Icons bar at the top of the
palette drawer. When an icon is dragged out to the work area, it automati-
cally expands and then returns to an icon when dragged back into dock.

Showing and hiding all your tools and palettes is easier as well. Press the
Tab key to hide all your tools and palettes. To cause them to reappear, move
your cursor over the left or right side of your screen and pause at the verti-

cal gray bar.

How can you tell whether you have Photoshop
Standard or Extended? If you purchase the
master, Design Premium, or Web Premium Suite,
you have Photoshop Extended.

Do you need Extended? Most likely not. The typ-
ical designer, whether Web or print, will most

Do you have Standard or Extended?

likely never need the advanced tools that sep-
arate Standard from Extended.

But if you're into 3D, life sciences, manufactur-
ing, or the medical field, you may want to take
advantage of the 3D, counting, and analysis
tools now available in Photoshop.
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Super Selection Tools and Features

Figure 1-2:
The new
Refine Edge
feature can
be used with
any of the
selection
tools.

If you want the ability to paint your selections, you'll love the new Quick
Selection tool. With this tool, you can easily brush over the image area that
you want to select. By default, additional strokes with the Quick Selection
tool add to the selection. You can delete by holding down Alt (Option on a
Mac) as you stroke. The toolbar provides more options, including New
Selection, Add To Selection, and Subtract From Selection buttons.

The new Refine Edge button, available from any of the selection tool’s
options, is quite helpful in cleaning up selections or adding feathering to
create a vignette of a selection. All of these options are available in a preview
window that includes choices for five different ways to preview the selec-
tion, as shown in Figure 1-2. (Read more detail about selections in Chapter 4
of this minibook.)
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Smart Filters

Photoshop CS3 has taken nondestructive imaging editing to the max with
Smart filters. Don’t worry about destroying your image with filters because
you can now edit filters after they’re applied. When you use a Smart Filter, a
Filter effects mask thumbnail appears in the Layer’s palette. You can select
the mask thumbnail and then, using your paint tools, paint black (or shades
of) to change where and how the filter is applied, or paint white to bring
back the filter.

You can turn off the Smart Filters by selecting the visibility icon in the Layers
palette or adjust filter settings by double-clicking the icon to the right of the
listed filter. It’s worth experimenting with this feature because you can apply
multiple filters. Read more about applying filters in Chapter 8 of this minibook.
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Black-and-White Conversion like a Pro

Figure 1-3:
Use the
Channel
Mixer
options, as
well as other
presets, in
the new
Black &
White
adjustment
layer.

Photoshop CS3 makes creating great-looking black-and-white images easier.
With an image open, you can click the Create New Fill or Adjustment Layer
button in the Layers palette and then select Black & White. The Black and
White dialog box appears, as shown in Figure 1-3. Choose a preset, or cus-
tomize the color conversion by using the Channel mixer adjustments. If
you're converting multiple images, you can save your settings by selecting
the Preset options button to the right of the Presets drop-down menu. If you
want to experiment with more creative options, use the Tint box and add a
color tint to your image as it’s converted.

o IMG_1198.1PG @ 2%% (Black B White 1, Layer ... [2[5][E]

Multiple Planes in Vanishing Point Filter

In Photoshop CS3, you can create images wrapped around multiple perspec-
tive planes, which is great if you're creating package design or needing spa-
tial illustrations. To experiment with this incredible feature:
1. Copy an image and choose Filter=>Vanishing Point.
The Vanishing Point dialog box appears.

2. Using the Create Plane tool, click four corners to make a perspective
plane.

Note that the plane is accurate if the grid is blue.



Figure 1-4:
Animage
wrapped
around
multiple
planes.

Help with Aligning ’53

3. If the grid isn’t blue, use the Edit Plane tool to adjust the corners.

4. Hold down the Ctrl key (Windows) and drag one of the middle nodes.
An additional perspective plane, generated from the original, appears.

5. Paste your image and drag it into your plane.

The image wraps the planes (see Figure 1-4).

Even better, Vanishing Point adjusts brush strokes, healing, and cloning as
you paint over the planes. Note that in Photoshop CS3, you're no longer
restricted to adding planes at 90-degree angles.

Help with Aligning

Ever take several versions of a picture and wish that you could easily combine
and align the images to pick the best of each? With the new Align feature,
you can do just that:
1. Drag similar images into a file to create layers.
These images may be several versions of a group picture, for example.
2. Select the Move tool and Shift+click to select the multiple layers.
3. Click the Auto-Align Layers button in the options bar.
The Auto-Align Layers dialog box appears.
4. Choose your alignment method and click OK.
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Improved Curve Controls

Check out Image=>Adjustment=>Curves for a look at the new improved
curves palette. Wow! It’s like a perfect combination of Levels and Curves.
If you know that you should use Curves, but like the interface of the Level
controls, the improved curve controls are a dream come true. Read about
using the Curves palette in Chapter 7 of this minibook.

Performance Improvements on Intel Macintosh

If you're a Macintosh user, you'll appreciate that Adobe has done a great
job at porting the software to the Intel-based processors. As a Universal
application, the software can run in a native mode on both Intel and
PowerPC Macintosh systems. As part of our testing, we’ve been using both
PC and Macintosh systems, both using Intel Core2 Duo processors. The per-
formance is strong on both platforms. Most noticeable is the huge speed
improvement between Photoshop CS3 running on an Intel-based Macintosh
and Photoshop CS2 running on the same system.

Before Photoshop CS3, the Intel-based Macintosh computers had to interpret
the software so that it could be used because the earlier versions of software
weren’t made for the Intel processors but for the PowerPC processors in the
last generation of Macintosh systems. This release of Photoshop CS3 has
been developed to run efficiently on either legacy or new Macintosh comput-
ers, regardless of the processor.

Compared to earlier versions of Photoshop running on the Intel-based
Macintosh systems, Photoshop CS3 is blazing fast. And if you still have an
older Macintosh system with a PowerPC processor, Photoshop CS3 still
runs on these computers as well.

Additional Features in Photoshop Extended

If you have Photoshop CS3 Extended, it’s probably because you purchased
the Master or one of the Premium Suites, or because you're in the medical,
architecture, manufacturing, or construction business. Photoshop CS3
Extended isn’t necessarily a better version of Photoshop, but it does contain
additional tools to help those users in certain industries get the counting,
viewing, and analysis tools that they need to do their job. As a designer, you
may never need the Counting tool, but it can be invaluable to someone in
manufacturing.
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Some features are in Photoshop Standard, but are enhanced in Photoshop
Extended. For example, although you have animation in the Standard ver-
sion, you see a timeline in the Extended version that has a higher level of
functionality. The following sections are by no means a complete list of
Extended features, but a quick look at some incredibly different features that
have been included in Photoshop CS3 Extended.

3D Layers

For those involved in 3D graphics, Photoshop Extended is a great tool.

You don’t build 3D elements in Photoshop, but you can take advantage

of 3D model visualization and texture editing and export of 3D models from
2D images. Support for common 3D interchange formats lets you import 3D
models, edit their textures, and easily composite designs with images, such
as site photographs.

You can freely rotate and manipulate these models in 3D space in a Photoshop
document. Access the textures applied to the model surfaces and edit them
with the full range of tools in Photoshop CS3 Extended. You can even create
3D models from 2D images, by defining perspective planes in an image with
Vanishing Point and then exporting the model to a 3D format.

Due to the scope of this book, we don’t discuss 3D features in detail, but you
can get step-by-step information by choosing Help=>Photoshop Help.

New Uideo Layers and Movie Paint

Now with the new video layers and the Animation (Timeline) palette,
Photoshop CS3 Extended offers a great new feature for video professionals,
Movie Paint. Movie Paint brings the power of Photoshop painting, retouch-
ing, and pixel level editing to every frame of a movie file. Using the
Animation palette to navigate, you can quickly find and edit any frame of the
movie file. Due to the advanced level of this feature, we don’t cover the
Animation (Timeline) palette in this book.

Comprehensive Image Analysis

Physicians, radiologists, and technicians using Photoshop? Absolutely,
thanks to the new selection, measurement, and analysis tools that let them
quickly extract and export a wide array of quantitative data from micro-
scopic and radiological images (see Figure 1-5).
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Photoshop Extended provides users with tools to count, rulers that can be
recorded in a measurement log, and other high-end analysis tools.



Chapter 2: Getting into
Photoshop CS3 Basics

In This Chapter

v+ Discovering Photoshop

v Organizing your palette

1~ Changing screen modes

Navigating the work area in Photoshop can be slightly cumbersome at
first, especially if you've never worked in a program that relies so
heavily on palettes. In this chapter, we introduce you to Photoshop CS3
and show you how to do basic tasks, such as opening and saving an image.
We also introduce you to the work area, show you what the Photoshop CS3
tools are all about, and reveal how to neatly organize and hide palettes.

Getting Started with Photoshop CS3

3

Unless you use Photoshop as a blank canvas for painting, you may rarely
create a new file in Photoshop because you usually have a source image that
you start with. This image may have been generated by a scanner, digital
camera, or stock image library. You can open existing Photoshop images

by choosing File>Open, selecting the file in the Open dialog box, and then
clicking the Open button.

Photoshop can open a multitude of file formats, even if the image was cre-
ated in another application, such as Illustrator or another image-editing
program, but you have to open the image in Photoshop by choosing
Filec>Open. If you just double-click an image file in a directory (one that
wasn’t originally created in Photoshop, or from different versions), the
image may open only in a preview application.

If you're opening a folder of images that you want to investigate first, choose
Filew>Browse to open Adobe Bridge, the control center for Adobe Creative
Suite. You can use Adobe Bridge to organize, browse, and locate the assets
you need to create your content. Adobe Bridge keeps native PSD, Al, INDD,
and Adobe PDF files, as well as other Adobe and non-Adobe application
files, available for easy access.



158 Getting Started with Photoshop CS3

Adobe Bridge is a standalone application that you can access from all appli-
cations in the Creative Suite by choosing File>oBrowse or by clicking the Go
To Bridge icon in the upper-right corner of the application window. Use the

Bridge interface to view your images as thumbnails and look for Metadata

information.

Creating a new file

If you're creating a new file, you may be doing so to create a composite of
existing files or to start with a blank canvas because you’re super creative.

Discover Camera Raw

If you haven't discovered the Camera Raw
capabilities in Adobe Photoshop, you'll want to
give them a try. Camera Raw is a format avail-
able forimage capture in many cameras. Simply
choose the format in your camera’s settings as
Raw instead of JPEG or TIFF. These raw files
are a bit larger than the standard JPEG files, but
you capture an enormous amount of data with
the image that you can retrieve upon opening.
(See www . adobe . com for a complete list of
cameras supporting Camera Raw.)

A camera raw file contains unprocessed picture
data from a digital camera’s image sensor, along
with information about how the image was cap-
tured, such as the camera and lens used, the
exposure settings, and white balance setting.
When you open the file in Adobe Photoshop
CS3, the built-in Camera Raw plug-in interprets
the raw file on your computer, making adjust-
ments for image color and tonal scale.

When you shoot JPEG images with your
camera, you're locked into the processing done
by your camera, but working with camera raw
files gives you maximum control over your
image, such as controlling the white balance,
tonal range, contrast, and color saturation, as
well as image sharpening. Cameras that can
shoot in RAW format have a setting on the

camera that changes its capture mode to RAW.
Instead of writing a final JPEG, a RAW data file
is written, which consists of black-and-white
brightness levels from each of the several mil-
lion pixel sites on the imaging sensor. The
actual image hasn't yet been produced, and
unless you have specific software, such as the
plug-in built into Adobe Photoshop, opening the
file can be very difficult, if not impossible.

To open a camera raw file, simply choose Filec>
Browse. Adobe Bridge opens, and you see sev-
eral panels, including the Folders, Content,
Preview, and Metadata panels. Using the
Folders panel, navigate to the location on your
computer where you have saved your Camera
Raw images; thumbnail previews appear in the
Content panel. Think of camera raw files as
your photo negative. You can reprocess the file
at any time to achieve the results you want.

If Adobe Photoshop CS3 doesn’t open your raw
file, you may need to update your raw plug-in.
(See www . adobe . com for the latest plug-in.)
The plug-in should be downloaded and placed
in this location in Windows: C:\Program
Files\Common Files\Adobe\Plug-Ins\CS3\File
Formats, and this location on the Macintosh:
Library\Application Support\Adobe\Plug-Ins\
CS3\File Formats.
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For whatever reason, note that when you choose File>New, you have a mul-
titude of basic format choices that you can select from the Preset menu.
They range from basic sizes and resolutions, such as U.S. Paper or Photo, to
other final output such as the Web, Mobile Devices, or Film.

Keep in mind that you’re determining not only size but resolution in your
new file. If your new file is to contain images from other files, make sure the
new file is the same resolution. Otherwise, you may get unexpected size
results when cutting and pasting or dragging images into your new file.
Choose Imager>Image Size to see the document dimensions.

Saving documents

Save an image file by choosing Filem>Save. If you're saving the file for the
first time, the Save As dialog box appears. Notice in the Format drop-

down list that you have plenty of choices for file formats. The different

file formats are discussed in more detail in Chapter 10 of this minibook.

You can always play it safe by choosing the Photoshop (PSD) file format.
The native Photoshop format supports all features in Photoshop. Choosing
some of the other formats may eliminate layers, channels, and other special
features.

Many users choose to save a native Photoshop file as a backup to any
other file formats. It’s especially important to have a backup or original
file saved as a native Photoshop file (PSD) as you increase in capabilities
and start taking advantage of layers and the other great capabilities of
Photoshop.

Getting to Know the Tools

A\

Tools are used to create, select, and manipulate objects in Photoshop CS3.
When you open Photoshop, the toolbox appears along the left edge of the
workspace (see Figure 2-1). We discuss palettes and the palette well in the
upcoming section, “Navigating the Work Area.”

In the toolbox, look for the name of the tool to appear in a ToolTip when
you hover the cursor over the tool. Following the tool name is a letter in
parentheses, which is the keyboard shortcut command that you can use
to access that tool. Simply press the Shift key along with the key command
you see to access any hidden tools. In other words, pressing P activates
the Pen tool, and pressing Shift+P activates the hidden tools under the
Pen tool in the order that they appear. When you see a small triangle at
the lower-right corner of the tool icon, you know that this tool contains
hidden tools.
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Toolbox Image window Palettes Palette well

Figure 2-1:
Photoshop
CS3
workspace
includes the
toolbox,
palettes, and
palette well.
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Table 2-1 lists the Photoshop tools, what each is used for, and in what chap-
ter you can find more about each.

Table 2-1 Photoshop CS Tools
Button Tool What It Does Chapter It’s Covered
in This Minibook
h" Move (V) Moves selections or layers 4
:'—'I Marquee (M) Selects image area 4
)
Lasso (L) Makes freehand selections 4

e
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Tool

What It Does

Chapter It’s Covered
in This Minibook

]

[ 8

U Quick Selection Selects similar pixels 4
: "ﬁhu Tool (New) (W)
% Crop (C) Crops an image 2
Slice (K) Creates HTML slices n/a
X
- Book I
Spot Healing Retouches flaws 8
ﬁ Brush (J) Chapter 2
a4
Brush (B) Paints foreground color 8 ) =
(=]
.ﬁf, w2
QD »n =
e=3
Clone Stamp (S) Copies pixel data 8 85 35
38
a4 w
IFr History Brush (Y) Paints from selected state 8
-.-‘
g Eraser (E) Erases pixels 8
F]
Ij Gradient (G) Creates a gradient 8
A Blur (R) Blurs pixels 8
.
.\- Toning (0) Dodges, burns, saturates 8
r |
n;:) Pen (P) Creates paths 5
a4
Type (T) Creates text 9

(continued)
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Table 2-1 (continued)

Button Tool What It Does Chapter It’s Covered
in This Minibook
Path Selection (A)  Selects paths 5
k.
Vector Shape (U)  Creates vector shapes 9
&
— Notes (N) Makes annotations n/a
F a4
Eyedropper (1) Samples pixels 8
Z,
-:.'-:'-IP Hand (H) Navigates page 9
a
q Zoom (Z) Increases, decreases view 2

\\3
Looking for the Magic Wand tool? Click and hold on the Quick Selection tool
in the toolbar to access it.

Navigating the Work Area

Getting around in Photoshop isn’t much different from getting around in
other Adobe applications. All Adobe applications make extensive use of
palettes, for example. In the following sections, we cover the highlights on
navigating in Photoshop.

Docking and saving palettes

Palettes, palettes everywhere . . . do you really need them all? Maybe not

just yet, but as you increase your skill level, you’ll take advantage of most

(if not all) of the Photoshop palettes. The palettes give you easy access to
WMBER important functions.

As you work in Photoshop, keep in mind these two key commands:
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4+ Press Tab to switch between hiding and showing the tools and palettes.

4+ Press Shift+Tab to hide the palettes, leaving only the toolbox visible.

On the far right of the Options bar (a toolbar that contains the options for
each tool and appears across the top of the work area) is the palette well,
which helps you organize and manage palettes. The palette well stores, or
docks, palettes so that you can access them easily. (See Figure 2-1, earlier in
this chapter.)

The palette well is available only when using a screen resolution greater
than 800 x 600 pixels (a setting of at least 1024 x 768 is recommended). Dock
palettes in the palette well by dragging the palette’s tab into the palette well;
release when the palette well is highlighted.

If you find that you're always using the same palettes, hide the palettes that
you don’t need and arrange your other palettes on-screen where you want
them. Then follow these steps to save that palette configuration:

1. Choose Window+>Workspacer>Save Workspace.

2. In the Save Workspace dialog box that appears, name the Workspace
and click Save.

3. Any time you want the palettes to return to your saved locations, choose
Window~>Workspacer>Name of Your Workspace (where Name of
Your Workspace is the name you supplied in Step 2).

Choose Window=>Workspace=>Reset Palette Locations to put the palettes
back in the same order they were upon the initial installation.

Taking advantage of new workspace features

Photoshop CS3 now has included many saved workspaces that you can take
advantage of to streamline workspaces and open the palettes you need for
specific tasks. These new features include workspaces for Web Design,
Painting and Retouching, and Color and Tonal Correction to name a few.

Increase your work area by turning your palettes into icons, as shown in
Figure 2-2. Do so by either right-clicking the tab of a palette and selecting
Collapse To Icons or clicking the Auto Collapse gray bar at the top of the
palette drawer. Yes, you heard it correctly — the area where the palettes are
located is actually a drawer that can be adjusted in or out by clicking and
dragging on the vertical pane to the left of the palettes.
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Zooming in to get a better look

What looks fine at one zoom level may actually look very bad at another.
You'll find yourself zooming in and out quite often as you work on an image
in Photoshop. You can find menu choices for zooming in the View menu; a
quicker way to zoom is to use the keyboard commands listed in Table 2-2.

Table 2-2 Zooming and Navigation Keyboard Shortcuts

Command Windows Shortcut Mac Shortcut

Actual size Alt+Ctrl+0 8+1

Fitin window  Ctrl+0 (zero) 88 +0 (zero)

Zoom in Ctrl++ (plus sign) or Ctrl+Spacebar 88 ++ (plus sign) or 88 +Spacebar
Zoom out Ctrl+— (minus) or Alt+Spacebar & +— (minus) or Option+Spacebar
Hand tool Spacebar Spacebar

Here are a few things to keep in mind as you work with the Zoom tool to get
a better look at your work:

4 100-percent view: Double-clicking the Zoom tool in the toolbox puts you
at 100 percent view. Do this before using filters to see a more realistic
result of your changes.

4+ Zoom marquee: Drag from the upper left to the lower right of the area
you want to zoom to. While dragging, a marquee appears; When you
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release the mouse button, the marqueed area zooms up to fill the image
window. The Zoom marquee gives you much more control than just
clicking on the image with the Zoom tool. Zoom back out to see the entire
image by pressing Ctrl+0. It fits the entire image in the viewing area.

\P
) 4+ Zoom using the keyboard shortcuts: If you have a dialog box open and

you need to reposition or zoom to a new location on your image, you
can use the keyboard commands without exiting the dialog box.

4+ A new window for a different look: Choose Window=>Arrange=
New Window to create an additional window for your front-most image.
This technique is helpful when you want to see the entire image (say, at
actual size)or to see the results as a whole, yet zoom in to focus on a
small area of the image to do some fine-tuning. The new window is
dynamically linked to the original window so that as you make changes,
the original and any other new windows created from the original are
A\ immediately updated.

Book I
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4+ Cycle through images: Press Ctrl+Tab to cycle through open images.
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Choosing Your Screen Mode

You have a choice of three screen modes in which to work. Most users start
and stay in the default (standard screen mode) until they accidentally end
up in another. The four modes are

4 Maximized Screen mode displays a maximized document window that
fills all available space between docks and that resizes when dock
widths change.

4+ Standard mode is the typical view, where you have an image window
open but can see your desktop and other images open behind.

4 Full-screen mode with menu view surrounds the image out to the edge
of the work area with a neutral gray. This mode not only prevents you
from accidentally clicking out of an image and leaving Photoshop, but
also from seeing other images behind your working image.

4 Full screen mode, no menu is a favorite with multimedia types. It shows
your image surrounded by black and also eliminates the menu items
from the top of the window. Press Tab to hide all tools, and you have a
very clean work environment.
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Cropping an Image
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A simple but essential task is to crop your image. Cropping means to elimi-
nate all that is not important to the composition of your image. Cropping is
especially important in Photoshop. Each pixel, no matter what color, takes
up the same amount of information, so cropping eliminates unneeded pixels
and saves on file size and processing time, so you want to crop your image
before you start working on it.

You can crop an image in Photoshop CS3 in two ways:

4 Use the Crop tool.

4+ Select an area with the Marquee tool and choose Imager> Crop.
To crop an image by using the Crop tool, follow these steps:

1. Press C to access the Crop tool and drag around the area of the image
that you want to crop to.

2. If you need to adjust the crop area, drag the handles in the crop-
bounding area.

3. When you’re satisfied with the crop bounding area, double-click in
the center of the crop area or press the Return or Enter key to crop
the image.

4. If you want to cancel the crop, press the Esc key.

Ever scan in an image crooked? When using the Crop tool, if you position the
cursor outside any of the handles, a rotate symbol appears. Drag the crop’s
bounding area to rotate it and line it up as you want it cropped. When you
press Return or Enter, the image is straightened out.
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with Mode Matters

In this Chapter
+» Working in black and white

v+ Understanding Photoshop image modes

Before diving into Photoshop, you must know what image mode you
should be working in and how important color settings are. So no
matter whether you're doing a one-color newsletter, a full-color logo, or
something in between, this chapter can help you create much better
imagery for both Web and print.

Working with Bitmap Images

You may have already discovered that Photoshop works a little differently
than most other applications. In order to create those smooth gradations
from one color to the next, Photoshop takes advantage of pixels. Bitmap
images (sometimes called raster images) are based on a grid of pixels. The
grid is smaller or larger depending on the resolution that you're working in.
The number of pixels along the height and width of a bitmap image are called
the pixel dimensions of an image, which are measured in pixels per inch
(ppi). The more pixels per inch, the more detail in the image.

Unlike vector graphics (mathematically created paths), bitmap images can’t
be scaled without losing detail. (See Figure 3-1 for an example of a bitmap
image and a vector graphic.) Generally, it’s best to use bitmap images at or
close to the size that you need. If you resize a bitmap image, it can become
jagged on the edges of sharp objects. On the other hand, you can scale
vector graphics and edit them without degrading the sharp edges.

Photoshop has the capability to work on both bitmap and vector art. (See
the path line around the vector shape layer and notice that the path isn’t
pixilated.) It gives you, as a designer, incredible opportunities when combin-
ing the two technologies.
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Figure 3-1:
Bitmap
Versus
vector.

For information on changing and adjusting image resolution, see Chapter 6
of this minibook.

Bitmap Vector

0° O°

Choosing the Correct Photoshop Mode

Choose Imager>Mode to view the image mode choices you can choose from.
Selecting the right one for an image is important because each mode offers
different capabilities and results. For example, if you choose the Bitmap
mode, you can work only in black and white . . . that’s it. No shades of color,
not even a gray. Most features are disabled in this Bitmap mode. This is fine
if you're working on art for a black-and-white logo, but not for most images.
If, instead, you work in the RGB mode, you have full access to Photoshop’s
capabilities. So read on to see what image mode is best for your needs.
When you’re ready to make your mode selection, have a file open and
choose a selection from Image=>Mode. You can read descriptions of each
image mode in the following sections.

Along with a description of each image mode, we include a figure showing
the Channels palette set to that mode. A channel is simply the information
about color elements in the image. The number of default color channels in
an image depends on its color mode. For example, a CMYK image has at
least four channels, one each for cyan, magenta, yellow, and black informa-
tion. Grayscale has one channel. If you understand the printing process,
think of each channel representing a plate (color) that, when combined,
creates the final image.

Bitmap

Bitmap mode offers little more than the ability to work in black and white.
Many tools are unusable, and most menu options are grayed out in this
mode. If you're converting an image to bitmap, you must convert it to
Grayscale first.



Figure 3-2:
Grayscale
supports
256 shades
of gray.
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Grayscale

Use Grayscale mode, shown in Figure 3-2, if you're creating black-and-white
images with tonal values, specifically for printing to one color. Grayscale
mode supports 256 shades of gray in the 8-bit color mode. Photoshop can
work with Grayscale in 16-bit mode, which provides more information, but
may limit your capabilities when working in Photoshop.

When you convert to Grayscale mode, you get a warning message confirming
that you want to discard all color information. If you don’t want to see this
warning every time you convert an image to grayscale, select the option to
not show the dialog box again before you click Discard.
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Duotone

Use Duotone mode when you’re creating a one- to four-color image created
from spot colors (solid ink, such as Pantone colors). You can also use the
Duotone mode to create Monotones, Tritones, and Quadtones. If you're pro-
ducing a two-color job, duotones create a beautiful solution to not having
full color.

The Pantone Matching color system helps to keep printing inks consistent
from one job to the next. By assigning a numbered Pantone color, such as
485 for red, you don’t risk one vendor (printer) using fire-engine red, and the
next using orange-red for your company logo.
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Figure 3-3:
Click the
white
swatch to
open the
Color
Libraries
dialog box.

To create a Duotone, follow these steps:

S

. Choose Imager~>Moder>Grayscale.
. Choose Image~>Moder>Duotone.

. In the Duotone dialog box, choose Duotone from the Type drop-

down list.

Your choices range from Monotone (one-color) up to Quadtone (four-
color). Black is automatically assigned as the first ink. But you can
change that if you like.

. To assign a second ink color, click the white swatch immediately

under the black swatch to open the Color Libraries dialog box, as
shown in Figure 3-3.

. Now comes the fun part: Type (quickly!) the Pantone or PMS number

that you want to access and then click OK.

There is no text field for you to enter the number in, so don’t look for
one. Just type the number while the Color Libraries dialog box is open.

Try entering 300 for an easy one. That selects PMS 300.

. You can already see that you have created a tone curve, but click the

Curve button to the left of the ink color to further tweak the colors.

. Click and drag the curve to adjust the black in the shadow areas, per-

haps to bring down the color overall; experiment with the results.

Color Libraries
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PANTOMC 400 C
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PANTONE 55 C ,obo=E

PANTOHE 407 €
Iype 2 codar name to

select it in the color fist,
BANTONE 488

LAN IO a0

8. (Optional) If you like your Duotone settings, store them by clicking

the Save button.
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Figure 3-4:
Index color
uses a
limited
number of
colors to
create an
image.
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Click the Load button to find your customized presets and to find preset
Duotones, Tritones, and Quadtones supplied to you by Adobe.

Duotone images must be saved in the Photoshop EPS format in order to
support the spot colors. If you chose another format, you risk the possi-
bility of converting your colors into a build of CMYK (Cyan, Magenta,
Yellow, and Black.)

9. Click OK when you’re finished.

Index color

You may not work in Index color, but you probably have saved a file in this
mode. Index color mode (see Figure 3-4) uses a color look-up table (CLUT) in
order to create the image.

Tndesed Color <]
Palatte: | Locd (Schoctine) i) ot
Cokors; | 10 | o
Forced: | Buck ared White. % FProvirw

[ Trarepunon ¥

Options

Dither: | Crffusion |
Armaunt: | 75 o
[Irreserve Exact Colors

A color look-up table contains all the colors that make up your image, like a
box of crayons used to create artwork. If you have a box of eight crayons
and only those crayons are used to color an image, you have a color look-up
table of only eight colors. Of course, your image would look much better if
you used the 64-count box of crayons with the sharpener on the back, but
those additional colors increase the size of the color look-up table, as well as
the file size.

The most colors that can be in index mode are 256. When saving Web
images, you often have to define a color table. We discuss the Save For Web
feature (which helps you to more accurately save an index color image) in
Chapter 10 of this minibook.
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Figure 3-5:
RGB creates
the image
from red,
green, and
blue.
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Choose Image>Mode=>Color Table to see the color table making up an
image.

RGB

RGB (Red, Green, Blue), shown in Figure 3-5, is the standard format that you
work in if you import images from a digital camera or you scan images on a
scanner in RGB mode. For complete access to features, RGB is probably the
best color mode to work in. If you're working on images for use on the Web,
color copiers, desktop color printers, and on-screen presentations, you want
to stay in the RGB mode.

| Channels » =

Cirl4r

If you're having your image printed on a press (for example, if you're having
the image professionally printed), it must be separated. Don’t convert
images to CMYK mode until you're finished with the color correction and
you know that your color settings are accurate. A good print service may
want the RGB file so that it can do an accurate conversion.

CMYK

CMYK (Cyan, Magenta, Yellow, Black) is the mode used for final separations
for the press. Use a good magnifying glass to look closely at anything that
has been printed in color, and you may see the CMYK colors that created it.
A typical four-color printing press has a plate for each color and runs the
colors in the order of cyan, magenta, yellow, and then black.

Don’t take converting an image into this mode lightly. You need to make deci-
sions when you convert an image to CMYK, such as where the file is going to
be printed and on what paper stock, so that the resulting image is the best it
can be. Talk to your print provider for specifications that are important
when converting to CMYK mode.
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Lab color

Lab (Lightness, A channel, and B channel) is a color mode that many high-
end color professionals use because of its wide color range. Using Lab, you
can make adjustments to luminosity (lightness) without affecting the color.
In this mode, you can select and change an L (Lightness or Luminosity)
channel without affecting the A channel (green and red) and the B channel
(blue and yellow).

Lab mode is also a good mode to use if you're in a color-managed environ-
ment and want to easily move from one color system to another with no loss
of color.

Some professionals prefer to sharpen their images in LAB mode because
they can select just the Lightness channel and choose Filter~>Sharpen=>
Unsharp Mask to sharpen only the gray matter of the image, leaving the
color noise-free.

Multichannel

Multichannel is used for many things; sometimes you end up in this mode,
and you’re not quite sure how. Deleting a channel from an RGB, CMYK, or
Lab image automatically converts the image to Multichannel mode. This
mode supports multiple spot colors.

Bit depth

You have more functionality in 16-bit and even 32-bit mode. Depending upon
your needs, you may spend most of your time in 8-bit mode, which is more
than likely all that you need.

Bit depth, also called pixel depth or color depth, measures how much color
information is available to display or print each pixel in an image. Greater bit
depth means more available colors and more accurate color representation
in the digital image. In Photoshop, this increase in accuracy does also limit
some of the features available, so don’t use it unless you have a specific
request or need for it.

To use 16-bit or 32-bit color mode, you also must have a source to provide
you with that information, such as a scanner or camera that offers a choice
to scan at 16-bit or 32-bit.
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Chapter 4: Creating a Selection

In This Chapter

v+ Discovering the selection tools

v+~ Painting selections the easy way

v+~ Giving transformed selections a try
v Feathering away

+ Keeping selections for later use

1~ Using the new Vanishing Point feature

It’s common to use Photoshop to create compositions that may not actu-
ally exist and to retouch images to improve them. What you don’t want is
obvious retouching or a composition that looks contrived. (The exception is
if you intend an image to be humorous, such as putting baby Joey’s head on
Daddy’s body.)

That’s where the selection tools come in. In this chapter, you discover several
selection methods and how to use the selection tools to make your images
look as though you haven’t retouched or edited them. Even if you're an experi-
enced Photoshop user, this chapter provides a plethora of tips and tricks that
can save you time and help make your images look absolutely convincing.

Getting to Know the Selection Tools

WMBER
@8‘
&

You create selections with the selection tools. Think of selections as windows
in which you can make changes to the pixels. Areas that aren’t selected

are masked, which means that these unselected areas are unaffected by
changes, much like when you tape around windows and doors before you
paint the walls. In this section, we briefly describe the selection tools and
show you how to use them. You must be familiar with these tools in order to
do anything in Photoshop.

As with all the Photoshop tools, the Options bar across the top of the
Photoshop window changes with each selection tool. The keyboard com-
mands you read about in this section exist on the Options bar as buttons.

If you move a selection with the Move tool, pixels move as you drag, leaving
a blank spot in the image. To clone a selection (that is, to copy and move the
selection at the same time), Alt+drag (Option+drag on a Mac) the selection
with the Move tool.
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The Marquee tool

The Marquee tool is the main selection tool; by that, we mean that you'll use
it most often for creating selections. The exception, of course, is when you
have a special situation that calls for a special tool, either the Lasso, Magic
Wand tool, or the new Quick Selection tool. Throughout this section, we
describe creating (and then deselecting) an active selection area; we also
provide you with tips for working with selections.

The Marquee tool includes the Rectangular Marquee (for creating rectangular
selections), Elliptical Marquee (for creating round or elliptical selections),
and Single Row Marquee or Single Column Marquee tools (for creating a
selection of a single row or column of pixels). You can access these other
Marquee tools by holding down on the default, Rectangle Marquee tool.

To create a selection, select one of the Marquee tools (remember you can
press M) and then drag anywhere on your image. When you release the
mouse button, you create an active selection area. When you’re working on
an active selection area, whatever effects you choose are applied to the
whole selection. To deselect an area, you have three choices:

4 Choose Select>Deselect.
4 Press Ctrl+D.

4+ While using a selection tool, click outside the selection area.

How you make a selection is important because it determines how realistic
your edits appear on the image. You can use the following tips and tricks
when creating both rectangular and elliptical selections:

4+ Add to a selection by holding down the Shift key; drag to create a
second selection that intersects the original selection (see the left image
in Figure 4-1). The two selections become one big selection.

4+ Delete from an existing selection by holding the Alt (Option on a Mac)
key and then drag to create a second selection that intersects the origi-
nal selection where you want to take away from the original selection
(on the right in Figure 4-1).

4+ Constrain a rectangle or ellipse to a square or circle by Shift+dragging;
make sure that you release the mouse button before you release the
Shift key. Holding down the Shift key makes a square or circle only when
there are no other selections. (Otherwise, it adds to the selection.)

4+ Make the selection from the center by Alt+dragging (Option+dragging on
a Mac); make sure that you release the mouse button before the Alt or
(Option) key.



Figure 4-1:
You can add
and delete
from
selections.
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4+ Create a square or circle from the center out by Alt+Shift+dragging
(Option+Shift+dragging on a Mac). Again, make sure that you always
release the mouse button before the modifier keys.

4+ When making a selection, hold down the spacebar before releasing the
mouse button to drag the selection to another location.

Fixed size

If you've created an effect that you particularly like — say, changing a block
of color in your image — and you’d like to apply it multiple times throughout
an image, you can do so. To make the exact same selection multiple times,
follow these steps:

1. With the Marquee tool selected, select Fixed Size from the Style drop-
down list on the Options bar.

You can also select Fixed Ratio from the Style drop-down list to create a
proportionally correct selection, but not fixed to an exact size.

2. On the Options bar, type the Width and Height values into the appro-
priate text fields.

You can change ruler increments by choosing Edit=>Preferences=
Units And Rulers (Photoshopr>Preferences>Units And Rulers on a Mac).

3. Click the image.
A selection sized to your values appears.

4. With the selection tool, drag the selection to the location that you
want selected.
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Figure 4-2:
The Float
iconis used
on the left,
and the
Move icon
is used on
the right.
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Shift+drag a selection to keep it aligned to a straight, 45-degree, or 90-degree
angle.

Floating and nonfloating selections

As a default, when you’re using a selection tool, such as the Marquee tool,
your selections are floating, which means that you can drag them to another
location without affecting the underlying pixels. You know that your selection
is floating by the little rectangle that appears on your cursor (see the left
image in Figure 4-2).

If you want to, however, you can move the underlying pixels. With the selection
tool of your choice, just hold down the Ctrl (88 on a Mac) key to temporarily
access the Move tool; the cursor changes to a pointer with scissors, denot-
ing that your selection is nonfloating. Now, when you drag, the pixel data
comes with the selection (as shown on the right in Figure 4-2).

Hold down Alt+Ctrl (Option+88 on a Mac) while using a selection tool and drag
to clone (copy) pixels from one location to another. Add the Shift key, and
the cloned copy is constrained to a straight, 45-degree, or 90-degree angle.

The Lasso tool

Use the Lasso tool for freeform selections (selections of an irregular shape).
To use the Lasso tool, just drag and create a path surrounding the area to be
selected. If you don’t return to your start point to close the selection before
you release the mouse button, Photoshop completes the path by finding the
most direct route back to your starting point.
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Just like with the Marquee tool, you can press the Shift key to add to a lasso
selection and press the Alt (Option on a Mac) key to delete from a lasso
selection.

Hold down on the Lasso tool to show the hidden Lasso tools, the Polygonal
Lasso and the Magnetic Lasso tool. Use the Polygonal Lasso tool by clicking
on a start point and then clicking and releasing from point to point until you
come back to close the selection. Use the Magnetic Lasso tool by clicking to
create a starting point and then hovering the cursor near an edge in your
image. The Magnetic Lasso tool is magnetically attracted to edges; as you
move your cursor near an edge, the Magnetic Lasso tool creates a selection
along that edge. Click to manually set points in the selection; when you get
back to the starting point, click to close the selection.

You may find that the Polygonal Lasso and the Magnetic Lasso tools don’t
make as nice of a selection as you’d like. Take a look at the upcoming sec-
tion, “Painting with the Quick Mask tool,” for tips on making finer selections.

The new Quick Selection tool

The Quick Selection tool lets you quickly “paint” a selection using a round
brush tip of adjustable size. Click and drag and watch as the selection
expands outward and automatically follows defined edges in the image.

A Refine Edge command lets you improve the quality of the selection
edges and visualize the selection in different ways for easy editing.

Follow these steps to find out how you can take advantage of this new tool:

1. Start by choosing File->Open and opening a file named Sunflower.psd
that already exists in your Photoshop CS3 Samples folder.

You can find the file in the following location on the Windows OS at
C:\Program Files\Adobe\Adobe Photoshop CS3\Samples and on the
Mac OS at Applications\Adobe\Adobe Photoshop CS3\Samples.

2. Select the Quick Selection tool.

3. Position the cursor over the yellow petals of the sunflower and notice
the brush size displayed with the cursor; click and drag to start paint-
ing the selection.

You can adjust the size of the painting selection by pressing [ to make
the brush size smaller or ] to make the brush size larger.

4. Using the Add To Selection or Subtract From Selection buttons in the
toolbar options, you can paint more of the selection or deselect active
areas (see Figure 4-3).
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Figure 4-3:
The Quick
Selection
tool allows
you to paint
your
selection.
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The Magic Wand tool

The Magic Wand tool is particularly helpful when you’re working on an
image of high contrast or with a limited number of colors. This tool selects
individual pixels of similar shades and colors. Select the Magic Wand tool,
click anywhere on an image, and hope for the best — the Magic Wand tool
isn’t magic at all. You decide how successful this tool is. What we mean by
that is that you control how closely matched each pixel must be in order for
the Magic Wand tool to include it in the selection. You do so by setting the
tolerance on the Options bar.

When you have the Magic Wand tool selected, a Tolerance text field appears
on the Options bar. As a default, the tolerance is set to 32. When you click
with a setting of 32, the Magic Wand tool selects all pixels within 32 shades
(steps) of the color that you clicked. If it didn’t select as much as you want,
increase the value in the Tolerance text field (all the way up to 255). The
amount that you enter really varies with each individual selection. If you're
selecting white napkins on an off-white tablecloth, you can set as low as 5 so
that the selection doesn’t leak into other areas. For colored fabric with lots
of tonal values, you might increase the tolerance to 150.
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Don'’t fret if you miss the entire selection when using the Magic Wand tool.
Hold down the Shift key and click in the missed areas. If it selects too much,
choose Edit=>Undo (Step Backwards) or press Ctrl+Z, reduce the value in the
Tolerance text field, and try again.

\\3

Manipulating Selections

After you master creating selections, you'll find that working with the
selections — painting, transforming, and feathering them — can be easy

and fun.
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Painting with the Quick Mask tool
If you have fuzzy selections (fur, hair, or leaves, for example) or you're having 5
difficulty using the selection tools, the Quick Mask tool can be a huge help =
because it allows you to paint your selection uniformly in one fell swoop. a
-
v
To enter into Quick Mask mode, create a selection and then press Q. %
(Pressing Q again exits you from Quick Mask mode.) You can also click the =,
Quick Mask button at the bottom of the toolbox. If you have a printing back- ]

ground, you’ll notice that the Quick Mask mode, set at its default color (red),
resembles something that you may want to forget: rubylith and amberlith.
(Remember slicing up those lovely films with Exacto blades before computer
masking came along?) In Quick Mask mode, Photoshop shows your image as
it appears through the mask. The clear part is selected; what’s covered in
the mask isn’t selected.

To create and implement a quick mask, follow these steps:

1. Press Q to enter Quick Mask mode.

2. Press D to change the foreground and background color boxes the
default colors of black and white.

3. Select the Brush tool and start painting with black in the clear area of
the image in Quick Mask mode.

It doesn’t have to be pretty; just get a stroke or two in there.
4. Press Q to return to the Selection mode.

You’re now out of Quick Mask mode. Notice that where you painted with
black (it turned red in the Quick Mask mode), the pixels are no longer
selected.

5. Press Q again to re-enter the Quick Mask mode and then press X.

This step switches the foreground and background colors (giving you
white in the foreground, black in the background).
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6. Using the Brush tool, paint several white strokes in the red mask area.
The white strokes turn clear in the Quick Mask mode.
7. Press Q to return to the Selection mode.

Where you painted white in the Quick Mask mode is now selected.

When in Quick Mask mode, you can paint white over areas you want selected
and black over areas that you don’t want selected. When painting in the
Quick Mask mode, increase the brush size by pressing the ] key. Decrease
the brush size by pressing the [ key.

In the Selection mode, your selection seems to have a hard edge; you can
soften those hard edges by using a softer brush in the Quick Mask mode. To
make a brush softer, press Shift+[ and press Shift+] to make a brush harder.

Because the Quick Mask mode makes selections based on the mask’s values,
you can create a mask by selecting the Gradient tool and dragging it across
the image in Quick Mask mode. When you exit Quick Mask mode, it looks as
though there is a straight-line selection, but actually the selection transitions
as your gradient did. Choose any filter from the Filters menu and notice how
the filter transitions into the untouched part of the image to which we
applied the new and improved Graphic Pen filter.

If you're working in Quick Mask mode, choose Windowr>Channels to see that
what you’re working on is a temporary alpha channel. See the later section,
“Saving Selections,” for more about alpha channels.

Transforming selections

Don’t deselect and start over again if you can just nudge or resize your selec-
tion a bit. You can scale, rotate, and even distort an existing selection.
Follow these steps to transform a selection:

1. Create a selection and then choose Select=>Transform Selection.
You can use the bounding box to resize and rotate your selection.

¢ Drag the handles to make the selection larger or smaller. Drag a
corner handle to adjust width and height simultaneously. Shift+drag
a corner handle to size proportionally.

¢ Position the cursor outside of the bounding box to see the Rotate
icon; drag when it appears to rotate the selection. Shift+drag to con-
strain to straight, 45-degree, or 90-degree angles.

¢ Ctrl+drag (88+drag on a Mac) a corner point to distort the selection,
as shown in Figure 4-4.

2. Press Return or Enter or double-click in the center of the selection
area to confirm the transformation; press Esc to release the transfor-
mation and return to the original selection.
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Figure 4-4:
Distort,
resize, and
rotate a
selection
using the
Transform
Selection Book Il
feature. Chapter 4
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Feathering &
Knowing how to retouch an image means little if you don’t know how to o
make it discreet. If you boost up the color using curves to the CEO’s face, e
do you want it to appear like a pancake has been attached to his cheek? =
=

Of course not — that isn’t discreet at all (or very wise). That’s where
feathering comes in. Feathering a selection blurs its edges, so as to create a
natural-looking transition between the selection and the background of the
image.

To feather an image, follow these steps:

1. Create a selection.

For the nonfeathered image shown on top in Figure 4-5, we used the
Elliptical Marquee tool to make a selection. We then copied the selec-
tion, created a new, blank image, and pasted the selection into the new
image.

To create the feathered image on the bottom in Figure 4-5, we used the

Elliptical Marquee tool to select the same area on the original image and
went on to Step 2.

2. Choose Select=>Modify->Feather.

3. In the Feather dialog box that appears, type a value in the Feather
Radius text field and then click OK.

For example, we entered 20 in the Feather Radius text field. (We then
copied the selection, created a new image, and pasted the feathered
selection into the new image to create the image on the bottom of
Figure 4-5.) Voila! The edges of the image are softened over a 20-pixel
area, as shown on the bottom of Figure 4-5. This technique is also
referred to as a vignette in the printing industry.
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Figure 4-5:
The top
image
doesn't have
feathering,
while the
second has
feathering
applied.
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The results of the feathering depend upon the resolution of the image. A
feather of 20 pixels in a 72-ppi (pixels per inch) image will be a much larger
area than a feather of 20 pixels in a 300-ppi image. Typical amounts for a nice
vignette on an edge of an image would be 20 to 50 pixels. Experiment with
your images to find what works best for you.

This feathering effect created a nice soft edge to your image, but it’s also
useful when retouching images:

1. Using any selection method, create a selection around a part of an
image that you want to lighten.

2. Choose Select->Modify=>Feather; in the Feather dialog box that
appears, enter 25 in the Feather Radius text field and click OK.

If you get an error message stating, No Pixels are more than 50% selected,
click OK and create a larger selection.

3. Choose Image=>Adjustments=>Curves.

4. Click in the center of the curve to add an anchor point and drag up to
lighten the image.

This step lightens the midtones of the image.
Notice how the lightening fades out so that there is no definite edge to the

correction. You can have more fun like this in Chapter 7 of this minibook,
where we cover color correction.

Selections

The term alpha channel sounds pretty complicated, but it’s simply a saved
selection. Depending upon the mode you’re in, you already have several
channels to contend with. A selection is just an extra channel that you can
call on at any time.

To create an alpha channel, follow these steps:

1. Create a selection that you want to save.
2. Choose Select=>Save Selection.
3. Name the Selection and click OK.

In the Channels palette is an additional named channel that contains
your selection.

Book I
Chapter 4
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To load a saved selection, follow these steps:

1. Choose Select->Load Selection.
The Load Selection dialog box appears.
2. Select your named channel from the Channel drop-down list.

If you have an active selection and then choose to load a selection, you
have additional options. You can do the following with an active selec-
tion when loading a channel by selecting one of the following options:

e New Selection: Eliminate the existing selection and create a new
selection based upon the channel you select.

¢ Add To Selection: Add the channel to the existing selection.

¢ Subtract From Selection: Subtract the channel from the existing
selection.

¢ Intersect With Selection: Intersect the channel with the existing
selection.

3. Click OK.
$\Q,p.\. ST(,&

Other Adobe applications, such as InDesign, Illustrator, Premiere, and After
Effects, can also recognize alpha channels.

Using the New Vanishing Point Feature

This incredible new feature lets you preserve correct perspective in edits
of images that contain perspective planes, such as the sides of a building.
You can do so much with this feature, and we provide you with a simple
introduction. Try experimenting with multiple planes and copying and
pasting items into the Vanishing Point window for even more effects.
Follow these steps:

1. Open a file that you want to apply a perspective filter to.

For this example, we used the file named Vanishing Point.psd.

You can find the file in Windows OS at C:\Program Files\Adobe\
Adobe Photoshop CS3\Samples and on the Mac OS at Applications\
Adobe\Adobe Photoshop CS3\Samples.

2. Create a new blank layer by clicking the Create A New Layer button at
the bottom of the Layers palette.

If you create a new layer each time you use Vanishing Point, the results
appear on a separate, editable layer. You can then use layer features,
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such as opacity, layer styles, and blending modes. Putting the Vanishing
Point results in a separate layer also preserves your original image.

. Choose Filter=>Vanishing Point.

A separate Vanishing Point window appears. If you receive an error mes-
sage about an existing plane, click OK.

If you're using a sample file from Photoshop, it may or may not have the
plane at release time. To help you understand this feature better, you
should delete the existing plane by pressing the Delete or Backspace key.

. Select the Create Plane tool and define the four corners nodes of the

plane surface.
Try to use objects in the image to help create the plane.

After the four corner nodes of the plane are created, the tool automati-
cally is switched to the Edit Plane tool.

. Select and drag the corner nodes to make an accurate plane.

The plane grid should appear blue, not yellow or red, if it’s accurate.

After creating the plane, you can move, scale, or reshape the plane. Keep
in mind that your results depend on how accurately the plane lines up
with perspective of the image.

You can use your first Vanishing Point session to simply creating perspec-
tive planes and then click OK. The planes appear in subsequent Vanishing
Point sessions when you choose Filter=>Vanishing Point. Saving perspec-
tive planes is especially useful if you plan to copy and paste an image
into Vanishing Point and need to have a ready-made plane to target.

. Choose the Stamp tool in the Vanishing Point window and then choose

On from the Heal drop-down menu in the options bar.

You’re going to love where this is going. In the example, we simply clone
the blue broom, but it should get your brains working about all the ways
that you can apply this greatly improved feature.

. With the Stamp tool still selected, cross over the middle part of the

broom and Alt+click (Option+Click on a Mac) to define it as the source
that is to be cloned.

. Without clicking, move toward the back of the perspective plane and

click and drag to reproduce the cloned part of the image, in this case
the broom.

Notice that it’s cloned as a smaller version, in the correct perspective
for its new location.

Book I
Chapter 4
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9.

10.

Start from Step 7 and clone the broom in front of the dog or clone any
region of an image up closer to the front of the perspective pane.

The cloned region is now cloned as a larger version of itself.

You can use the Marquee tool options (Feather, Opacity, Heal, and Move
Mode) at any time, either before or after making the selection. When you
move the Marquee tool, the Stamp tool, or the Brush tool into a plane,
the bounding box is highlighted, indicating that the plane is active.

Click OK.

To preserve the perspective plane information in an image, save your
document in PSD, TIFF, or JPEG format.



Chapter 5: Using the
Photoshop Pen Tool

In this Chapter
v Putting shape layers to work
v+~ Using a path as a selection

1 Creating clipping paths

r]e Pen tool is the ultimate method to make precise selections. You can
also use it to create vector shapes and clipping paths (silhouettes). In this
chapter, you discover how to take advantage of this super multitasking tool.
This chapter also shows you how to apply paths made with the Pen tool as
shapes, selections, and clipping paths. If you're interested in the fundamen-
tals of creating paths with the Pen tool in Illustrator, check out Book IV,
Chapter 5, where we cover the Pen tool in more detail.

We recommend that you use the Pen tool as much as you can to truly master
its capabilities. If you don’t use it on a regular basis, it will seem awkward,
but it does get easier! Knowing how to effectively use the Pen tool puts you
a grade above the average Photoshop user, and the quality of your selections
will show it. Read Chapter 9 of this minibook to find out how to use the Pen
tool to create layer masks and adjustment layers.

Using Shape Layers

As a default, when you start creating with the Pen tool, Photoshop automati-
cally creates a shape layer, which is useful for adding additional elements,
but is frustrating if you're attempting to create just a path with the Pen tool.
Select the Pen tool and note the default setting on the left side of the
Options bar. You can choose from the following options:

4+ Shape layers: Creates a new shape layer, a filled layer that contains
your vector path.

4+ Paths: Creates a path only; no layer is created.

4+ Fill Pixels: Creates pixels directly on the image. No editable path or
layer is created. This option may not be useful to new users, but some
existing users prefer to use this method because it’s the only way to
access the Line tool from previous versions.
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Figure 5-1:
The Vector
Shape tools.

Figure 5-2:
A custom
wave shape
integrated
with an
image in
Photoshop.

Shape layers can be very useful when the goal of your design is to seam-
lessly integrate vector shapes and pixel data. A shape layer can contain
vector shapes that you can then modify with the same features of any other
layer. You can adjust the opacity of the shape layer, change the blending
mode, and even apply layer effects to add drop shadows and dimension.
Find out how to do this in Chapter 9 of this minibook.

Create a shape layer using any of these methods:

4+ Create a shape with the Pen tool. With the Pen tool, you can create
interesting custom shapes and even store them for future use. We show
you how in the following section.

4+ Use one of the Vector Shape tools shown in Figure 5-1. Vector shapes
are premade shapes (you can even create your own!) that you can create
by dragging on your image area with a shape tool.

4+ Import a shape from Illustrator. Choose Filem>Place to import an
lllustrator file as a shape layer or path into Photoshop.
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Creating and using a custom shape

Perhaps you like the wave kind of shape (see Figure 5-2) that has been crop-
ping up in design pieces all over the place.
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is active.
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Copy and paste shapes right from Illustrator CS3 to Photoshop CS3. Simply
select your shape in Adobe Illustrator and choose Edit=>Copy, then switch to
the Photoshop application, and with a document open, choose Edit=>Paste.

You can create a wavy shape like that, too. With an image or blank document
open, just follow these steps:

1.

Click and drag with the Pen tool to create a wavy shape.

Don’t worry about the size of the shape. The shape is vector, so you can
scale it up or down to whatever size you need without worrying about
making jagged edges. Just make sure that you close the shape (return
back to the original point with the end point).

As you create the shape, it fills in with your foreground color. Try to ignore
it if you can; the next section shows you how to change the fill color, and
Chapter 8 of this minibook covers how to change it to a transparent fill.

. With the shape still selected, choose Edit->Define Custom Shape, name

the shape, and click OK.

After you have saved your custom shape, you can recreate it at any
time. If you don’t like the shape, choose Windows=> Layers to open the
Layers palette and then drag the shape layer you just created to the
Trash icon in the lower-right corner of the palette. If you’d like to
experiment with your custom shape now, continue with these steps.

. Click and hold on the Rectangle tool to access the other hidden vector

tools; select the last tool, the Custom Shape Tool.

When the Custom Shape tool is selected, a Shape drop-down menu
appears on the Options bar at the top of the screen, as shown in Figure 5-3.

You have lots of custom shapes to choose from, including the one you’'ve
just created. If you just saved a shape, yours is in the last square; you
have to scroll down to select it.
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Figure 5-4:
Experiment
with blend-
ing modes
and opacity
changes
on shape
layers.

4. Select your custom shape; click and drag in the image area to create
your shape.

You can make it any size that you want.

5. To change the shape’s size, choose Edit->Free Transform Path, press
Ctrl+T (38+T on a Mac), or grab a bounding box handle and drag.

Shift+drag a corner handle to keep the shape proportional as you resize it.

Because a shape is created on its own layer, you can experiment with
different levels of transparency and blending modes in the Layers palette.
Figure 5-4 shows shapes that are partially transparent. Discover lots of other
features you can use with shape layers in Chapter 9 of this minibook.
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Changing the color of the shape

When you create a shape with a shape tool, the shape takes the color of your
present foreground color. To change the color of an existing shape, open the
Layers palette by choosing Windowr>Layers; notice that the Vector Shape
tool creates a new layer for every shape you make. Creating a new layer is a
benefit when it comes to creating special effects because the shape layer is
independent of the rest of your image. (Read more about using layers in
Chapter 9 of this minibook.)

To change a shape’s color, double-click the color thumbnail, on the left in the
shape layer. The Color Picker appears, as shown in Figure 5-5. To select a
new color, drag the Hue slider up or down or click in the large color pane

to select a color with the saturation and lightness that you want to use.

Click OK when you’re done.
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Editing a shape
k Like Adobe Illustrator, Photoshop provides both a Path Selection tool and
[} a Direct Selection tool. The Direct Selection tool is hidden under the Path
Selection tool. To move an entire shape on a layer, choose the Path Selection
tool and drag the shape.
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To edit the shape, deselect the shape (while using the Path Selection or
Direct Selection tool, click outside the shape). Then select the Direct
Selection tool. With the Direct Selection tool, click individual anchor points
and handles to edit and fine-tune the shape, as shown in Figure 5-6.

Figure 5-6:
Edit individ-
ual anchor
points with
the Direct
Selection
tool.

Removing a shape layer

Because the Pen tool now has multiple options, you may find yourself
unexpectedly creating a shape layer. Delete a shape layer by dragging the
layer thumbnail to the Trash icon in the lower-right corner of the Layers
palette.
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Figure 5-7:
Save your
path by
dragging the
shape path
to the Create
New Path
icon before
throwing
away the
shape layer.

If you want to keep your path but throw away the shape layer, choose
Window>Paths. Then drag the shape vector mask to the New Path icon, as
shown in Figure 5-7, which creates a saved path. Now you can throw away
the shape layer.

Using a Path as a Selection

You can use the Pen tool to create precise selections that would be difficult
to create with other selection methods. The Pen tool produces clean edges
that print well and can be edited using the Direct Selection tool. Before
using the Pen tool, make sure that you click the Paths button on the
Options bar.

To use a path as a selection (which is extremely helpful when you’re trying
to make a precise selection), follow these steps:

1. Open any file, or create a new blank file.

2. Using the Pen tool (make sure that the Paths button is selected on the
Options bar or else you will create a Shape layer!), click to place
anchor points; drag to create a curved path around the image area
that you want selected; and completely close the path by returning to
the start point (see Figure 5-8).

Use the techniques that we discuss in Book IV, Chapter 4 to perform this
step. A circle will appear before you click to close the path.

3. Choose Window>Paths.
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In the Paths palette, you can create new and activate existing paths, §_ S
apply a stroke, or turn paths into selections by clicking the icons at the S3
bottom of the palette (see Figure 5-9). o=
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4. Click the Load Path As Selection icon.
The path is converted into a selection.
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Use this quick and easy method for turning an existing path into a selection:
Ctrl+click (88+click on a Mac) the path thumbnail in the Paths palette.
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Clipping Paths

If you want to create a beautiful silhouette that transfers well to other appli-
cations for text wrapping (see Figure 5-10), create a clipping path.
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Creating a clipping path is easy when you have a good path! Just follow
these steps:

1. Use the Pen tool to create a path around the image area that is to be
the silhouette.

2. In the Paths palette, choose Save Path from the palette menu (click the
triangle in the upper-right corner of the palette to access this menu),
as shown in Figure 5-11, and then name the path.

(If Save Path isn’t an option, your path has already been saved; skip to
Step 3.)

3. From the same palette menu, choose Clipping Path.
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4. In the Clipping Paths dialog box, choose your path from the drop-

down list if it’s not already selected; click OK.

Leave the Flatness Device Pixels text field blank unless you have a need
to change it. The flatness value determines how many device pixels are
used to create your silhouette. The higher the amount, the less points
are created, thereby allowing for faster processing time. This speed
does come at a cost, though; set the flatness value too high, and you
may see (you’d have to look really close) straight edges instead of
curved edges.

. Choose File->Save As and in the Format drop-down list, select Photoshop

EPS; in the EPS Options dialog box that appears, accept the defaults
and click OK.

If you get PostScript errors when printing, choose Clipping Path from the
palette menu and up the value to 2 pixels in the Flatness Device Pixels
text field. Keep returning to this text field and upping the value until

the file prints, or give up and try printing your document with another
printer.

If you're placing this file in other Adobe applications, such as InDesign,
you don’t need to save the file as EPS; you can leave it as a Photoshop
(.psAd) file.
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Chapter 6: Thinking about
Resolution Basics

In This Chapter

+ Understanding resolution basics
v~ Adjusting file size
1~ Applying the Unsharp Mask filter to an image

S)mething as important as getting the right resolution for your images
deserves its own chapter, but fortunately, the topic isn’t all that complex.
In this chapter, you discover the necessary resolution for various uses of
Photoshop imagery (from printing a high-resolution graphic to e-mailing a
picture of your kids to Mom), how to properly increase the resolution, and
how to adjust image size.

Having the proper resolution is important to the final outcome of your
image, especially if you plan to print that image. Combine the information
here with using the correction tools that we show you in the next chapter,
and you should be ready to roll with great imagery.

Creating Images for Print

\\s

To see and make changes to the present size and resolution of an image
in Photoshop, choose Image=>Image Size. The Image Size dialog box
appears.

The Width and Height text fields in the Pixel Dimensions area of the Image
Size dialog box are used for on-screen resizing, such as for the Web and
e-mail. The Width and Height text fields in the Document Size area show the
size at which the image will print. The Resolution text field determines the
resolution of the printed image; a higher value means a smaller, more finely
detailed printed image.
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Before you decide upon a resolution, you should understand what some of
the resolution jargon means:

4+ dpi (dots per inch): The resolution of an image when printed.

4+ Ipi (lines per inch): The varying dot pattern that printers and presses
use to create images (see Figure 6-1). This dot pattern is referred to as
the Ipi, even though it represents rows of dots. The higher the Ipi, the
finer the detail, and the less of the dot pattern or line screen you see.

4+ Dot gain: The spread of ink as it’s applied to paper. Certain types of
paper will wick a dot of ink farther than others. For example, newsprint
has a high dot gain and typically prints at 85 Ipi; a coated stock paper
has a lower dot gain and can be printed at 133-150 Ipi and even higher.

Human eyes typically can’t detect a dot pattern in a printed image at 133 dpi
or higher.

Figure 6-1:
The dot
pattern used
to print
images is
referred to
as Ipi (lines
perinch).

<P Deciding the resolution or dpi of an image requires backward planning. If you
want to create the best possible image, you should know where it will print
before deciding the resolution. Communicate with your printer service if the
image is going to press. If you're sending your image to a high-speed copier,
you can estimate that it will handle 100 Ipi; a desktop printer will handle 85
Ipi to 100 Ipi.

The resolution formula

When creating an image for print, keep this formula in mind:

2 x Ipi = dpi (dots per inch)
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This formula means that if your image is going to press using 150 Ipi, have
your image at 300 dpi. To save space, many designers use 1.5 x Ipi and get
pretty much the same results; you can decide which works best for you.

Changing the resolution

Using the Image Size dialog box is only one way that you can control the
resolution in Photoshop. Even though you can increase the resolution, do so
sparingly and avoid it if you can. The exception is when you have an image
that is large in dimension size but low in resolution, like those that you typi-
cally get from a digital camera. You may have a top-of-the-line digital camera
that produces 72 dpi images, but at that resolution, the pictures are 28 x 21
inches (or larger)!

To increase the resolution of an image without sacrificing quality:

1. Choose Image->Image Size.

The Image Size dialog box appears, as shown in Figure 6-3.
2. Deselect the Resample Image check box.

This way, Photoshop doesn’t add additional pixels.
3. Enter the desired resolution in the Resolution text field.

Photoshop keeps the pixel size (the size of the image on screen) the
same, but the document size (the size of the image when printed)
decreases when you enter a higher resolution.

4. If the image isn’t the size that you need it to be, select the Resample
Image check box and type the size in the Width and Height text fields
in the Document Size section.

Note that it’s best to reduce the size of a bitmap image, such as a digital
photo, rather than increase it.

You can also deselect the Resample Image check box and essentially
play a game of give and take to see what the resolution will be when you
enter the size you want your image printed at in the Width and Height
text fields in the Document Size area.

Images can typically be scaled from 50 to 120 percent before looking
jagged (to scale by a percentage, select Percent from the drop-down lists
beside the Width and Height text fields). Keep this in mind when placing
and resizing your images in a page layout application, such as InDesign.

5. Click OK when you’re finished; double-click the Zoom tool in the tool-
box to see the image at actual size on-screen.
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To increase the resolution without changing the image size, follow these
steps. (This situation isn’t perfect because pixels that don’t presently exist
are created by Photoshop and may not be totally accurate. Photoshop tries
to give you the best image, but you may have some loss of detail.)

1. Choose Imager->Image Size.

2. When the Image Size dialog box appears, make sure that the
Resample Image check box is selected.

Note that Bicubic is selected in the method drop-down list. This method
is the best, but slowest, way to reinterpret pixels when you resize an
image. Using this method, Photoshop essentially looks at all the pixels
and takes a good guess as to how the newly created pixels should look,
based upon surrounding pixels.

3. Enter the resolution that you need in the Resolution text field, click OK,
and then double-click the Zoom tool to see the image at actual size.

Determining the Resolution for Web Images

Did you ever have somebody e-mail you an image, and, after spending

10 minutes downloading it, you discover that the image is so huge that all
you can see on the monitor is your nephew’s left eye? Many people are
under the misconception that if an image is 72 dpi, it’s ready for the Web.
Actually, pixel dimension is all that matters for Web viewing of images; this
section helps you make sense of this.

Most people view Web pages in their browser windows in an area of about
640 x 480 pixels. You can use this figure as a basis for any images you create
for the Web, whether the viewer is using a 14-inch or a 21-inch monitor.
(Remember, those people who have large monitors set to high screen resolu-
tions don’t necessarily want a Web page taking up the whole screen!) If you're
creating images for a Web page or to attach to an e-mail message, you may
want to pick a standard size to design by, such as 600 x 400 pixels at 72 dpi.

To use the Image Size dialog box to determine the resolution and size for on-
screen images, follow these steps:
1. Have an image open and choose Image->Image Size.
The Image Size dialog box appears.

2. To make the image take up half the width of a typical browser
window, type 300 (half of 600) in the top Width text field.

If a little chain link is visible to the right, the Constrain Proportions
check box is selected, and Photoshop automatically determines the
height from the width that you entered.
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3. Click OK and double-click the Zoom tool to see the image at actual
size on-screen.

That’s it! It doesn’t matter whether your image is 3,000 or 30 pixels wide,
as long as you enter the correct dimensions in the Pixel Dimension area,
the image works beautifully.

Applying the Unsharp Mask Filter to an Image

MBER
x‘&
&

When you resample an image in Photoshop, it can become blurry. A good
practice is to apply the Unsharp Mask filter. This feature sharpens the

image based upon levels of contrast, while keeping the areas that don’t have
contrasting pixels smooth. You do have to set up this feature correctly to get
good results. Here is the down-and-dirty method of using the Unsharp Mask
filter:

1. Choose Viewr>Actual Pixels or double-click the Zoom tool.

When you’re using a filter, you want to view your image at actual size to
best see the effect.

2. Choose Filter~>Sharpen->Unsharp Mask.
In the Unsharp Mask dialog box that appears, set these three options:

e Amount: The Amount value ranges from 0 to 500. The amount that
you choose has a lot to do with the subject matter. Sharpening a car
or appliance at 300 to 400 is fine, but do this to the CEO’s 75-year-old
wife, and you may suffer an untimely death because every wrinkle,
mole, or hair will magically become more defined. If you're not sure
what to use, start with 150 and play around until you find an Amount
value that looks good.

e Radius: The Unsharp Mask filter creates a halo around the areas that
have enough contrast to be considered an edge. Typically, leaving
the amount between 1 to 2 is fine for print, but if you're creating a
billboard or poster, increase the size.

e Threshold: This option is the most important one in the Unsharp
Mask dialog box. The Threshold setting is what determines what
should be sharpened. If left at zero, you’ll see noise throughout the
image, much like the grain that you see in high-speed film. Bring it up
to 10, and this triggers the Unsharp Mask filter to apply only the
sharpening when the pixels are ten shades or more away from each
other. The amount of tolerance ranges from 1 to 255. Apply too
much, and no sharpening appears; apply too little, and the image
becomes grainy. A good number to start with is 10.
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To compare the original state of the image with the preview of the
Unsharp Mask filter’s effect in the preview pane of the Unsharp Mask
dialog box, click and hold on the image in the Preview pane; this shows
the original state of the image. When you release the mouse button, the
unsharp mask is previewed again.

3. When you’ve made your choice, click OK.

The image appears to have more detail.

Once in a while, stray colored pixels may appear after you apply the
Unsharp Mask filter. Get in the habit of choosing Edit=>Fade Unsharp Mask
immediately after applying the Unsharp Mask filter. In the Fade dialog box,
select the Luminosity blend mode from the Mode drop-down list and then
click OK. This step applies the Unsharp Mask filter to the grays in the image
only, thereby eliminating sharpening of colored pixels.

New in Photoshop CS3 you can use smart filters. Smart filters allow you to
undo, all or some of any filter, including sharpening filters, that you apply to
a layer. Find out how by reading Chapter 8 in this minibook.



Chapter 7: Creating a Good Image

In This Chapter

+ Understanding the Histogram
1 Getting ready to correct an image
+~ Making a good tone curve

v+ Discovering adjustment layers

Wth all the incredible things you can do in Photoshop, you can easily
forget the basics. Yes, you can create incredible compositions with

special effects, but if the people look greenish, it detracts from the image.
Get in the habit of building good clean images before heading into the artsy
filters and fun things. Color correction isn’t complicated, and if done properly,
it will produce magical results in your images. In this chapter, you discover
how to use the values you read in the Info palette and use the Curves dialog
box to produce quality image corrections.

Reading a Histogram

Before making adjustments, look at the image’s histogram, which displays an
image’s tonal values, to evaluate whether the image has sufficient detail to
produce a high-quality image. In Photoshop CS3, choose Windowr>Histogram
to display the Histogram palette.

§‘&N\BER The greater the range of values in the histogram, the greater the detail.

Y Poor images without much information can be difficult, if not impossible,
to correct. The Histogram palette also displays the overall distribution of
shadows, midtones, and highlights to help you determine which tonal cor-
rections are needed.

Figure 7-1 shows a good full histogram that indicates a smooth transition
from one shade to another in the image. Figure 7-2 shows that when a his-
togram is spread out and has gaps in it, the image is jumping too quickly
from one shade to another, producing a posterized effect. Posterization is an
effect that reduces tonal values to a limited amount, creating a more defined
range of values from one shade to another. Great if you want it, yucky if you
want a smooth tonal change from one shadow to another.

So how do you get a good histogram? If you're scanning, make sure that
your scanner is set for the maximum amount of colors. Scanning at 16
shades of gray gives you 16 lines in your histogram . . . not good!
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Figure 7-1:
A histogram
shows lots
of informa-
tion, and
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Figure 7-2:
A histogram
showing
little infor-
mation; the
enlarged
image
shows the
lack of
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<P If you have a bad histogram, we recommend that you rescan or reshoot the
image. If you have a good histogram to start with, keep the histogram good
by not messing around with multiple tone correction tools. Most professionals
use the Curves feature . . . and that’s it. Curves (choose Image~>Adjustments=>
Curves), if used properly, do all the adjusting of levels (brightness and con-
trast) and color balance, all in one step. You can read more about curves in
the section “Creating a Good Tone Curve,” later in this chapter.

Figure 7-3 shows what happens to a perfectly good histogram when someone
gets a little too zealous and uses the entire plethora of color correction con-
trols in Photoshop. Just because the controls are there doesn’t mean that
you have to use them.
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Figure 7-3:
Tonal infor-
mation is Ferore | g
broken up
as more and
more adjust-
ments SO e
are made
to an image.
Vg\\\\NG!
s If you see a Warning icon appear while you’re making adjustments, double-
click anywhere on the histogram to refresh the display.
Breaking into key types
Don’t panic if your histogram is smashed all the way to the left or right. The
bars of the histogram represent tonal values. You can break down the types
of images, based upon their values, into three key types:
4+ High key: A very light-colored image, such as the image shown in
Figure 7-4. Information is pushed toward the right in the histogram.
Color correction has to be handled a little differently for these images
to keep the light appearance to them.
4+ Low key: A very dark image, such as the image shown in Figure 7-5.
Information is pushed to the left in the histogram. This type of image is
difficult to scan on low-end scanners because the dark areas tend to
blend together with little definition.
Figure 7-4:
A high key
image is a

lightimage.
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Figure 7-5:
Alow key
image is a
dark image.

4+ Mid key: A typical image with a full range of shades would be consid-
ered mid key, such as the image shown in Figure 7-6. These images are
the most common and easiest to work with. In this chapter, we deal with
images that are considered mid key.

Figure 7-6:
A typical
image with
afull range
of values is
a mid key
image.

Setting up the correction

To produce the best possible image, try to avoid correcting in CMYK mode.
If your images are typically in RGB or LAB mode, keep them in that mode
throughout the process. Convert them to CMYK only when you’re finished
manipulating the image.
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Don’t forget! Press Ctrl+Y (38+Y on a Mac) to toggle on and off the CMYK pre-
view so that you can see what your image will look like in CMYK mode with-
out converting it!

Set up these items before starting any color correction:

1. Select the Eyedropper tool; on the Options bar, change the sample size

from Point Sample to 3 By 3 Average in the Sample Size drop-down list.

The Eyedropper tool is hidden in the Count Tool if you have Photoshop
Extended.

This setting gives you more accurate readings.

. If the Histogram palette isn’t already visible, choose

Window= Histogram.

. If the Info palette isn’t already visible, choose Window=>Info to show

the Info palette so that you can check values.

. Make sure that your color settings are correct.

If you're not sure how to check or set up color settings, see Chapter 3 of
this minibook.

Creating a Good Tone Curve

Figure 7-7:
The image
is murky
before
defining a
highlight

and shadow. |

A tone curve represents the density of an image. To get the best image, you
must first find the highlight and shadow points in the image. An image cre-
ated in less-than-perfect lighting conditions may be washed out or have odd
color casts. See Figure 7-7 for an example of an image with no set highlight
and shadow. Check out Figure 7-8 to see an image that went through the
process of setting a highlight and shadow.
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Figure 7-8:
The tonal
values are
opened up
after high-
light and
shadow
have
been set.

To make the process of creating a good tone curve more manageable, we've
broken the process into four parts:

4+ Finding the highlight and shadow

4+ Setting the highlight and shadow

4 Adjusting the midtone

4+ Finding a neutral

Even though each part has its own set of steps, you must go through all four
parts to accomplish the task of creating a good tone curve (unless you're
working with grayscale images, in which case you can skip the neutral part).
In this example, an Adjustment layer is used for the curve adjustments.

The benefit is that you can turn off the visibility of the adjustment at a later
point or double-click the adjustment layer thumbnail to make ongoing edits
without destroying your image.

Finding and setting the highlight and shadow

In the noncomputer world, you’d spend a fair amount of time trying to locate
the lightest and darkest part of an image. Fortunately, you can cheat in
Photoshop by using some of the new features in the Curves palette.

Here’s how you access the palette:

1. With an image worthy of adjustment — meaning one that isn’t
perfect already — choose Windowr>Layer (if the Layers palette
isn’t already open).



Figure 7-9:
You can
access the
new and
improved
Curves
palette by
using the
Create
New Fill Or
Adjustment
Layer button.
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2. Click and hold on the Create New Fill Or Adjustment Layer button at
the bottom of the Layers palette and select Curves.

The Curves palette, shown in Figure 7-9, appears.

Notice the grayed-out histogram behind the image Curve window. The his-
togram aids you in determining where you need to adjust the image’s curve.

If you're correcting in RGB (as you should be!), the tone curve may be oppo-
site of what you think it should be. Instead of light to dark displaying as you’d
expect, RGB displays dark to light. Now think about it: RGB is generated with
light, and no RGB means that there is no light and you therefore have black.
Turn all RGB on full force, and you create white. Try pointing three filtered
lights, one red, one green, and one blue. The three lights pointed in one
direction really do create white.

If working with RGB confuses you, simply click on the Pigment/Ink% check
box, shown in Figure 7-10. The sample in this example uses the curve based
upon pigment.
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Figure 7-10:
You can
view the
curve using
information
based upon
light or
pigment.

Note that in the new Curves palette, you see a Preset drop-down menu that
offers quick fixes using standard curves for certain corrections. These set-
tings are great for quick fixes, but for the best image, you should create a

custom curve.

The first thing you need to do in the Curves palette is determine the lightest
and darkest part of the image, which is referred to as locating the highlight

and shadow:

1. To help you see where the highlight and shadow are in the image,
check the Show Clipping check box.

Curves

Preset: | MOne w| =
hannel: | HisE R
o
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Input;
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show: [l Chamel Cnealas [ Rading
[¥]Histogram [¥lintersection Line

Ok

cancel

[ e |

Options...

[+ Preview

2. Grab the right modify curve slider, shown in Figure 7-11, and slide it
until you start to see white appear.

Coincidently, the white should appear where you see your histogram
(grayed out in the curves palette) begin.
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Adjusting the midtone

You may have heard the statement, “Open up the midtones.” This phrase
essentially means that you're lightening the midtonal values of an image.

In many cases, opening up the midtones is necessary to add contrast and
bring out detail in your image.

To adjust the midtones, follow these steps:

1. In the Curves dialog box, click the middle of the curve ramp to create
an anchor point; drag up slightly.

The image lightens. (If you're in Pigment/Ink % mode, drag down to
lighten the image.) Don’t move a dramatic amount and be very careful
to observe what is happening in your Histogram palette (which you
should always have open when making color corrections).

Because you set highlight and shadow (see preceding section) and are
now making a midtone correction, you see the bars in the histogram
spreading out. The spreading of the information is necessary to a point,
and it’s the reason why you don’t click OK until all steps have been taken
in the Curves dialog box.

2. To adjust the three-quarter tones (the shades around 75 percent), click
halfway between the bottom of the curve ramp and the midpoint to
set an anchor point.

Use the grid in the Curves dialog box to find it easily. (In Pigment/Ink %,
the three-quarter point is in the upper section of the color ramp.) Adjust
the three-quarter area of the tone curve up or down slightly to create
contrast in the image. Again, keep an eye on your histogram!

3. If you’re working on a grayscale image, your tonal correction is done,
and you can click OK.

If you're working on a color image, don’t click OK; keep the Curves
dialog box open for the final step, which is outlined in the next section.

Finding a neutral

The last step in creating a tone curve only applies if you're working on a
color image. The key to understanding color is knowing that equal amounts
of color create gray. By positioning the mouse cursor over gray areas in an
image and reading the values in the Info palette, you can determine what
colors you need to adjust.

1. With your Curves dialog box open, position it so that you can see the
Info palette.

If the Info palette is buried under another palette or a dialog box, choose
Window=Info to bring it to the front.
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2. Position your cursor over your image and, in the Info palette, look for
the RGB values in the upper-left section.

You see color values and then forward slashes and more color values.
The numbers before the slash indicate the values in the image before
you opened the Curves dialog box; the numbers after the slash show the
values now that you have made changes in the Curves dialog box. Pay
attention to the values after the slashes.

3. Position the cursor over something gray in your image.

It can be a shadow on a white shirt, a counter top, a road — anything

that is a shade of gray. Look at the Info palette. If your image is perfectly

color balanced, the RGB values following the forward slashes should all Book Il
be the same. Chapter 7

4. If your color isn’t balanced, click the Set Gray Point Eyedropper in the
Curves dialog box and click the neutral or gray area of the image.

The middle eyedropper (Set Gray Point) is a handy way of bringing the
location that you click on closer together in RGB values, thereby balanc-
ing the colors.
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5. Now you can click OK; if you're asked whether you want to save your
color target values, click Yes.

Curves can be as complex or simple as you make them. As you gain more
confidence using them, you can check neutrals throughout an image to
ensure that all unwanted color casts are eliminated. You can even individu-
ally adjust each color’s curve by selecting them from the Channel drop-down
list in the Curves dialog box.

When you’re finished with color correction, using the Unsharp Mask filter on
your image is a good idea. Chapter 5 of this minibook shows you how to use
this filter.

Using an Adjustment Layer

You may go through a curve adjustment only to discover that some areas of
the image are still too dark or too light. If this is the case, you're better off
using an adjustment layer, which is a layer that adjusts a selected area of
your image, based upon a correction applied on the layer. By using an adjust-
ment layer, you can turn off the correction or change it over and over again
with no degradation to the quality of the image. You can apply an adjustment
layer by following these steps:

1. Select the area of the image that needs adjustments.

See Chapter 4 of this minibook if you need a refresher on how to make
selections in Photoshop.
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Figure 7-13:
You can
paint on the
Adjustment
Layer mask
to apply
correction
to different
parts of the
image.

2. Choose Selectz>Modify=>Feather to soften the selection.

The Feather dialog box appears.

3. Enter a value into the Feather dialog box.

If you're not sure what value will work best, enter 15 in the Feather
Radius text field and click OK.

4. If the Layers palette isn’t visible, choose Windowst>oLayers; click and

hold on the Create New Fill Or Adjustment Layer icon and select
Curves from the menu that appears.

5. In the Curves dialog box, click the middle of the curve ramp to create

an anchor point; drag up or down to lighten or darken your selected
area and click OK.

Notice in the Layers palette (see Figure 7-13) that your adjustment layer,
named Curves 2, has a mask to the right of it. The selected area is white;
unselected areas are black.
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6. With your adjustment layer selected in the Layers palette, use the

Brush tool to paint white to apply the correction to other areas of the
image; paint with black to exclude areas from the correction.

You can even change the opacity using the Brush tool Options bar at the
top to apply only some of the correction!
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Testing a Printer

If you go through all the work of making color corrections to your images
and you still get printed images that look hot pink, it may not be you! Test
your printer by following these steps:

1. Create a neutral gray out of equal RGB values (double-click the Fill
Color swatch in the toolbar).

2. Create a shape, using your neutral gray as the fill color.
For example, you can use the Ellipse tool to create a circle or oval.

3. Choose File=>Print and click OK to print the image from your color

printer.

If you're seeing heavy color casts, you need to adjust your printer; cleaning
or replacing the ink cartridge may fix the problem. Check out Chapter 10 of
this minibook for more about printing your Photoshop files.
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Chapter 8: Working with Painting
and Retouching Tools

In This Chapter

v Using the Swatches palette
+* Getting to know foreground and background colors
v Introducing painting and retouching tools

v+ Discovering blending modes

Tlis chapter shows you how to use the painting and retouching tools in
Photoshop. If you're unsure about how good the painting you're about
to do will look, create a new layer and paint on that. (See Chapter 9 of this
minibook to find out how to create and use layers.) That way, you can delete
the layer by dragging it to the Trash icon (at the bottom of the Layers palette)
if you decide that you don’t like what you have done. Don’t forget to make the
Eraser tool your friend! You can also repair painting or retouching mistakes
by Alt+dragging (Option+dragging on a Mac) with the Eraser tool selected to
erase the last version saved or present history state.

Have fun and be creative! Because Photoshop is pixel-based, you can create
incredible imagery with the painting tools. Smooth gradations from one
color to the next, integrated with blending modes and transparency, can
lead from super-artsy to super-realistic effects. In this chapter, you discover
painting fundamentals, and we show you how to use retouching tools to
eliminate wrinkles, blemishes, and scratches. Don’t you wish you could do
that in real life?

Using the Swatches Palette

Use the Swatches palette to store and retrieve frequently used colors. The
Swatches palette allows you to quickly select colors.

The Swatches palette also gives you access to many other color options. By
using the palette menu, you can select from a multitude of different color
schemes, such as Pantone or Web-safe color sets. These color systems are
converted to whatever color mode in which you’re working.
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Choosing Foreground and Background Colors

To sample and then store a color for later use, follow these steps:
1. To sample a color from an image, select the Eyedropper tool in the
toolbox and click a color on the image.

Alternatively, you can use any of the paint tools (the Brush tool for
example) and Alt+click (Option+click on a Mac).

The color you click becomes the foreground color.
2. Store the color in the Swatches palette by clicking the New Swatch
button at the bottom of the Swatches palette.

Anytime you want to use that color again, simply click it in the Swatches
palette to make it the foreground color.

Choosing Foreground and Background Colors

At the bottom of the toolbox reside the foreground and background color
swatches. The foreground color is the color that you apply when using any of
the painting tools. The background color is the color that you see if you erase
or delete pixels from the image.

Choose a foreground or background color by clicking the swatch, which
opens the Color Picker dialog box. To use the color picker, you can either
enter values in the text fields on the right, or you can slide the hue slider.

Pick the hue (color) that you want to start with and then click in the color
pane to the left to choose the amount of light and saturation (grayness or
brightness) you want in the color. Select the Only Web Colors check box to
choose one of the 216 colors in the Web safe color palette. The hexadecimal
value used in HTML documents appears in the text field in the lower right of
the color picker.

New in Photoshop CS3, you can click the Add To Swatches button right in

the Color Picker to save a color for future use.

The Painting and Retouching Tools

Grouped together in the toolbox are the tools used for painting and retouch-
ing. The arrow in the lower right of a tool indicates that the tool has more
related hidden tools; simply click and hold on the tool to see additional



Figure 8-1:
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painting and retouching tools. In this chapter, we show you how the Spot
Healing Brush, Healing Brush, Patch, Red Eye, Brush, Clone Stamp, History
Brush, Eraser, and Gradient tools work. You also discover ways to fill shapes
with colors and patterns.

Changing the brush

As you click to select different painting tools, note the Brush menu, second
from the left, on the Options bar, as shown in Figure 8-1. Click the arrow to

open the Brush Picker. You can use the Master Diameter slider to make the
brush size larger or smaller, as well as change the hardness of the brush.
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The hardness refers to how “fuzzy” the edges are; a softer brush is more
feathered and soft around the edges, while a harder edge would be more def-
inite with a harder edge (see Figure 8-2).
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Figure 8-2:
A soft edge
(left) as
compared
to a hard
edge (right)
brush stroke.

W

Don'’t feel like accessing the Brushes palette every time you want to make a
change? Press the right bracket ] several times to make your brush diameter
larger or press the left bracket [ to make the brush diameter smaller. Press
Shift+ ] to make the brush harder or Shift+[ to make the brush softer.

Choose Window=>Brushes to see a list of Brush presets, plus many more
brush options that you can use to create custom brushes. You can also
choose other brush libraries using the palette menu (click the triangle in the
upper-right corner of the Brushes Preset Picker). When you select an addi-
tional library, a dialog box appears, asking whether you want to replace the
current brushes with the brushes in the selected library. Click the Append
button to keep existing brushes and add the library to the list, or click OK to
replace the existing brushes.

Access the Brushes Preset Picker as you're painting by right-clicking (Ctrl+
clicking on a Mac) anywhere in the image area. Double-click a brush to select
it; press Esc to hide the Brushes palette.

The Spot Healing Brush Tool

#

The Spot Healing Brush tool is destined to become everyone’s favorite.
Who wouldn’t love a tool that can remove years from your face and any
blemishes, too?

The Spot Healing Brush tool quickly removes blemishes and other imperfec-
tions in your images. Click a blemish and watch it paint matching texture,
lighting, transparency, and shading to the pixels being healed. The Spot
Healing Brush doesn’t require you to specify a sample spot. The Spot
Healing Brush automatically samples from around the retouched area.
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The Healing Brush Tool

You can use the Healing Brush tool for repairs, such as eliminating scratches
and dust from scanned images. The difference between the Spot Healing
Brush tool (see preceding section) and the Healing Brush tool is that a
sample spot is required before applying the Healing Brush. Follow these
steps to use this tool:

1.

2.

Select the Healing Brush tool in the toolbox (it’s a hidden tool of the
Spot Healing Brush tool).

Find an area in the image that looks good and then Alt+click
(Option+click on a Mac) to sample that area.

For example, if you're going to eliminate wrinkles on a face, choose a
wrinkle-free area of skin near the wrinkle. (Try to keep it relatively close
in skin tone.)

. Position the mouse cursor over the area to be repaired and start

painting.

The Healing Brush tool goes into action, blending and softening to
create a realistic repair of the area.

. Repeat Steps 2 and 3 as necessary to repair the blemish, wrinkles, or

scratches.

The Patch Tool

.. Hidden behind the Healing Brush tool in the toolbox is the Patch tool. Use
{f‘ the Patch tool to repair larger areas, such as a big scratch or a large area of
skin, by following these steps:

1.

Click and hold the Healing Brush tool to select the Patch tool; on the
Options bar, select the Destination radio button.

You can either patch the source area or the destination. The preference
is really up to you. We recommend taking a good source and dragging it
over the location of the image that needs to be repaired.

. With the Patch tool still selected, drag to create a marquee around the

source that you want to use as the patch.

The source would be an unscratched or wrinkle-free area.

. After you create the marquee, drag the selected source area to the

destination that is to be repaired.

The Patch tool clones the selected source area as you drag it to the des-
tination (the scratched area); when you release the mouse button, the
tool blends in the source selection and repairs the scratched area!
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Make the patch look even better by choosing Edit=>Fade Patch Selection
immediately after you apply the patch. Adjust the opacity until there are no
tell-tale signs that you made a change.

The Red Eye Tool

‘5

E ]

So you finally got the group together and shot the perfect image, but red eye
took over! Red eye is caused by a reflection of the camera’s flash in the retina
of your photo’s subject(s). You see it more often when taking pictures in a
dark room because the subject’s iris is wide open. If you can, use your
camera’s red-eye reduction feature. Or, better yet, use a separate flash unit
that you can mount on the camera farther away from the camera’s lens.

You will love the fact that red eye is extremely easy to fix in Photoshop CS3.
Just follow these steps:
1. Select the Red Eye tool (hidden behind the Spot Healing Brush tool).
2. Click a red eye.

You should see a change immediately, but if you need to make adjust-
ments to the size or the darkness amount, you can change options in the
tool options bar at the top of your work area.

The Brush Tool

rd

Painting with the Brush tool in Photoshop is much like painting in the real
world. What you should know are all the nifty keyboard commands that you
can use to be much more productive when painting. These shortcuts are really
great, so make sure that you try them as you read about them. By the way,
the keyboard commands you see in Table 8-1 work on all the painting tools.

Table 8-1 Brush Keyboard Shortcuts
Function Windows Mac
Choose the Brush tool B B

Increase brush size | ]

Decrease brush size [ [

Harden brush Shift+] Shift+]

Soften brush Shift+[ Shift+[

Sample color Alt+click Option+click
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Function Windows Mac
Switch foreground and background color X X
Change opacity by a given percentage Type a number Type a number

between 1 and 100 between1 and 100

If you're really into the brushes, you have lots of great options available in
the Brushes palette (choose Window=>Brushes to open the palette).

You have several choices of attributes, most of which have dynamic controls
in the menu options that allow you to vary brush characteristics by tilting or
applying more pressure to a stylus pen (if you're using a pressure-sensitive
drawing tablet), among other things.

Note: A warning sign indicates that you don’t have the appropriate device
attached to use the selected feature, such as a pressure-sensitive drawing
tablet.

The following options are available in the Brushes palette:

4+ Brush Tip Shape: Select from these standard controls for determining
brush dimensions and spacing.

<+

Shape Dynamics: Change the size of the brush as you paint.

<+

Scattering: Scatter the brush strokes and control brush tip count.
4+ Texture: Choose a texture from pre-existing patterns or your own.

Create a pattern by selecting an image area with the Rectangular
Marquee tool. Choose Edit=>Define Pattern, name the pattern, and then
click OK. The pattern is now available in the Brush palettes Texture
choices.

+

Dual Brush: Use two brushes at the same time.

4+ Color Dynamics: Change the color as you paint.

4 Other Dynamics: Change the opacity and flow.
If you've been using Photoshop for several versions, you may notice that
with Photoshop CS3, the attributes at the bottom of the Brushes palette
aren’t necessarily new, but have been moved from their old positions on the
Options bar. Here is what these attributes do:

4+ Noise: Adds a grainy texture to the brush stroke.

4+ Wet Edges: Makes the brush stroke appear to be wet by creating a heav-
ier amount of color on the edges of the brush strokes.
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4+ Airbrush: Gives airbrush features to the Brush tools (CS3 no longer has
a standalone Airbrush tool as in previous versions of Photoshop). You
can also turn on the Airbrush feature by clicking the Airbrush button
and adjusting the pressure and flow on the Options bar.

If you click and hold with the Brush tool out on the image area, the paint
stops spreading. Turn on the Airbrush feature and notice that when you
click and hold, the paint keeps spreading, just like with a can of spray
paint. You can use the Flow slider on the Options bar to control the
pressure.

4+ Smoothing: Smoothes the path that you create with the mouse.

4+ Protect Texture: Preserves the texture pattern when applying brush
presets.

In addition to the preceding options, you can also adjust the jitter of the
brush. The jitter specifies the randomness of the brush attribute. At 0 per-
cent, an element doesn’t change over the course of a stroke; at 100 percent,
a stroke will totally vary from one attribute to another. For example, if you
select Other Dynamics in the Brushes palette and then change the Opacity
Jitter to 100 percent, the opacity will vary from 0 to 100 percent while you're
painting.

After going through all the available brush options, you may want to start
thinking about how you’ll apply the same attributes later. Saving the Brush
tool attributes is important as you increase in skill level.

The Clone Stamp Tool

The Clone Stamp tool is used for pixel-to-pixel cloning. It’s different from the
Healing Brush tool in that it does no automatic blending into the target area.

* You can use the Clone Stamp tool for removing a product name from an

image, replacing a telephone wire that is crossing in front of a building, or
duplicating an item.

Here’s how you use the Clone Stamp tool:

1. With the Clone Stamp tool selected, position the cursor over the area
that you want to clone and then Alt+click (Option+click on a Mac) to
define the clone source.

2. Position the cursor over the area where you want to paint the cloned
pixels and start painting.

Note the cross hair at the original sampled area, as shown in Figure 8-3.
As you're painting, the cross hair follows the pixels that you're cloning.
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Figure 8-3:
A cross hair
over the
source
shows what
you are
cloning.

<P When using the Clone Stamp tool for touching up images, it’s best to resam-
ple many times so as to not leave a seam where you replaced pixels. A good
clone stamper Alt+clicks (Option+clicks on a Mac) and paints many times
over until the retouching is complete.

The History Brush Tool

Choose Window=>History to see the History palette. You could work for
weeks playing around in the History palette, but this section gives you the
basics.

At the top of the History palette is a snapshot of the last saved version of
the image. Beside the snapshot is an icon noting that it’s the present History
state.

By default, when you paint with the History Brush tool, it will paint back to
F'f the way the image looked at the last saved version, but you can click the
empty square to the left of any state in the History palette to make it the
target for the History Brush tool.

--.‘
\\J

Use the History Brush tool to fix errors and add spunk to your images.

The Eraser Tool

You may not think of the Eraser tool as a painting tool, but it can be! When you
drag on the image with the Eraser tool, it rubs out pixels to the background
4 color. (Basically, it paints with the background color.) If you're dragging

with the Eraser tool on a layer, it rubs out pixels to reveal the layer’s trans-
parent background. (You can also think of the Eraser tool as painting with
transparency.)
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The Eraser tool uses all the same commands as the Brush tools. You can
make an eraser larger, softer, and more or less opaque. But even better,
follow these steps to use the Eraser tool creatively:

1. Open any color image and apply a filter.

For example, we chose Filter>Blur~>Gaussian Blur. In the Gaussian Blur
dialog box that appeared, we changed the blur to 5 and then clicked OK
to apply the Gaussian Blur filter.

2. Select the Eraser tool and press 5 to change it to 50 percent opacity.
You can also use the Opacity slider on the Options bar.

3. Hold down the Alt (Option on a Mac) key to paint back 50 percent of
the original image’s state before applying the filter; continue painting
in the same area to bring the image back to its original state!

The original sharpness of the image returns where you painted.

Holding down the Alt (Option on a Mac) key is the key command to erase to
the last saved version (or history state) of the image. This tool is incredible
for fixing little mistakes, or when you applied cool filters and you want to
bring back some of the original image.

The Gradient Tool

Choose the Gradient tool and click and drag across an image area to create a
gradient in the direction and length of the mouse motion. A short drag cre-
ates a short gradient; a long drag produces a smoother, longer gradient.

Using the Options bar, you can also choose the type of gradient that you
want: Linear, Radial, Angle, Reflected, or Diamond.

As a default, gradients are created using the current foreground and back-
ground colors. Click the arrow on the gradient button on the Options bar to
assign a different preset gradient.

To create a gradient, follow these steps:

1. Choose the Gradient tool and click the Gradient Editor button on the
Options bar.

The Gradient Editor dialog box appears. At the bottom of the gradient
preview, you see two or more stops. The stops are where new colors are
inserted into the gradient. They look like little house icons. Use the
stops on the top of the gradient slider to determine the opacity.



Figure 8-4:
Assigning
varying
amounts of
opacity
using the
stops on top
of the gra-
dient slider.
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2. Click a stop and click the color swatch to the right of the word Color
to open the color picker and assign a different color to the stop.

3. Click anywhere below the gradient preview to add more color stops.
4. Drag a color stop off the Gradient Editor dialog box to delete it.

5. Click on the top of the gradient preview to assign different stops with
varying amounts of opacity, as shown in Figure 8-4.

Gradient Editor E]%]

Mare: Cuslenn e

iGradient Type:  Sold v |
Smoothness: | 100 | » |%
G O i%
@ ]
Stops

Opaity: (100 [» |%  Location: | 100 |9

6. When you're finished editing the gradient, name it and then click the
New button.

The new gradient is added to the preset gradient choices.

7. To apply your gradient, drag across a selection or image using the
Gradient tool.

Blending Modes

You can use blending modes to add flair to the traditional opaque paint. Use
blending modes to paint highlights or shadows that allow details to show
through from the underlying image or to colorize a desaturated image.

You access the blending modes for paint tools from the Options bar.
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You really can’t get a good idea of how the blending mode will work with
the paint color and the underlying color until you experiment. (That’s what
multiple undos are for!) Alternatively, you can copy the image you want to
experiment with onto a new layer and hide the original layer; see Chapter 9
of this minibook for more about layers.

The following list describes the available blending modes:

+
+

+

+

Normal: Paints normally, with no interaction with underlying colors.

Dissolve: Gives a random replacement of the pixels, depending on the
opacity at any pixel location.

Behind: Edits or paints only on the transparent part of a layer.

Darken: Replaces only the areas that are lighter than the blend color.
Areas darker than the blend color don’t change.

Multiply: Creates an effect similar to drawing on the page with magic
markers. Also looks like colored film that you see on theatre lights.

Color Burn: Darkens the base color to reflect the blend color. If you're
using white, no change occurs.

Linear Burn: Looks at the color information in each channel and
darkens the base color to reflect the blending color by decreasing
the brightness.

Lighten: Replaces only the areas darker than the blend color. Areas
lighter than the blend color don’t change.

Screen: Multiplies the inverse of the underlying colors. The resulting
color is always a lighter color.

Color Dodge: Brightens the underlying color to reflect the blend color.
If you're using black, there is no change.

Linear Dodge: Looks at the color information in each channel and
brightens the base color to reflect the blending color by increasing the
brightness.

Overlay: Multiplies or screens the colors, depending on the base color.

Soft Light: Darkens or lightens the colors, depending on the blend color.
The effect is similar to shining a diffused spotlight on the artwork.

Hard Light: Multiplies or screens the colors, depending on the blend
color. The effect is similar to shining a harsh spotlight on the artwork.

Vivid Light: Burns or dodges the colors by increasing or decreasing the
contrast.
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4+ Linear Light: Burns or dodges the colors by decreasing or increasing the
brightness.

4+ Pin Light: Replaces the colors, depending on the blend color.

4+ Hard Mix: Paints strokes that have no effect with other Hard Mix paint
strokes. Use this mode when you want no interaction between the
colors.

4+ Difference: Subtracts either the blend color from the base color or the
base color from the blend color, depending on which has the greater
brightness value. The effect is similar to a color negative.

4+ Exclusion: Creates an effect similar to, but with less contrast than, the
Difference mode.

4+ Hue: Applies the hue (color) of the blend object onto the underlying
objects but keeps the underlying shading or luminosity intact.

4 Saturation: Applies the saturation of the blend color but uses the lumi-
nance and hue of the base color.

4+ Color: Applies the blend object’s color to the underlying objects but pre-
serves the gray levels in the artwork. This mode is great for tinting
objects or changing their colors.

4+ Luminosity: Creates a resulting color with the hue and saturation of the
base color and the luminance of the blend color. This mode is essentially
the opposite of the Color mode.

4+ Lighter Color: Compares the total of all channel values for the blend and
base color and displays the higher value color.

4+ Darker Color: Compares the total of all channel values for the blend and
base color and displays the lower value color.

Painting with color

This section provides an example of using the blending modes to change
and add color to an image. A great example of using a blending mode is tint-
ing a black-and-white (grayscale) image with color. You can’t paint color in
Grayscale mode, so follow these steps to add color to a black-and-white
image:

1. Open an image in any color mode and choose Image->"Mode->RGB.

2. If the image isn’t already a grayscale image, choose Image=>
Adjustments->Desaturate.

This feature makes it appear as though the image is black and white, but
you're still in a color mode with which you can apply color.
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3. Choose a painting tool (the Brush tool, for example) and, using the
Swatches palette, choose the first color that you want to paint with.

4. On the Options bar, select Color from the Mode drop-down list and
then use the Opacity slider to change the opacity to 50 percent.

You could also just type 5.
5. Start painting!

The Color blending mode is used to change the color of the pixels, while
keeping the underlying grayscale (shading) intact.

Another way to bring attention to a certain item in an RGB image (like those
cute greeting cards that have the single rose in color and everything else in
black and white) is to select the item you want to bring attention to. Choose
Select=>Modify=>Feather to soften the selection a bit (5 pixels is a good number
to enter in the Feather Radius text field). Then choose Select=Inverse.

Now with everything else selected, choose Image=>Adjustments=>Desaturate.
Everything else in the image looks black and white, except for the original
item that you selected.

Filling selections

If you have a definite shape that doesn’t lend itself to being painted, you can
fill it with color instead. Make a selection and choose Edit=Fill to access the
Fill dialog box. From the Use drop-down list, you can choose from the follow-
ing options to fill the selection: Foreground Color, Background Color, Color
(to open the color picker while in the Fill dialog box) Pattern, History, Black,
50% Gray, or White.

If you want to use an existing or saved pattern from the Brushes palette, you
can retrieve a pattern by selecting Pattern in the Fill dialog box as well.
Select History from the Use drop-down list to fill with the last version saved
or the history state.

If you would rather use the Paint Bucket tool, which fills based upon the tol-
erance set on the Options bar, it’s hidden in the Gradient tool.

To use the Paint Bucket tool to fill with the foreground color, simply click the
item that you want to fill. This technique isn’t as exact as using the Fill dialog
box, but it’s good for filling solid areas quickly.
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Saving Presets

All the Photoshop tools allow you to save presets so that you can retrieve
them from a list of presets. The following steps show you an example of
saving a Brush tool preset, but the same method can be used for all other
tools as well:

1.
2.

Choose a brush size, color, softness, or anything!
Click the Tool Preset Picker button on the left side of the Options bar.

The preset menu for that tool appears.

. Click the triangle in the upper-right corner to access the fly-out menu

and then choose New Tool Preset.

The New Tool Preset dialog box appears.

. Type a descriptive name in the Name text field (leave the Include

Color check box selected if you want the preset to also remember the
present color) and then click OK.

Your preset is created and saved.

. Access the preset by clicking the tool’s Preset Picker button and

choosing it from the tool’s Preset Picker list.

Each preset that you create is specific to the tool that it was created in, so
you can have a crop preset, an eraser preset, and so on. After you get in the
habit of saving presets, you’ll wonder how you ever got along without them!
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Chapter 9: Using Layers

In This Chapter

v Discovering layers

1~ Using type as a layer

v+ Implementing layer masks
» Organizing your layers

v+~ Using Smart Objects

v+~ Playing with layer effects

Layers are incredibly helpful in production. By using layers, you can
make realistic additions to an image that you can remove, edit, and con-
trol with blending modes and transparency. Unfortunately, to show you all
the features of layers goes beyond what we can cover in this chapter. This
chapter covers layer basics to get you started working with layers in
Photoshop. We show you how to create composite images using easy layer
features — just enough knowledge to get yourself into a pretty complex
mess of layers! Even if you're an experienced Photoshop user, read this
chapter to discover all sorts of neat key commands that can help you in
your workflow.

If you're a video professional, open some videos in Photoshop Extended
CS3. Photoshop Extended automatically creates a Movie layer, and using the
timeline, you can do pixel editing frame by frame!

A\
Have fun with layers and don’t worry if you mess up; you can always press
F12 to revert the image to the state it was in at the last time you saved it.

Creating and Working with Layers

Layers make creating composite images (images pieced together from many
other individual images) easy because you can separate individual elements
of the composite onto their own layers. Much like creating collages by cut-
ting pictures from magazines, you can mask out selections on one image and
place them on a layer in another image. When pixel information is on its
own layer, you can move it, transform it, correct its color, or apply filters
just to that layer, without disturbing pixel information on other layers.
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The best way to understand how to create and use layers is to, well, create
and use layers. The following steps show you how to create a new, layered
image:

1. Create a new document by choosing Filec>New.
The New dialog box appears.

2. Select Default Photoshop Size from the Preset Sizes drop-down list,
select the Transparent option from the Background Contents area,
and then click OK.

Because you selected the Transparent option, your image opens with an
empty layer instead of a white background layer. The image appears as a
checkerboard pattern, which signifies that it’s transparent.

If you don'’t like to see the default checkerboard pattern where there is
transparency, choose Edit>Preferences>Transparency And Gamut
(Photoshop=Preferences~>Transparency And Gamut on a Mac). In the
Preferences dialog box that appears, you can change the Grid Size drop-
down list to None to remove the checkerboard pattern entirely. If you
don’t want to totally remove the transparency grid, you can change the
size of the checkerboard pattern or change the color of the checkerboard.

When you open an existing document (say a photograph), this image
will be your background layer.

3. Create a shape on the new image.

For example, create a red square by using the Rectangular Marquee tool
to create a square selection; we then filled the selection with red by
double-clicking the Foreground color swatch, selecting a red from the
color picker, and clicking in the selection with the Paint Bucket tool
(hidden under the Gradient tool).

After you've selected the color, you can also use the key command
Alt+Delete (Option+Delete on a Mac) to fill the selected area with color.

4. To rename the layer, double-click the layer name (Layer 1) in the
Layers palette and type a short, descriptive name.

A good practice is to name your layers based on what they contain; for
this example, the layer was named the catchy name of “square.”

5. Create a new layer by Alt+clicking (Option+clicking on a Mac) the
New Layer button at the bottom of the Layers palette.

The New Layer dialog box appears.
6. Give your new layer a descriptive name and then click OK.

7. Create a shape on the new layer.



Figure 9-1:
The circle
overlaps the
square.
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We created a circle by using the Elliptical Marquee tool and filling the
selection with yellow.

The new shape can overlap the shape on the other layer, as shown in
Figure 9-1.
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Duplicating a layer

Perhaps you want to create a duplicate of a layer for your composite. This
technique can be helpful for do-it-yourself drop shadows, as well as adding
elements to an image, such as more apples in a bowl of fruit.

Alt+drag (Option+drag on a Mac) the square layer to the New Layer button
at the bottom of the Layers palette to duplicate it. Again, by holding down
Alt (Option on a Mac), you can name the layer as you create it.

Selecting a layer

When you start working with layers, you may find yourself moving or adjust-
ing pixels, only to discover that you accidentally edited pixels on the wrong
layer. Select the layer that you plan to work on by clicking the layer name in
the Layers palette.

Unlike previous versions of Photoshop, Photoshop CS3 represents a selected
layer by simply highlighting the layer in the Layer’s palette. Don’t bother
looking for an indicator paintbrush icon in this version.

Here are some tips to help you select the correct layer:
4 Select the Move tool and then right-click (Ctrl+click on a Mac) to see a

contextual menu listing all layers that have pixel data at the point you
clicked and to choose the layer that you want to work with.
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4 Get in the habit of holding down the Ctrl (88 on a Mac) key while using
the Move tool and when selecting layers. This technique temporarily
turns on the Auto Select feature, which automatically selects the top-
most visible layer that contains the pixel data that you clicked.

4+ Press Alt+[ (Option+[ on a Mac) to select the next layer down from the
selected layer in the stacking order.

4 Press Alt+] (Option+] on a Mac) to select the next layer up from the
selected layer in the stacking order.

Controlling the visibility of a layer

Hide layers that you don’t immediately need by clicking the eye icon in the
Layers palette. To see only one layer, Alt+click (Option+click on a Mac) the
eye icon of the layer you want to keep visible. Alt+click (Option+click on a
Mac) the eye icon again to show all layers.

Rearranging the stacking order

Layers are like clear pieces of film lying on top of each other. Change the
stacking order of the layers in the Layers palette by dragging a layer until
you see a black separator line appear, indicating that you're dragging the
layer to that location. You can also use these great commands to help you
move a layer:

Command Windows Shortcut Mac Shortcut
Move selected layer up Ctrl+] 38+]
Move selected layer down Ctrl+[ 8B+[

Creating a Text Layer

When you create text in Photoshop, the text is created on its own layer. By
having the text separate from the rest of your image, applying different
styles and blending modes to customize the type, as well as repositioning
the text, are simplified.

To create a text layer, choose the Type tool and click the image area. You
can also click and drag to create a text area. The Options bar, shown in
Figure 9-2, gives you the controls to change font, size, blending mode, and
color of the text.



Figure 9-2:
The Text
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Warping text

When you click the Create Warped Text button on the Options bar, the Warp
Text dialog box appears. This dialog box enables you to apply different types
of distortion to your text.

You can still edit text that has been warped. To remove a warp, click the
Create Warp Text button again and select None from the Style drop-down list.

Fine-tuning text

For controls such as leading, baseline shift, and paragraph controls, click the
Toggle The Character And Paragraph Palettes icon near the right end of the
Options bar.

Use the keyboard commands in Table 9-1 to build text in Photoshop. Make
sure that you have text selected when you use these shortcuts.

Table 9-1 Helpful Typesetting Key Commands
Function Windows Mac
Increase font size Shift+Ctrl+> Shift+88+>
Decrease font size Shift+Ctrl+< Shift+38+<
Increase kerning (cursor must be Alt+— Option+—
between two letters)

Decrease kerning (cursor must be Alt+— Option+«
between two letters)

Increase tracking (several letters Alt+— Option+—
selected)

Decrease tracking (several letters Alt+e— Option+<«
selected)

Increase or decrease leading Alt+T or Alt+l Option+T or Option+{

(several lines selected)
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To change the font, drag over the font family name on the Options bar and
then press the up-arrow key (1) to go up in the font list or the down-arrow
key (1) to go down in the font list.

After you're finished editing text, confirm or delete the changes by clicking
the buttons on the right of the Options bar.

If you’d rather use key commands to confirm or delete your changes, press
the Esc key to cancel text changes; press Ctrl+Enter (88+Return on a Mac) to
commit text changes (or use the Enter key on the numeric keypad).

Using Layer Masks

\\J

In this section, we show you how to create a layer mask from a selection or a
pen path. A layer mask covers up areas of the image that you want to make
transparent and exposes pixels that you want visible. Masks can be based
upon a selection that you’ve created with the selection tools, by painting on
the mask itself, or by using the Pen tool to create a path around the object
you want to keep visible.

Creating a layer mask from a selection

You need to have two images open to follow these steps where we show you
how to create layer masks from a selection:

1. When combining images, choose Image->Image Size to make sure that
the images are approximately the same resolution.
Otherwise, you may create some interesting, but disproportional, effects.

2. Using the Move tool, click one image and drag it to the other image
window.

A black border appears around the image area when dropping an image
into another image window. By dragging and dropping an image, you
automatically create a new layer on top of the active layer.

Hold down the Shift key when dragging one image to another to per-
fectly center the new image layer in the document window.

3. Using any selection method, select a part of the image that you want
to keep on the newly placed layer. Choose Select~> Modify- Feather to
soften the selection (5 pixels should be enough).

4. Click the Layer Mask button at the bottom of the Layers palette.

A mask is created off to the right of your layer, leaving only your selec-
tion visible, as shown in Figure 9-3.
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5. If you click the Layer thumbnail in the Layers palette, the mask
thumbnail shows corner edges, indicating that it is activated.
While the layer mask is active, you can paint on the mask.

6. Press D to return to the default black-and-white swatch colors in the
toolbox.

7. Select the Brush tool and paint black while the mask thumbnail is
selected to cover up areas of the image that you don’t want to see;
press X to switch to white and paint to expose areas on the image that
you do want to see.

You can even change the opacity as you paint to blend images in with
each other.
\\3

To create a smooth transition from one image to another, drag the Gradient
tool across the image while the layer mask is selected in the Layers palette.

Creating a vector mask from a pen path

A vector mask masks a selection, but it does so with the precision that you
can get only from using a path. The following steps show you another,
slightly more precise, way to create a layer mask by using a pen path:

1. Use the Pen tool and click from point to point to make a closed
pen path.

If you already have a path, choose Windows=>Paths and click a path to
select it.
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See Chapter 4 of this minibook for more about working with the Pen tool.

2. On the Layers palette, click the Layer Mask button and then click it
again.

Wow! A mask from your pen path! Anything that wasn’t contained within
the path is now masked out. Use the Direct Selection tool to edit the
path, if necessary.

If you no longer want vector mask, drag the thumbnail to the Trash icon in
the Layers palette. An alert dialog box appears, asking if you'd like to discard
the mask or apply it. Click the Discard button to revert your image back

to the way it appeared before applying the mask or click the Apply button to
apply the masked area.

Organizing Your Layers

As you advance in layer skills, you’ll want to keep layers named, neat, and in
order. In this section, we show you some tips to help you organize multiple
layers.

Activating multiple layers simultaneously

Select multiple layers simultaneously by selecting one layer and then Shift+
clicking to select additional layers. The selected layers are highlighted.
Selected layers will move and transform together, making repositioning and
resizing easier than activating each layer independently.

Select multiple layers to keep their relative positions to each other and take
advantage of alignment features. When you select two or more layers and
choose the Move tool, you can take advantage of alignment features on the
Options bar (see Figure 9-4). Select three or more layers for distribution
options.

New Auto-Align Layers tool

Ever have multiple shots of a group, one with the guy’s eyes shut, and the
girl looking the other way? Or maybe you like the smile in one better than in
another. Using the new auto-alignment feature, you can pull the best parts of
multiple images into one “best” image.

To use the new tool, simply have the Move tool active, select multiple layers,
and then click the Auto-Align Layers button to the right of the alignment
tools. The window you see in Figure 9-5 appears; make your selection and
click OK.



Organizing Your Layers 2 43

Align horizontal centers

Align Distribute
bottom bottom edges
Distribute | Distribute
Align top horizontal
Figure 9-4: top edges | centers
Align layers | | |
using the ‘ o == e
Move tool's | * "T I e
align
options. Align Align Distribute right edges Book Il
— Vertical | right b Chapter 9
centers Distribute left edges
Align left Distribute vertical centers
g
2.
(1=}
=
Auto-Align Layers %] 2
(1]
Hrojechio 1
_@';i " Z
Eh*—“ﬁ: [Caxdd ]
Ciperspective
Figure 9-5: ~ _

The new wm Koo}

Auto-Align O cyrukical

Layers e
add Bl

feature can

help create D Repasition Oy

a better

composite. T8 T

Layer groups

After you start using layers, you'll likely use lots of them, and your Layers
palette will become huge. If you find yourself scrolling to navigate from one
layer to another, take advantage of layer groups, which essentially act as fold-
ers that hold layers that you choose. Just like a folder you use for paper, you
can add, remove, and shuffle around the layers within a layer set. Use layer
sets to organize your layers and make the job of duplicating multiple layers
easier.
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To create a layer group, follow these steps:

1. After creating several layers, Shift+click to select the layers that you
want to group together in a set.

2. Choose New Group From Layers from the Layers palette menu, name
the group, and then click OK.

That’s it. You've created a layer group from your selected layers.

Pass through in the blending mode indicates that no individual blending
modes are changed. Using the Blending Mode drop-down list in the Layers
palette, you can change all the layers within a group to a specific blending
mode, or you can use the Opacity slider to change the opacity of all layers in
a group at once.

After you create a layer group, you can still reorganize layers within the
group or even drag in or out additional layers. You can open and close a
layer group with the arrow to the left of the set name.

Duplicating a layer group

After you've created a layer group, you may want to copy it. For example,
you may want to copy an image, such as a button created from several
layers topped off with a text layer. The most efficient way to make a copy of
that button is to create a layer group and copy the entire group. To copy an
image made up of several layers that aren’t in a layer group would require
you to individually duplicate each layer — how time-consuming!

To duplicate a layer group, follow these steps:

1. Select a group from the Layers palette.
2. From the palette menu, choose Duplicate Group.
The Duplicate Group dialog box appears.

3. For the destination, choose the present document or any open docu-
ment or create a new document.

Be sure to give the duplicated set a distinctive name!
4. Click OK.

Using Layer Styles

Layer styles are wonderful little extras that you can apply to layers to create
drop shadows, bevel and emboss effects, apply color overlays, gradients,
patterns and strokes, and more.
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Applying a style
To apply a layer style (for example, the drop shadow style, one of the most
popular effects) to an image, just follow these steps:

1. Create a layer on any image.

For example, you could create a text layer to see the effects of the layer
styles.

2. With the layer selected, click and hold the Layer Style button at the
bottom of the Layers palette; from the menu options, choose Drop
Shadow.

In the Layer Style dialog box that appears, you can choose to change the
blending mode, color, distance spread, and size of a drop shadow. You
should see it has already applied to your text. Position the cursor on the
image area and drag to visually adjust the position of the drop shadow.

3. When you’re happy with the drop shadow, click OK to apply it.

To apply another effect and change its options, click and hold the Layer
Style button in the Layers palette and choose the name of the layer style
from the menu that appears — Bevel And Emboss, for example. In the dialog
box that appears, change the settings to customize the layer style and click
OK to apply it to your image. For example, if you choose Bevel And Emboss
from the Layer Styles menu, you can choose from several emboss styles and
adjust the depth, size, and softness.

Here are some consistent items that you see in the Layer Style dialog box, no
matter what effect you choose:

4+ Contour: Use contours to control the shape and appearance of an effect.
Click the arrow to open the Contour fly-out menu to choose a contour
preset or click the contour preview to open the Contour Editor and
create your own edge.

4+ Angle: Drag the cross hair in the angle circle or enter a value in the
Angle text field to control where the light source comes from.

4+ Global light: If you aren’t smart about lighting effects on multiple
objects, global light will make it seem as though you are. Select the Use
Global Light check box to keep the angle consistent from one layer style
to another.

4+ Color: Whenever you see a color box, you can click it to select a color.
This color can be for the drop shadow, highlight, or shadow of an
emboss, or for a color overlay.
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Figure 9-6:
A text layer
with styles
applied and
the fill
reduced to
0 percent.

Creating and saving a style

If you come up with a combination of attributes that you like, click the New
Style button in the upper right of the Layer Style dialog box. Name the style,
and it’s now stored in the Styles palette. After you click OK, you can retrieve
the style at any time by choosing Windowr>Styles. If it helps, click the palette
menu button and choose either Small or Large List to change the Styles
palette to show only the name of the styles.

After you've applied a layer style to a layer, the style is listed in the Layers
palette. You can turn off the visibility of the style by turning off the eye icon
or even throw away the layer style by dragging it to the Layers palette’s
Trash icon.

Thinking about opacity versus fill

In the Layers palette, you have two transparency options, one for opacity
and one for fill. Opacity affects the opacity of the entire layer, including
effects. Fill, on the other hand, affects only the layer itself, but not layer
styles. Figure 9-6 shows what happens when the Bevel And Emboss style is
applied to text and the fill is reduced to 0 percent. It looks like the text was
embossed onto the image. You can do lots of neat stuff with the Layer Fill
feature!
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Smart, Really Smart! Smart Objects

Choose Filem>Place and place an image, illustration, or even a movie into a
Photoshop document and discover that, as always, a new layer is created,
but even better than that, a Smart Object is created. The icon in the lower
right of the layer thumbnail indicates that this layer is a Smart Object.



Figure 9-7:
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Merging and Flattening the Image

What does being a Smart Object mean? It means that you have much more
flexibility with the placement of your images. Have you ever placed a logo, to
find out later you need it to be three times the size? Resizing is no longer an
issue, as the Photoshop Smart Object is linked to an embedded original. If
the original is vector, you can freely resize the image over and over again
without worrying about poor resolution. Want to change the spelling of your
placed Illustrator logo? Just double-click the Smart Object, the embedded
original is opened right in Adobe Illustrator, make your changes and save the
file, and viola . . . it’s automatically updated in the Photoshop file.

What could be better than this? Smart filters, of course. You can apply Smart
filters to any Smart Object layer, or even convert a layer to use Smart Filters,
by choosing Filters=>Convert For Smart Filters. Once a layer has been con-
verted to a Smart Object, you can choose filters, any filters, and apply them
to the layer. If you want to paint out the effects of the filter on the layer,
simply paint with black on the Filter effects thumbnail. Paint with different
opacities of black and white to give an artistic feel to the Filter effect, as
shown in Figure 9-7. You can even turn off the filters by turning off the visibil-
ity on the Filter Effects thumbnail by clicking the eye icon to the left of the
Filter Effects Thumbnail.

|14 MG 3119.0PG @ 16.1% (Layer 0, Fillor

d2 4 Al 0%
» E T
+
- Smart Fiters
® Grache Pen
W Gausmian

Merging and Flattening the Image

Merging layers combines several selected layers into one layer. Flattening is
when you reduce all layers to one background layer. Layers can increase
your file in size, thereby also tying up valuable processing resources. To
keep file size down, you may choose to merge some layers or even flatten
the entire image down to one background layer.
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Merging

Merging layers is helpful when you no longer need every layer to be inde-
pendent, like when you have a separate shadow layer aligned to another
layer and don’t plan on moving it again, or when you combine many layers
to create a composite and want to consolidate it to one layer.

To merge layers (in a visual and easy way), follow these steps:

1. Turn on the visibility of only the layers that you want merged.
2. Choose Merge Visible from the Layers palette menu.

That’s it. The entire image isn’t flattened, but the visible layers are now
reduced to one layer.

To merge visible layers onto a target (selected) layer that you create while
keeping the visible layers independent, do the following: Create a blank layer
and select it. Hold down Alt (Option on a Mac) when choosing Merge Visible
from the palette menu.

Flattening

If you don’t have to flatten your image, don’t! Flattening your image reduces
all layers down to one background layer, which is necessary for certain file
formats, but after you flatten an image, you can’t take advantage of blending
options or reposition the layered items. (Read more about saving files in
Chapter 10 of this minibook.)

If you absolutely must flatten layers, keep a copy of the original, unflattened
document for additional edits in the future.

To flatten all layers in an image, choose Layer=Flatten Image or choose
Flatten Image from the palette menu on the Layers palette.



Chapter 10: Saving Photoshop
Images for Print and the Web

In This Chapter

+ Determining the correct file formats for saving
v+ Preparing your images for the Web

v+ Discovering the color table

A productive workflow depends on you choosing the proper format in
which to save your Photoshop files. Without the correct settings, your
file may not be visible to other applications, or you may delete valuable
components, such as layers or channels. This chapter provides you with the
necessary information to save the file correctly for both print and Web. We
cover the file format choices before moving on to the proper use of the Save
For Web & Devices feature (for saving in the GIF, JPEG, PNG, and WBMP file
formats).

Saving files in the correct file format is important not only for file size, but
in support of different Photoshop features, as well. If you're unsure about
saving in the right format, save a copy of the file, keeping the original in the
PSD format (the native Photoshop format). Photoshop alerts you automati-
cally when you choose a format in the Save As or the Save For Web &
Devices dialog box that doesn’t support Photoshop features. When you
choose a format that doesn’t support some of the features you've used,
such as channels or layers, a yield sign appears when a copy is being made.
It’s a good idea to save an original backup just in case you need to return to
the original file.

3

Choosing a File Format for Saving

When you choose Filer>Save for the first time (or you choose File>Save As
to save a different version of a file), you see at least 18 different file formats
that you can choose from in the Save As Type drop-down list. We don’t
cover each format in this chapter (some are specific to proprietary work-
flows), but we do show you which formats are best for the typical workflow
that you may face.



250 Choosing a File Format for Saving

Creating a PDF presentation

You can create a multipage PDF file or presen-
tation by using Adobe Bridge (choose
Filec>Browse). While in Adobe Bridge, choose
Toolst>Photoshop=>PDF Presentation. In the
PDF Presentation dialog box, use the Browse
button to choose the files that you want to add
to the Source list. You can Ctrl+click (88+click
on a Mac) to select multiple files and add them
to the Source list.

In the output options section, choose Multi-
Page or Presentation PDF. If you choose

Presentation, you're given the opportunity to
set up slide show options, such as timing and
transition effects.

Click Save, name the file, and click Save again.
The Save Adobe PDF dialog box appears. If you
want to see the PDF immediately, make sure
that you select the View PDF After Saving
check box, choose any other specific options
that you want for the PDF (see Book VII for
more specifics on PDF settings), and click OK.

SMBER

Wonderful and easy Photoshop PSD

If you're in an Adobe workflow (you’re using any Adobe products), you can

keep the image in the native Photoshop PSD format. By choosing this format,

transparency, layers, channels, and paths are all maintained and left intact
when placed in the other applications.

To maximize compatibility with previous versions of Photoshop and with
other applications, choose Edit=>Preferences=File Handling (Photoshopw

Preferences=File Handling on a Mac). Choose Always from the Maximize PSD

File Compatibility drop-down list. This choice saves a composite (flattened)
image along with the layers of your document.

Leaving the Maximize PSD File Compatibility drop-down list set to Always
creates a larger file. If file size is an issue, leave the drop-down list set to Ask,

and only use the feature when you need to open the Photoshop file in older

versions of Photoshop.

Photoshop EPS

Virtually every desktop application accepts the EPS (Encapsulated
PostScript) file format. The EPS format is used to transfer PostScript-
language artwork between various applications. It supports vector data,

duotones, and clipping paths.

When you choose to save in the EPS format, an EPS Options dialog box
appears. Leave the defaults and click OK.
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Alter the settings in the EPS Options dialog box only if you’re familiar with
custom printer calibration, or you need to save your image to a specific
screen ruling. Screen rulings (Ipi) are usually set in a page layout application,
such as Adobe InDesign or QuarkXPress.

Photoshop PDF

If compatibility is an issue, save your file in the Photoshop PDF (Portable
Document Format) format. PDF files are supported by more than a dozen
platforms when viewers use Acrobat or Adobe Reader. (Adobe Reader is
available for free at www.adobe . com.) What a perfect way to send pictures
to friends and family! Saving your file in the Photoshop PDF format supports
your ability to edit the image when you open the file by choosing File>Open
in Photoshop.

TIFF

TIFF (Tagged Image File Format) is a flexible bitmap image format that is sup-
ported by most image-editing and page-layout applications widely supported
by all printers. TIFF supports layers and channels, but it has a maximum size
of 4GB. We hope your files aren’t that large!

DCS

The Photoshop DCS (Desktop Color Separation) 1.0 and 2.0 formats are
versions of EPS that enable you to save color separations of CMYK or multi-
channel files. Some workflows require this format, but if you have imple-
mented spot color channels in your image, using the DCS file format is
required to maintain them.

Choose the DCS 2.0 format unless you received specific instructions to use
the DCS 1.0 format — for example, for reasons of incompatibility in certain
workflows.

for the Web and Devices

To access the maximum number of options for the GIF, JPEG, PNG, and
WBMP file formats, save your image by choosing File>Save For Web &
Devices. The Save For Web & Devices dialog box appears, which allows you
to optimize the image as you save it. This procedure may sound big, but it’s
just the process of making the image as small as possible while keeping it
visually pleasing.
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Figure 10-1:
Animage
with large
amounts of
solid color is
a good
candidate
for the GIF
file format.

Saving images for the Web is a give-and-take experience. You may find your-
self sacrificing perfect imagery to make the image small enough in size that
it can be downloaded and viewed quickly by users. Read the upcoming sec-
tions on GIF and JPG formats to see how you can best handle creating Web

images.

The following sections describe the differences between GIF, JPEG, PNG, and
WBMP. Choose the appropriate format based upon the type of image you're
saving.

Having the image size correct before you save the file for the Web is a good
practice. If you need to read up on resizing images, see Chapter 6 of this
minibook. But generally speaking, you want to resize the image to the right
pixel dimensions. Choose Filter->Sharpen~>Unsharp Mask to gain back some
of the detail lost when resizing the image and then save the image for the Web.

GIF

Supposedly, the way you pronounce GIF (Graphics Interchange Format) is
based on the type of peanut butter you eat. Is it pronounced like the peanut
butter brand (Jiff), or with a hard G, like gift? Most people seem to pro-
nounce it like gift (minus the T).

Use the GIF format if you have lots of solid color, such as a logo like the one
shown in Figure 10-1.

AGI

The GIF format is not lossy (it doesn’t lose data when the file is compressed
in this format), but it does reduce the file size by using a limited number of
colors in a color table. The lower the number of colors, the smaller the file
size. If you've ever worked in the Index color mode, you're familiar with this
process.
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Transparency is supported by the GIF file. But generally, GIFs don’t do a
good job with anything that needs smooth transitions from one color to
another because of its poor support of anti-aliasing. Anti-aliasing is the
method that Photoshop uses to smooth jagged edges. When pixels transition
from one color to another, Photoshop produces multiple color pixels to
evenly blend from one pixel to another.

Because anti-aliasing needs to create multiple colors for this effect, GIF files
are generally not recommended. In fact, when you reduce a GIF in size,
you’re more apt to see banding because the anti-aliasing can’t take place
with the limited number of colors available in the GIF format.

You can, of course, dramatically increase the number of colors to create a c::p'i';rl:o
smoother transition, but then you risk creating monster files that take for-
ever to download. T
D QD
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Saving a GIF ig>
When you choose Filem>Save for Web, you first see the available GIF format [y g.
options. The GIF options may be more clear to you if you have an image = 2
(with lots of solid color) open. §_-g

To save a file for the Web as a GIF, follow these steps:

1. Choose Filec>Save For Web & Devices.
The Save For Web & Devices dialog box appears.
2. At the top, click the 2-Up tab.

You see the original image on the left and the optimized image on the
right (or top and bottom, depending upon the proportions of your
image).

In the lower portion of the display, you see the original file size com-
pared to the optimized file size, as well as the approximate download
time. This time is important! Nobody wants to wait around for a Web
page to load; most people won’t wait more than ten seconds for the
entire Web page to appear, so try to keep an individual image’s down-
load time down to five seconds or less. Remember, all the images on a
page can add up to one monstrous wait time for the viewer!

Change the download speed by choosing from the Preview menu (it’s
the arrow on the upper-right side of the Save For Web & Devices dialog
box). The Preview menu isn’t labeled, so look for the ToolTip to appear
when you hover your cursor over the arrow icon.
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3. Choose GIF 32 No Dither from the Preset drop-down list.

You may see a change already. Photoshop supplies you with presets that
you can choose from, or you can customize and save your own.

4. Choose whether you want dithering applied to the image by selecting
an option from the Specify The Dither Algorithm drop-down list.

This choice is purely personal. Because you may be limiting colors,
Photoshop can use dithering to mix the pixels of the available colors to
simulate the missing colors. Many designers choose the No Dither
option.

Using the color table

When you save an image as a GIF using the Save For Web & Devices dialog
box, you see the color table for the image on the right side of the dialog box.
The color table is important because it not only allows you to see the colors
used in the image, but also enables you to customize the color table by using
the options at the bottom of the color table.

You may want to customize your color table by selecting some of your
colors to be Web safe and locking colors so that they’re not bumped off as
you reduce the amount of colors.

To customize a color table, follow these steps:

1. If your image has only a few colors that you'd like to convert to
Web-safe colors, choose the Eyedropper tool from the left of the Save
For Web & Devices dialog box and click the color, in the Optimized
view.

The sampled color is highlighted in the color table.
2. Click the Web Safe button at the bottom of the color table.

A ToolTip appears when you cross over this button with the text; Shifts/
Unshift selected colors to web palette.

A diamond appears, indicating that the color is now Web safe.

3. Lock colors that you don’t want to delete as you reduce the number of
colors in the color table.

Select a color with the Eyedropper tool or choose it in the color table
and then click the Lock Color button. A white square appears in the
lower-right corner, indicating that the color is locked.
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If you lock 32 colors and then reduce the color table to 24, some of your
locked colors will be deleted. If you choose to add colors, those locked
colors will be the first to return.

How is the color table created? Based upon a color reduction algorithm
method that you choose, the Save For The Web feature samples the
number of colors that you indicate. If keeping colors Web safe is impor-
tant, select the Restrictive (Web) option for the method; if you want
your image to look better on most monitors, but not necessarily be Web
safe, choose the Adaptive option.

4. Use the arrows to the right of the Colors combo box or enter a
number to add or delete colors from the color table.

5. If your image uses transparency, select the Transparency check box.

Remember that transparency is counted as one of your colors in the
color table.

6. Select the Interlaced check box only if your GIF image is large in size
(25K or larger).

Selecting this option causes the image to build in several scans on the

Web page, a low-resolution image that pops up quickly to be refreshed
with the higher resolution image when it’s finished downloading. Inter-
lacing gives the illusion of the download going faster but makes the file
size larger, so use it only if necessary.

7. Click Save.

Now the image is ready to be attached to an e-mail message or used in a
Web page.

JPEG

JPEG (Joint Photographic Experts Group) is the best format for continuous
tone images (those with smooth transitions from one color to another, as in
photographs), like the image shown in Figure 10-2.

The JPEG format is lossy, so you should not save a JPEG, open it, edit it, and
save it again as a JPEG. Because the JPEG compression causes data to be
lost, your image will eventually look like it was printed on a paper towel.
Save a copy of the file as a JPEG, keeping the original image in the PSD
format if you need to later edit the image, open the original PSD, make your
changes, save the PSD, and then save a copy of the edited file as a JPEG.

The JPEG format does not support transparency, but you can cheat the
system a little by using matting.
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Figure 10-2:
Images with
smooth
transitions
from one
color to
another
make good
candidates
for the JPEG
file format.

Color Table " image Lo

A good image to save in the JPEG format is a typical photograph or illustra-
tion with lots of smooth transitions from one color to the next. To save an
image as a JPEG, follow these steps:

1. Choose Filec>Save For Web & Devices and then click the 2-Up tab to
view the original image (left) at the same time as the optimized image
(right).

2. Choose one of the JPEG preset settings from the Settings drop-down
list.

You can choose Low, Medium, High, or customize a level in between the
presets by using the Quality slider.

3. Leave the Optimized check box selected to build the best JPEG at the
smallest size.

The only issue with leaving this check box selected is that some very old
browsers won'’t read the JPEG correctly. (This is probably not an issue
for most of your viewers.)

4. Deselect the ICC Profile check box unless you’re in a color-managed
workflow and color accuracy is essential.

Deselecting the ICC Profile check box dramatically increases the file size,
and most people aren’t looking for exact color matches from an image
on the monitor . . . and it’s scary if they are!
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5. Use the Blur slider to bring down some detail.

It’s funny, but one JPEG that’s the exact same pixel dimensions as
another may vary in file size because the more detailed an image, the
more information is needed. So an image of lots of apples will be larger
than an image the same size that has a lot of clear blue sky in it. The blur
feature does blur the image (surprise!), so you may want to use this for
only a Low Source image in Dreamweaver.

6. (Optional) Choose a matte color from the Matte drop-down list.

Because JPEG doesn’t support transparency, you can flood the transpar-
ent area with a color that you choose from the Matte drop-down list.
Choose the color that you're using for the background of your Web page
by choosing Other and entering the hexadecimal color in the lower por-
tion of the color picker.

7. Click Save.

PNG

PNG (Portable Network Graphics) is almost the perfect combination of JPEG
and GIF. Unfortunately, PNG isn’t yet widely supported . . . note, as well, that
PNG-24 images have file sizes that can be too large to use on the Web.

PNG supports varying levels of transparency and anti-aliasing. This variation
means that you can specify an image as being 50 percent transparent, and it
will actually show through to the underlying Web page! You have a choice of
PNG-8 and PNG-24 in the Save For Web & Devices dialog box. As a file format
for optimizing images, PNG-8 doesn’t give you any advantage over a regular
GIF file.

PNG files are not supported by all browsers. In older browsers, a plug-in may
be required to view your page. Ouch ... by choosing PNG, you could shoot
yourself in the foot because not all your viewers will be able to view the PNG.

If you're saving a PNG file, you have a choice of PNG-8 or PNG-24. The PNG-8
options are essentially the same as the GIF options; see the “Saving a GIF”
section, earlier in this chapter, for details.

PNG-24 saves 24-bit images that support anti-aliasing (the smooth transition
from one color to another). They work beautifully for continuous-tone images,
but are much larger than a JPEG file. The truly awesome feature of a PNG file
is that it supports 256 levels of transparency. In other words, you can apply
varying amounts of transparency in an image, as shown in Figure 10-3, where
the image shows through to the background.
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Figure 10-3:
A PNG-24
file with
varying
amounts of
trans-
parency.

Figure 10-4:
The WBMP
format
supports
black and
white only.
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WBMP is short for Wireless BitMap, a format optimized for mobile comput-
ing, has no compression, is one-bit color (just black and white, no shades!),
and is one bit deep. WBMP images aren’t necessary pretty, but functional
(see Figure 10-4). You do have dithering controls to show some level of tone
value.
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If you're creating images for mobile devices, you should know that WBMP is
part of the Wireless Application Protocol, Wireless Application Environment
Specification Version 1.1.
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Select the Preview In Default Browser check box at the bottom of the Save
For Web & Devices dialog box to launch your chosen Web browser and dis-
play the image as it will appear with the present settings. If you haven’t set
up a browser, click the down arrow and choose Other from the drop-down
menu. Browse to locate a browser that you want to preview your image in.

Want to see how your mobile content is going to look on specific devices?
Then click the Device Central button in the lower right of the Save For Web &
Devices dialog box.

Matte

Matting appears as a choice in the JPEG, GIF, and PNG format options.
Matting is useful if you don’t want ragged edges appearing around your
image. Matting looks for pixels that are greater than 50 percent transparent
and makes them fully transparent; any pixels that are 50 percent or less
transparent become fully opaque.

Even though your image might be on a transparent layer, there will be some
iffy pixels, the ones that aren’t sure what they want to be.. . . to be transpar-
ent or not to be transparent. Choose a matte color to blend in with the
transparent iffy pixels by selecting Eyedropper, White, Black, or Other (to
open the color picker) from the Matte drop-down list in the Save For Web &
Devices dialog box.

Settings

Whether you're saving a GIF, JPG, or PNG file, you probably spent some time
experimenting with settings to find what works best for your needs. Save
your selected options to reload at a later time by saving the settings. Do so
by clicking the arrow to the right of the Preset drop-down list. Choose Save
Settings from the menu that appears and give your settings a name. Your
named, customized settings then appear in the Settings drop-down list.
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Chapter 1: Introduction
to Fireworks CS3

In This Chapter

+ Understanding the power of Fireworks CS3

v Touring the Fireworks CS3 interface

1 Checking over your work with a preview
+ Creating a customized work environment
v Setting your preferences

v Getting help when you need it

Freworks CS3 is the latest version of a graphics creation and editing pro-
gram designed to streamline the process of making images for the Web.
In the days before the original version of Fireworks, making graphics for the
Web could be a frustrating and time-consuming process involving trial and
error. And the results often looked pretty bad.

With products such as Fireworks, all that has changed. This chapter gives
you a brief introduction and tour of the product and shows you how to set
up Fireworks to fit your working style.

Understanding the Power of Fireworks

You can divide the basic process of making graphics for a Web site into two
major parts:

4+ Creating the images: Drawing, importing, and manipulating pictures, as
well as designing the overall page layout on the Fireworks canvas

4+ Optimizing the images: Slicing the page layout into pieces, selecting the
proper compression format and level for each piece, and exporting the
individual pieces

Fireworks has two different tools that make the process of creating graphics
for a Web site easier: layers and slices. Layers are a mainstay of graphics
development tools, such as Photoshop and Illustrator, and of animation
programs, such as Adobe Flash. Layers make creating and editing graphics
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a simpler proposition. Slices, first introduced in the original version of Fire-
works, offer an efficient way to divide a design into individually optimized
Web graphics. You can read more about both layers and slices in the follow-
ing sections.

Making designing easier with layers

We discuss layers in more detail in Book III, Chapter 5, but this section
serves as an introduction to the benefits of layers.

Layers act like transparent sheets that you can stack, one on top of the other.
You draw a separate element of the image on each transparency. Any area
where you haven’t put something remains transparent, so layers beneath
show through. In a typical file, you may have several text layers and many
layers of backgrounds, icons, lines, shapes, and so on.

If you ever make mistakes or change your mind about overall layout, text, or
graphical elements, layers can save you much time as you design your site.
Suppose that you're painting watercolors on fine paper. If you mess up one
part of the image, you often ruin the whole thing because you have only one
layer to work with — the paper. Short of cutting a piece out of the paper, you
probably can’t delete your mistakes. Layers offer a more flexible approach to
creating and editing images.

Using layers provides many benefits. Some of the most practical advantages
include the following:

4+ You can change any element of your design — text, bitmap, or vector
shape — without altering or destroying any other element.

4+ You can apply effects to layers that are grouped together, decreasing the
amount of time needed to edit an image. (Of course, you can also apply
effects to individual layers.)

4+ You can easily move elements up and down in the stack of layers to
change the visual effect on the screen.

4+ You can test new designs and effects in a snap because you can very
easily hide and show elements of an image.

Creating slices

We discuss slices in more detail in Book IIl, Chapter 6, but here’s an introduc-
tion to the concept of slices. Imagine for a moment that you've created your
masterpiece design for a new Web site. Your Fireworks file may include a lot
of different kinds of imagery, such as the following:

4 Animations

4+ Drawings



Figure 1-1:
The Web
Layer and
slices.
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4 Header graphics, such as banners
4+ Logos

4+ Navigation buttons

4+ Photos

Before you can create your Web page, you have to get all these graphics into
a Web-friendly format, which is where slices come in. The idea is simple and
elegant: Include a special layer in the program that no one can ever remove,
in which you can create guides as to how you want the images to be “sliced”
into separate, individually optimized, and hyperlinked images. Figure 1-1
shows that special layer, called the Web Layer, and some slices in action,
including a slice with an attached behavior (see Book IIl, Chapter 7 for infor-
mation on behaviors).
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Slices provide some key advantages over outmoded methods of creating
images for the Web:

4+ You can slice a design into more than one image at a time.

4 You can export multiple files in a single procedure.

4+ You can control exactly where images are sliced, which helps prevent
you from making images with overlapping areas.
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4+ You have an increased ability to optimize image size (and thereby

reduce download time) by selecting the best optimization method for
each slice.

Slices guarantee that the layout of your Web page appears nearly identical
on every user’s screen to the design that you create in Fireworks. (If you
have HTML text on your page, the appearance of that text may vary, depend-
ing on which browser and platform the user views your page with.)

Taking a Quick Tour of the Fireworks Interface

The Fireworks interface is set up to make accessing the tools quick and intu-
itive. When you start Fireworks, it doesn’t create a new document automati-
cally; instead, you see the Start page, as Figure 1-2 shows. From the Start
page, you get one-click access to

4+ Create New: Click the Fireworks File link to open a new, blank image.

4+ Extend: Click the Fireworks Exchange link to browse to a part of the
Adobe Web site that includes a lot of free, cool, downloadable tools and
graphical elements created by users like you.
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3 Open T8 Frewors Document (Phic)

Extend
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4 Open a Recent Item: Just click the filename, or click the Open folder and
browse to a file to open the image in Fireworks.

4+ Information: Click the Getting Started link, the New Features link, or the
Resources link to view basic tips and tutorials. Or click the link to the
Fireworks Developer Center, where you can find tutorials, sample files,
and feedback from other Fireworks users.

If you don’t want the Start page to show up every time you launch Fireworks,
select the Don’t Show Again check box at the bottom-left corner of the page.

To create a new Fireworks file (called a PNG file), follow these steps:

1. Choose FilecoNew, or click the Fireworks File link on the Start page.
The New Document dialog box appears.

2. Choose the canvas size for your document in the New Document
dialog box.

The default width and height are 660 x 440 pixels (or the dimensions of
the previous file that you created in Fireworks), and the default resolu-
tion is 72 pixels per inch. You can enter your own size in the fields pro-
vided and change the unit of measurement by selecting one from the
drop-down list. Leave the resolution at 72 pixels per inch unless you're
designing for some medium other than the Web, such as print.

3. Select a color for the canvas.

The default canvas color is white, but you can choose a custom color by
selecting the Custom radio button and then using the eyedropper to
choose a color from the color picker. You can also choose to have a
transparent background by selecting the Transparent radio button.

4. Click OK to create your new Fireworks document.

When you click OK, your screen looks similar to Figure 1-3.

The Tools panel: A bird’s-eye view

The panels along the left side of the screen are parts of the Tools panel,
which provides access to all the tools that you use to make and modify your
graphics. The Tools panel divides tools into groups based on their function:

4+ Select: Contains tools used to select an object, as well as tools used to
crop or otherwise manipulate the canvas.
4+ Bitmap: Stores tools used to paint, draw, fill, and so on.

4+ Vector: Contains tools used to create and manipulate vector graphics.
(See Book IV for more on vector graphics.)
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Figure 1-3:
The default
Fireworks
CS3
interface.
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4+ Web: Holds tools, such as the Slice tool, that are designed specifically
for getting images ready for the Web.

4+ Colors: Stows away tools that control the color(s) of objects.

4+ View: Holds tools that you can use to change your view of the canvas or
the screen.

An arrow at the lower-right corner of a tool’s icon indicates that the tool has
one or more specialized variations. You can click the arrow to activate a pop-
up menu that displays icons for the available variations.

The Tools panel: A bug’s-eye view

This section gives you the lowdown on the tools that you probably use the
most in the Tools panel. A triangle (known as the flippy) at the bottom right
of the tool icon indicates that related tools are available. Click the icon or
the flippy and hold the mouse button down to activate a pop-up menu so
that you can choose from all the available tools. When you select a tool, you
can also cycle through the related tools by pressing certain keys on your
keyboard (for example, select the Marquee tool in the Bitmap section and
press M to toggle through the Marquee tool options). The tool tip for each
tool includes the key that you can press to cycle through the options on the
tool. You can activate the tool tip by hovering the mouse over the tool.
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You get to see the tools in action in various chapters of several of the mini-
books, but for now, here are the highlights for each of the four key cate-
gories of drawing tools:

4+ Select: The following four tools (clockwise from top left) make up the
Select section of the Tools panel:

Pointer/Select Behind tool: Use the Pointer tool to select objects on
the canvas by clicking them or clicking and dragging an area that
encompasses them. Use the Select Behind tool when you want to
click an object on the canvas that other objects cover.

Subselection tool: Use the Subselection tool to select an individual
object from a group.

Crop/Export Area tool: Click the Crop tool and click and drag to
select an area on the canvas to crop an image. When you crop an
image, you discard everything outside the selected area from your
image. After you have selected the area that you want to keep,
double-click inside the area to crop. Use the Export Area tool to
create a new image from the area that you select. After you have
selected the area you want to export, double-click inside the area to
bring up the Export Preview window.

Scale/Skew/Distort tool: This tool is inactive (as indicated by the
dimmed icon) until you select an object on the canvas. Click this tool
and click and drag the transform handles at the corners of the object
to change its size and/or shape.

4+ Bitmap: The following tools (clockwise from top left) make up the
Bitmap section of the Tools panel:

Marquee/Oval Marquee tool: Click the Marquee tool and click and
drag to select a rectangular area on the canvas. Hold down the shift
key while you click and drag to select a square area. If you want to
select an oval area, use the Oval Marquee variation (hold down the
shift key to select a perfect circle). When you select an area, you
select all objects that fall completely within the area.

Lasso/Polygon Lasso tool: Click the Lasso tool and click and drag on
the canvas to select an irregularly shaped area of the canvas. If the
shape you want to select is made up of straight lines, use the
Polygon Lasso.

Brush tool: Click this tool to paint on the canvas. See Book III,
Chapter 3 for more information about the very versatile Brush tool.

Eraser tool: Click the Eraser tool to erase a swath through any
bitmap object on the canvas. The Eraser tool doesn’t work with
vector objects in Fireworks.
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Rubber Stamp/Replace Color/Red Eye Removal tool: Click this tool
to copy a selected area of a bitmap to another spot on the canvas.
Alt+click the area that you want to copy (Opt+click on the Mac) and
then click and paint where you want the copy to go. Use the Replace
Color tool to swap one color for another wherever you click and
drag the Replace Color brush on the canvas. Simply click with the
Red Eye Removal tool to replace red with black wherever you click
the canvas; as you might guess from its name, this tool is designed to
fix that annoying byproduct of flash photography, red pupils.

Blur/Sharpen/Dodge/Burn/Smudge tools: Click the Blur tool and
click and drag on the canvas to soften the focus of an area of a bitmap
image. Use the Sharpen tool to bring a selected area into focus. Click
the Dodge tool and click and drag on the canvas to lighten an area of
a bitmap image. Click the Burn tool and click and drag to darken an
area of a bitmap image. Click the Smudge tool and click and drag on
the canvas to smear a part of an image into another part of the image,
as if you were finger painting. You can set the parameters for these
tools in the Property inspector (explained later in this chapter, in the
section “The Property inspector”).

Pencil tool: Click the Pencil tool and click and drag to draw single-
pixel-width bitmap lines. If you want control over the thickness and
texture of the line that you're creating, use the Brush tool.

Magic Wand tool: Click the Magic Wand and click a bitmap to select
neighboring areas of solid or similar colors in your image.

4 Vector: The following tools (clockwise from top left) make up the Vector
section of the Tools panel:

Line tool: Throw your ruler away! With the Line tool, you can draw a
straight line every time. You can adjust the line’s thickness, color,
and other parameters in the Property inspector.

Pen/Vector Path/Redraw Path tool: Click the Pen tool to create
vector graphics by drawing Beziér paths. You can use the Pen tool to
select points and let Fireworks connect the dots, or you can draw the
shape yourself with the Vector Path tool. You can use the Redraw
Path tool to change the shape of a vector graphic by clicking and
dragging any of the points that define the shape.

Text tool: Click this tool and click the canvas to place and edit text
on the canvas. See Book IlI, Chapter 3 for information on how to
make the most of the Text tool.

Knife tool: Click this tool and click and drag a line to cut vector
paths in two.

Freeform/Reshape Area/Path Scrubber (Additive)/Path Scrubber
(Subtractive) tool: Use the Freeform tool to reshape a vector path by
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pushing or pulling the stroke instead of moving the individual points
that define it. Use the Reshape Area tool to pull a vector path as if it
were taffy. If you have a graphics tablet, use the Path Scrubber tool
to change the color, thickness, and various other properties of the
vector path. You can set the properties to vary based on variations
in the pressure or speed that you use in drawing.

Rectangle/ Ellipse/Polygon/Auto Shape tool: Create vector shapes
by clicking these tools and clicking and dragging on the canvas.

4+ Web: The Web tools allow you to create and show or hide areas that can
be used as links on Web pages.

Rectangle/Circle/Polygon Hotspot tools: Use these tools to create
hotspots (linkable areas) without cutting up the underlying images in
“HTML and images” exports.

Slice/Polygon Slice tools: Use these tools to “slice” up your canvas
into individual images for export.

Hide Slices and Hotspots and Show Slices and Hotspots tools. Click
the tool on the bottom left of the Web section to hide the Web Layer
(the overlays that show where your slices and hotspots are). Click
the tool on the right to show the Web Layer.

4+ Colors: The Colors tools allow you to select and apply colors to lines,
objects, and anything else on your canvas.

Eyedropper tool: Click this handy tool to select a color from the
swatches in the color picker or from any object on the canvas by
clicking when you place the Eyedropper on the color that you want.

Paint Bucket/Gradient tool: Click this tool and then click a shape on
the canvas to fill the shape with a solid color (Paint Bucket) or gradi-
ent. For details about gradients, see Book IIl, Chapter 4.

The Stroke tool: Click the color box next to the pencil to choose a
stroke color. For more information on choosing colors, see Book III,
Chapter 3.

The Fill tool: Click the color box next to the paint bucket to choose a
fill color.

The Default Color button: Click it to give a black stroke and white fill
to a selected vector object (or to a vector object you're about to
create).

The “None” color button (a white square with a red slash): Click
this tool to delete the color of